summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2012-03-14 18:40:06 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2012-03-14 18:40:06 +0000
commit8ef45c109fe75f863cb685f83092123efe136b28 (patch)
treee28e321c238054fca31a60a462d9ba4b2aa53829 /dev-ruby
parentMarked ~hppa too. (diff)
downloadgentoo-2-8ef45c109fe75f863cb685f83092123efe136b28.tar.gz
gentoo-2-8ef45c109fe75f863cb685f83092123efe136b28.tar.bz2
gentoo-2-8ef45c109fe75f863cb685f83092123efe136b28.zip
Added dev-libs/libev to DEPEND and removed bundled libev. Added test.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/coolio/ChangeLog8
-rw-r--r--dev-ruby/coolio/coolio-1.1.0-r1.ebuild36
-rw-r--r--dev-ruby/coolio/files/coolio-1.1.0-libev.patch24
3 files changed, 67 insertions, 1 deletions
diff --git a/dev-ruby/coolio/ChangeLog b/dev-ruby/coolio/ChangeLog
index d897d0ebb438..f8c1f92d885c 100644
--- a/dev-ruby/coolio/ChangeLog
+++ b/dev-ruby/coolio/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/coolio
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/ChangeLog,v 1.1 2012/03/14 15:10:54 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/ChangeLog,v 1.2 2012/03/14 18:40:06 matsuu Exp $
+
+*coolio-1.1.0-r1 (14 Mar 2012)
+
+ 14 Mar 2012; MATSUU Takuto <matsuu@gentoo.org> +coolio-1.1.0-r1.ebuild,
+ +files/coolio-1.1.0-libev.patch:
+ Added dev-libs/libev to DEPEND and removed bundled libev. Added test.
*coolio-1.1.0 (14 Mar 2012)
diff --git a/dev-ruby/coolio/coolio-1.1.0-r1.ebuild b/dev-ruby/coolio/coolio-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..d2abdc03bff9
--- /dev/null
+++ b/dev-ruby/coolio/coolio-1.1.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/coolio/coolio-1.1.0-r1.ebuild,v 1.1 2012/03/14 18:40:06 matsuu Exp $
+
+EAPI="4"
+# iobuffer: -jruby -rbx
+USE_RUBY="ruby18 ruby19 ree18"
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+RUBY_FAKEGEM_NAME="cool.io"
+
+inherit ruby-fakegem
+
+MY_P="${RUBY_FAKEGEM_NAME}-${PV}"
+DESCRIPTION="A high performance event framework for Ruby which uses the libev C library"
+HOMEPAGE="http://coolio.github.com/"
+SRC_URI="http://rubygems.org/downloads/${MY_P}.gem"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libev"
+RDEPEND="${DEPEND}"
+
+ruby_add_rdepend ">=dev-ruby/iobuffer-1"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${P}-libev.patch" || die
+ rm -r Gemfile* ext/libev ext/cool.io/libev.c || die
+}
+
+each_ruby_compile() {
+ ${RUBY} -S rake compile || die
+}
diff --git a/dev-ruby/coolio/files/coolio-1.1.0-libev.patch b/dev-ruby/coolio/files/coolio-1.1.0-libev.patch
new file mode 100644
index 000000000000..e559667ef7c5
--- /dev/null
+++ b/dev-ruby/coolio/files/coolio-1.1.0-libev.patch
@@ -0,0 +1,24 @@
+diff -Naur coolio-1.1.0.orig/ext/cool.io/ev_wrap.h coolio-1.1.0/ext/cool.io/ev_wrap.h
+--- coolio-1.1.0.orig/ext/cool.io/ev_wrap.h 2012-03-15 03:30:08.755266522 +0900
++++ coolio-1.1.0/ext/cool.io/ev_wrap.h 2012-03-15 03:31:50.839378421 +0900
+@@ -4,5 +4,5 @@
+ # define FD_SETSIZE 2048 /* wishful thinking, as msvcrt6 [?] seems to only allow 512 fd's and 256 sockets max */
+ #endif
+
+-#include "../libev/ev.h"
++#include "ev.h"
+
+diff -Naur coolio-1.1.0.orig/ext/cool.io/extconf.rb coolio-1.1.0/ext/cool.io/extconf.rb
+--- coolio-1.1.0.orig/ext/cool.io/extconf.rb 2012-03-15 03:30:08.755266522 +0900
++++ coolio-1.1.0/ext/cool.io/extconf.rb 2012-03-15 03:31:04.114327009 +0900
+@@ -20,6 +20,10 @@
+ libs << "-lrt"
+ end
+
++if have_library('ev', 'ev_loop_new')
++ libs << "-lev"
++end
++
+ if have_header('sys/select.h')
+ $defs << '-DEV_USE_SELECT'
+ end