summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-01-13 06:39:58 +0000
committerHans de Graaff <graaff@gentoo.org>2015-01-13 06:39:58 +0000
commit8f1ccb9ab10e2dd4e4314a8df26b1f7a7fc557a8 (patch)
treed767c27da27a20fcfa534098ebdc2182725bf569 /dev-ruby
parentAdd ~arm keyword (diff)
downloadgentoo-2-8f1ccb9ab10e2dd4e4314a8df26b1f7a7fc557a8.tar.gz
gentoo-2-8f1ccb9ab10e2dd4e4314a8df26b1f7a7fc557a8.tar.bz2
gentoo-2-8f1ccb9ab10e2dd4e4314a8df26b1f7a7fc557a8.zip
Version bump.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/fast_gettext/ChangeLog9
-rw-r--r--dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild48
2 files changed, 55 insertions, 2 deletions
diff --git a/dev-ruby/fast_gettext/ChangeLog b/dev-ruby/fast_gettext/ChangeLog
index 940f319065c4..df82185929c7 100644
--- a/dev-ruby/fast_gettext/ChangeLog
+++ b/dev-ruby/fast_gettext/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/fast_gettext
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.28 2014/07/24 06:30:13 graaff Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/ChangeLog,v 1.29 2015/01/13 06:39:58 graaff Exp $
+
+*fast_gettext-0.9.2 (13 Jan 2015)
+
+ 13 Jan 2015; Hans de Graaff <graaff@gentoo.org> +fast_gettext-0.9.2.ebuild:
+ Version bump.
*fast_gettext-0.9.0 (24 Jul 2014)
diff --git a/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild b/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild
new file mode 100644
index 000000000000..56b0c9fcdfc8
--- /dev/null
+++ b/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/fast_gettext/fast_gettext-0.9.2.ebuild,v 1.1 2015/01/13 06:39:58 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG Readme.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="GetText but 3.5 x faster, 560 x less memory, simple, clean namespace (7 vs 34) and threadsave!"
+HOMEPAGE="https://github.com/grosser/fast_gettext"
+SRC_URI="https://github.com/grosser/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activerecord dev-ruby/protected_attributes dev-ruby/bundler )"
+
+all_ruby_prepare() {
+ rm Gemfile.lock || die
+
+ # Remove jeweler and bump from Gemfile since they are not needed for tests.
+ sed -i -e '/jeweler/d' -e '/bump/d' -e '/appraisal/d' Gemfile || die
+
+ # Avoid unneeded dependency on git and development dependencies.
+ sed -e '/git ls-files/ s:^:#:' \
+ -e '/\(wwtd\|bump\)/ s:^:#:' \
+ -i fast_gettext.gemspec || die
+
+ # Don't run a test that requires safe mode which we can't provide
+ # due to insecure directory settings for the portage dir. This spec
+ # also calls out to ruby which won't work with different ruby
+ # implementations.
+ sed -i -e '/can work in SAFE mode/,/^ end/ s:^:#:' spec/fast_gettext/translation_repository/mo_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Make sure the right ruby interpreter is used
+ sed -i -e "s:bundle exec ruby:bundle exec ${RUBY}:" spec/fast_gettext/vendor/*spec.rb || die
+}