summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-28 08:58:44 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-28 08:58:44 +0000
commit90c80126c278e44d5935603524f72ab165221fd2 (patch)
tree8ab7c3e41dce858da4e717d0c1977a215b2c51ba /dev-ruby
parent[bump] dev-perl/File-HomeDir-0.990.0 (diff)
downloadgentoo-2-90c80126c278e44d5935603524f72ab165221fd2.tar.gz
gentoo-2-90c80126c278e44d5935603524f72ab165221fd2.tar.bz2
gentoo-2-90c80126c278e44d5935603524f72ab165221fd2.zip
Version bump. Update patch to remove fix applied upstream.
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-inline/ChangeLog10
-rw-r--r--dev-ruby/ruby-inline/files/ruby-inline-3.11.1-ldflags.patch10
-rw-r--r--dev-ruby/ruby-inline/ruby-inline-3.11.1.ebuild53
3 files changed, 71 insertions, 2 deletions
diff --git a/dev-ruby/ruby-inline/ChangeLog b/dev-ruby/ruby-inline/ChangeLog
index 2661de061e76..d2ae673bcc58 100644
--- a/dev-ruby/ruby-inline/ChangeLog
+++ b/dev-ruby/ruby-inline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-inline
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.45 2011/12/25 07:24:08 graaff Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ChangeLog,v 1.46 2012/01/28 08:58:44 graaff Exp $
+
+*ruby-inline-3.11.1 (28 Jan 2012)
+
+ 28 Jan 2012; Hans de Graaff <graaff@gentoo.org> +ruby-inline-3.11.1.ebuild,
+ +files/ruby-inline-3.11.1-ldflags.patch:
+ Version bump. Update patch to remove fix applied upstream.
*ruby-inline-3.11.0 (25 Dec 2011)
diff --git a/dev-ruby/ruby-inline/files/ruby-inline-3.11.1-ldflags.patch b/dev-ruby/ruby-inline/files/ruby-inline-3.11.1-ldflags.patch
new file mode 100644
index 000000000000..e6856ac5a0d7
--- /dev/null
+++ b/dev-ruby/ruby-inline/files/ruby-inline-3.11.1-ldflags.patch
@@ -0,0 +1,10 @@
+--- lib/inline.rb.~1~ 2010-08-28 14:49:06.866480357 +0200
++++ lib/inline.rb 2010-08-28 15:05:14.553732182 +0200
+@@ -577,6 +577,7 @@
+ "-L#{Config::CONFIG['libdir']}",
+ '-o', so_name.inspect,
+ File.expand_path(src_name).inspect,
++ Config::CONFIG['LIBRUBYARG_SHARED'],
+ libs,
+ crap_for_windoze ].join(' ')
+
diff --git a/dev-ruby/ruby-inline/ruby-inline-3.11.1.ebuild b/dev-ruby/ruby-inline/ruby-inline-3.11.1.ebuild
new file mode 100644
index 000000000000..0ee33131f301
--- /dev/null
+++ b/dev-ruby/ruby-inline/ruby-inline-3.11.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-inline/ruby-inline-3.11.1.ebuild,v 1.1 2012/01/28 08:58:44 graaff Exp $
+
+EAPI=4
+
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RubyInline"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows to embed C/C++ in Ruby code"
+HOMEPAGE="http://www.zenspider.com/ZSS/Products/RubyInline/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+
+ruby_add_rdepend dev-ruby/zentest
+
+ruby_add_bdepend "
+ doc? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )
+ test? (
+ dev-ruby/hoe
+ dev-ruby/hoe-seattlerb
+ )"
+
+all_ruby_prepare() {
+ epatch "${FILESDIR}/${PN}-3.11.0-gentoo.patch"
+
+ # Respect ruby's (and thus Gentoo's) LDFLAGS, and explicitly link
+ # against the ruby shared library to avoid confusion and potential
+ # crashes when later using the shared object.
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc example.rb example2.rb demo/*.rb
+}