summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Legler <a3li@gentoo.org>2009-03-14 15:32:13 +0000
committerAlex Legler <a3li@gentoo.org>2009-03-14 15:32:13 +0000
commit9445758d041f087ae1759d0b3d4769327f46c109 (patch)
treefa1ce5ee3050967453a7a37ae57801c744a50cfe /dev-ruby
parentppc stable #256165 (diff)
downloadgentoo-2-9445758d041f087ae1759d0b3d4769327f46c109.tar.gz
gentoo-2-9445758d041f087ae1759d0b3d4769327f46c109.tar.bz2
gentoo-2-9445758d041f087ae1759d0b3d4769327f46c109.zip
Revbump to fix the 2.1 slot for bug 247549.
(Portage version: 2.2_rc25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/actionpack/ChangeLog8
-rw-r--r--dev-ruby/actionpack/actionpack-2.1.2-r1.ebuild25
-rw-r--r--dev-ruby/actionpack/files/2.1.2-csrf-circumvention.patch13
3 files changed, 45 insertions, 1 deletions
diff --git a/dev-ruby/actionpack/ChangeLog b/dev-ruby/actionpack/ChangeLog
index 117ffd6e4ae8..37e7201bdb3c 100644
--- a/dev-ruby/actionpack/ChangeLog
+++ b/dev-ruby/actionpack/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/actionpack
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.98 2009/01/10 16:30:20 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/ChangeLog,v 1.99 2009/03/14 15:32:13 a3li Exp $
+
+*actionpack-2.1.2-r1 (14 Mar 2009)
+
+ 14 Mar 2009; Alex Legler <a3li@gentoo.org>
+ +files/2.1.2-csrf-circumvention.patch, +actionpack-2.1.2-r1.ebuild:
+ Revbump to include patch for secbug #247549 for 2.1.2.
10 Jan 2009; Raúl Porcel <armin76@gentoo.org> actionpack-2.2.2.ebuild:
ia64 stable wrt #253425
diff --git a/dev-ruby/actionpack/actionpack-2.1.2-r1.ebuild b/dev-ruby/actionpack/actionpack-2.1.2-r1.ebuild
new file mode 100644
index 000000000000..a624a8c50821
--- /dev/null
+++ b/dev-ruby/actionpack/actionpack-2.1.2-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/actionpack/actionpack-2.1.2-r1.ebuild,v 1.1 2009/03/14 15:32:13 a3li Exp $
+
+inherit eutils ruby gems
+
+DESCRIPTION="Eases web-request routing, handling, and response."
+HOMEPAGE="http://rubyforge.org/projects/actionpack/"
+
+LICENSE="MIT"
+SLOT="2.1"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/ruby-1.8.5
+ =dev-ruby/activesupport-2.1.2"
+
+src_install() {
+ gems_src_install
+
+ # Patch for bug 247579.
+ # Yes, I know, but we cannot patch gems in a different way *yet*.
+ cd "${D}/$(gem18 env gemdir)/gems/${P}/lib" || die "cd failed"
+ epatch "${FILESDIR}/${PV}-csrf-circumvention.patch"
+}
diff --git a/dev-ruby/actionpack/files/2.1.2-csrf-circumvention.patch b/dev-ruby/actionpack/files/2.1.2-csrf-circumvention.patch
new file mode 100644
index 000000000000..a455b39f4635
--- /dev/null
+++ b/dev-ruby/actionpack/files/2.1.2-csrf-circumvention.patch
@@ -0,0 +1,13 @@
+Patch from upstream git (commit 099a98e9) to fix bug #247549.
+
+--- lib/action_controller/mime_type.rb.1
++++ lib/action_controller/mime_type.rb
+@@ -18,7 +18,7 @@
+ # end
+ class Type
+ @@html_types = Set.new [:html, :all]
+- @@unverifiable_types = Set.new [:text, :json, :csv, :xml, :rss, :atom, :yaml]
++ @@unverifiable_types = Set.new [:json, :csv, :xml, :rss, :atom, :yaml]
+ cattr_reader :html_types, :unverifiable_types
+
+ # A simple helper class used in parsing the accept header