summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-06-13 06:26:03 +0000
committerHans de Graaff <graaff@gentoo.org>2012-06-13 06:26:03 +0000
commit98fb909f85e7f60d92e69cabd898386e4af2cd0b (patch)
tree2053e0e130814dacc85612d35ce1f18f5ca02dae /dev-ruby
parentVersion bump for Rails 3.2.6. (diff)
downloadgentoo-2-98fb909f85e7f60d92e69cabd898386e4af2cd0b.tar.gz
gentoo-2-98fb909f85e7f60d92e69cabd898386e4af2cd0b.tar.bz2
gentoo-2-98fb909f85e7f60d92e69cabd898386e4af2cd0b.zip
Version bump for Rails 3.2.6.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/activerecord/ChangeLog7
-rw-r--r--dev-ruby/activerecord/activerecord-3.2.6.ebuild75
2 files changed, 81 insertions, 1 deletions
diff --git a/dev-ruby/activerecord/ChangeLog b/dev-ruby/activerecord/ChangeLog
index e83eb22c9dcd..cc6f3048b451 100644
--- a/dev-ruby/activerecord/ChangeLog
+++ b/dev-ruby/activerecord/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/activerecord
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.185 2012/06/01 07:06:38 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/ChangeLog,v 1.186 2012/06/13 06:26:03 graaff Exp $
+
+*activerecord-3.2.6 (13 Jun 2012)
+
+ 13 Jun 2012; Hans de Graaff <graaff@gentoo.org> +activerecord-3.2.6.ebuild:
+ Version bump for Rails 3.2.6.
*activerecord-3.2.5 (01 Jun 2012)
diff --git a/dev-ruby/activerecord/activerecord-3.2.6.ebuild b/dev-ruby/activerecord/activerecord-3.2.6.ebuild
new file mode 100644
index 000000000000..f28a46dedbb9
--- /dev/null
+++ b/dev-ruby/activerecord/activerecord-3.2.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/activerecord/activerecord-3.2.6.ebuild,v 1.1 2012/06/13 06:26:03 graaff Exp $
+
+EAPI=4
+USE_RUBY="ruby18 ruby19 ree18"
+
+# this is not null so that the dependencies will actually be filled
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="activerecord.gemspec"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="Implements the ActiveRecord pattern (Fowler, PoEAA) for ORM"
+HOMEPAGE="http://rubyforge.org/projects/activerecord/"
+SRC_URI="http://github.com/rails/rails/tarball/v${PV} -> rails-${PV}.tgz"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="mysql postgres sqlite3"
+
+RUBY_S="rails-rails-*/activerecord"
+
+ruby_add_rdepend "~dev-ruby/activesupport-${PV}
+ ~dev-ruby/activemodel-${PV}
+ >=dev-ruby/arel-3.0.2:3.0
+ >=dev-ruby/tzinfo-0.3.29
+ sqlite3? ( >=dev-ruby/sqlite3-ruby-1.3.5 )
+ mysql? ( >=dev-ruby/mysql2-0.3.10:0.3 )
+ postgres? ( >=dev-ruby/pg-0.11.0 )"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/bundler
+ ~dev-ruby/actionpack-${PV}
+ >=dev-ruby/sqlite3-ruby-1.3.5
+ >=dev-ruby/mocha-0.9.5
+ virtual/ruby-test-unit
+ )"
+
+all_ruby_prepare() {
+ # Remove items from the common Gemfile that we don't need for this
+ # test run. This also requires handling some gemspecs.
+ sed -i -e "/\(uglifier\|system_timer\|sdoc\|w3c_validators\|pg\|jquery-rails\|'mysql'\|journey\|ruby-prof\)/d" ../Gemfile || die
+ sed -i -e '/rack-ssl/d' ../railties/railties.gemspec || die
+ sed -i -e '/mail/d' ../actionmailer/actionmailer.gemspec || die
+
+ # Avoid tests depending on hash ordering
+ sed -i -e '/test_should_automatically_build_new_associated/,/ end/ s:^:#:' test/cases/nested_attributes_test.rb || die
+
+ # Avoid test depending on mysql adapter which we don't support for
+ # this Rails version to simplify our dependencies.
+ rm test/cases/connection_specification/resolver_test.rb || die
+}
+
+each_ruby_test() {
+ case ${RUBY} in
+ *jruby)
+ ;;
+ *rubyee18)
+ # Turn on travis support to avoid tripping bugs in ree18.
+ TRAVIS=true ${RUBY} -S rake test_sqlite3
+ ;;
+ *)
+ if use sqlite3; then
+ ${RUBY} -S rake test_sqlite3 || die "sqlite3 tests failed"
+ fi
+ ;;
+ esac
+}