summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-02-24 08:11:19 +0000
committerHans de Graaff <graaff@gentoo.org>2013-02-24 08:11:19 +0000
commitab25a5229fe42b69cff246060157e89dcabde7eb (patch)
tree5a91a0fa4b6bdd22d5c26ae40648395af43cd3c4 /dev-ruby
parentCleanup. (diff)
downloadgentoo-2-ab25a5229fe42b69cff246060157e89dcabde7eb.tar.gz
gentoo-2-ab25a5229fe42b69cff246060157e89dcabde7eb.tar.bz2
gentoo-2-ab25a5229fe42b69cff246060157e89dcabde7eb.zip
Cleanup.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-mocks/ChangeLog6
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild54
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.11.3.ebuild41
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild61
4 files changed, 5 insertions, 157 deletions
diff --git a/dev-ruby/rspec-mocks/ChangeLog b/dev-ruby/rspec-mocks/ChangeLog
index 7263d045d5eb..272f74954361 100644
--- a/dev-ruby/rspec-mocks/ChangeLog
+++ b/dev-ruby/rspec-mocks/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/rspec-mocks
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.51 2013/01/29 07:15:08 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/ChangeLog,v 1.52 2013/02/24 08:11:19 graaff Exp $
+
+ 24 Feb 2013; Hans de Graaff <graaff@gentoo.org> -rspec-mocks-2.6.0.ebuild,
+ -rspec-mocks-2.10.1.ebuild, -rspec-mocks-2.11.3.ebuild:
+ Cleanup.
*rspec-mocks-2.12.2 (29 Jan 2013)
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild
deleted file mode 100644
index a38364470c85..000000000000
--- a/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.10.1.ebuild,v 1.4 2013/01/15 05:43:28 zerochaos Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
-RUBY_S="rspec-${PN}-*"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-core-2.10.0:2
- dev-ruby/rspec-expectations:2
- )"
-
-# Not clear yet to what extend we need those (now)
-# >=dev-ruby/cucumber-0.6.2
-# >=dev-ruby/aruba-0.1.1"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- # This particular failure is reported to be fixed in jruby 1.6.
- ewarn "Tests disabled because they crash jruby."
- ;;
- *)
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -ryaml -S rspec spec || die
- ;;
- esac
-
- # There are features but they require aruba which we don't have yet.
-}
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.11.3.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.11.3.ebuild
deleted file mode 100644
index 9dc8998bca5e..000000000000
--- a/dev-ruby/rspec-mocks/rspec-mocks-2.11.3.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.11.3.ebuild,v 1.3 2013/01/15 05:43:28 zerochaos Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18 ruby19 jruby"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-SRC_URI="https://github.com/rspec/${PN}/tarball/v${PV} -> ${P}-git.tgz"
-RUBY_S="rspec-${PN}-*"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/rspec-core-2.10.0:2
- dev-ruby/rspec-expectations:2
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-}
-
-each_ruby_test() {
- RUBYOPT="${RUBYOPT} -ryaml" each_fakegem_test
-}
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
deleted file mode 100644
index bf10832a0a7d..000000000000
--- a/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-mocks/rspec-mocks-2.6.0.ebuild,v 1.12 2013/01/15 05:45:34 zerochaos Exp $
-
-EAPI=2
-USE_RUBY="ruby18 ree18 jruby"
-
-RUBY_FAKEGEM_TASK_TEST="none"
-
-RUBY_FAKEGEM_TASK_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="http://rspec.rubyforge.org/"
-
-LICENSE="MIT"
-SLOT="2"
-KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-# cucumber and rspec-core are loaded unconditionally in the Rakefile,
-# so we also need to require them for USE=doc.
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-core-2.6.0:2
- dev-ruby/rspec-expectations:2
- )
- doc? ( dev-ruby/rspec-core:2 )"
-
-# Not clear yet to what extend we need those (now)
-# >=dev-ruby/cucumber-0.6.2
-# >=dev-ruby/aruba-0.1.1"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm Gemfile || die
-}
-
-all_ruby_compile() {
- if use doc ; then
- RUBYLIB="${S}/lib" rake rdoc || die
- fi
-}
-
-each_ruby_test() {
- case ${RUBY} in
- *jruby)
- # This particular failure is reported to be fixed in jruby 1.6.
- ewarn "Tests disabled because they crash jruby."
- ;;
- *)
- PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -S rake spec || die
- ;;
- esac
-
- # There are features but they require aruba which we don't have yet.
-}