summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2013-11-18 03:03:34 +0000
committerManuel Rüger <mrueg@gentoo.org>2013-11-18 03:03:34 +0000
commitae5e96f879b8c1916fe48379e6b1351feb20c329 (patch)
tree6fd1262bd35dbd9c80d959eb3920c9e1980e3ff5 /dev-ruby
parentfixing bug 490838 (diff)
downloadgentoo-2-ae5e96f879b8c1916fe48379e6b1351feb20c329.tar.gz
gentoo-2-ae5e96f879b8c1916fe48379e6b1351feb20c329.tar.bz2
gentoo-2-ae5e96f879b8c1916fe48379e6b1351feb20c329.zip
Version bump. Add ruby20 target. ppc64 keyword dropped. Rekeywording in bug #465948
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/listen/ChangeLog8
-rw-r--r--dev-ruby/listen/listen-1.3.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-ruby/listen/ChangeLog b/dev-ruby/listen/ChangeLog
index 7c2374cd1c34..8212f80c3427 100644
--- a/dev-ruby/listen/ChangeLog
+++ b/dev-ruby/listen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/listen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/ChangeLog,v 1.23 2013/07/27 22:11:23 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/ChangeLog,v 1.24 2013/11/18 03:03:34 mrueg Exp $
+
+*listen-1.3.1 (18 Nov 2013)
+
+ 18 Nov 2013; Manuel Rüger <mrueg@gentoo.org> +listen-1.3.1.ebuild:
+ Version bump. Add ruby20 target. ppc64 keyword dropped. Rekeywording in bug
+ #465948
27 Jul 2013; Agostino Sarubbo <ago@gentoo.org> listen-0.7.3.ebuild:
Stable for x86, wrt bug #477478
diff --git a/dev-ruby/listen/listen-1.3.1.ebuild b/dev-ruby/listen/listen-1.3.1.ebuild
new file mode 100644
index 000000000000..125daf279ca2
--- /dev/null
+++ b/dev-ruby/listen/listen-1.3.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/listen/listen-1.3.1.ebuild,v 1.1 2013/11/18 03:03:33 mrueg Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ruby20 jruby"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Listens to file modifications and notifies you about the changes."
+HOMEPAGE="https://github.com/guard/listen"
+SRC_URI="https://github.com/guard/listen/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x64-macos"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rb-inotify-0.9.0"
+
+all_ruby_prepare() {
+ sed -i -e '/[Cc]overalls/d' spec/spec_helper.rb || die
+ # Drop failing test
+ sed -i -e '/#85/,+17d' spec/listen/directory_record_spec.rb || die
+}