summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-06-16 09:13:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-06-16 09:13:40 +0000
commitbd070714028c7a88caa9526e09e0f8b772e0d3ed (patch)
tree500ad9a83fb7c62f9a6a764f5282437ce26e7a49 /dev-ruby
parentFixed utp related build issue reported in bug #368523, thank jhdtl for report... (diff)
downloadgentoo-2-bd070714028c7a88caa9526e09e0f8b772e0d3ed.tar.gz
gentoo-2-bd070714028c7a88caa9526e09e0f8b772e0d3ed.tar.bz2
gentoo-2-bd070714028c7a88caa9526e09e0f8b772e0d3ed.zip
Version bump. Add ree18.
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/narray/ChangeLog9
-rw-r--r--dev-ruby/narray/narray-0.5.9_p9.ebuild56
2 files changed, 63 insertions, 2 deletions
diff --git a/dev-ruby/narray/ChangeLog b/dev-ruby/narray/ChangeLog
index 28a57cbdb1e9..59381195b421 100644
--- a/dev-ruby/narray/ChangeLog
+++ b/dev-ruby/narray/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/narray
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.41 2010/05/18 12:47:59 flameeyes Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/ChangeLog,v 1.42 2011/06/16 09:13:40 graaff Exp $
+
+*narray-0.5.9_p9 (16 Jun 2011)
+
+ 16 Jun 2011; Hans de Graaff <graaff@gentoo.org> +narray-0.5.9_p9.ebuild:
+ Version bump. Add ree18.
18 May 2010; Diego E. Pettenò <flameeyes@gentoo.org>
narray-0.5.9_p7.ebuild:
diff --git a/dev-ruby/narray/narray-0.5.9_p9.ebuild b/dev-ruby/narray/narray-0.5.9_p9.ebuild
new file mode 100644
index 000000000000..3a0f6817750e
--- /dev/null
+++ b/dev-ruby/narray/narray-0.5.9_p9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/narray/narray-0.5.9_p9.ebuild,v 1.1 2011/06/16 09:13:40 graaff Exp $
+
+EAPI=2
+
+# jruby → native extension
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog README.en README.ja SPEC.en SPEC.ja"
+
+RUBY_FAKEGEM_VERSION="${PV/_p/.}"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Numerical N-dimensional Array class"
+HOMEPAGE="http://www.ir.isas.ac.jp/~masa/ruby/index-e.html"
+SRC_URI="mirror://rubyforge/${PN}/${P/_/}.tar.gz"
+
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE=""
+
+S="${WORKDIR}/${P/_/}"
+
+all_ruby_prepare() {
+ # the tests aren't really written to be a testsuite, so the
+ # failure cases will literally fail; ignore all of those ad
+ # instead expect that the rest won't fail.
+ sed -i -e '/[fF]ollowing will fail/,$ s:^:#:' \
+ "${S}"/test/*.rb || die "sed failed"
+}
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed"
+ cp -l ${PN}.so lib || die "copy of ${PN}.so failed"
+}
+
+each_ruby_test() {
+ for unit in test/*; do
+ # Skip over the FFTW test because it needs a package we don't
+ # have in tree.
+ [[ ${unit} == test/testfftw.rb ]] && continue
+
+ ${RUBY} -Ilib ${unit} || die "test ${unit} failed"
+ done
+}