summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-09 15:47:46 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-09 15:47:46 +0000
commitdda5ca44e1d928658e2497eab25b338ed4f7d665 (patch)
tree09a033abe14cdaa1983ad0f6f6705ec48d56e6fc /dev-ruby
parentInitial import. New dependency of dev-ruby/haml. (diff)
downloadgentoo-2-dda5ca44e1d928658e2497eab25b338ed4f7d665.tar.gz
gentoo-2-dda5ca44e1d928658e2497eab25b338ed4f7d665.tar.bz2
gentoo-2-dda5ca44e1d928658e2497eab25b338ed4f7d665.zip
Add dependency on dev-ruby/fssm. This was mandatory but not noticed due to it being vendored. Fixes bug 350846. Dropped keywords for ppc,ppc64,x86: bug 351212.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/haml/ChangeLog9
-rw-r--r--dev-ruby/haml/haml-3.0.25-r1.ebuild42
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ruby/haml/ChangeLog b/dev-ruby/haml/ChangeLog
index 5fc5571f7f68..9a457b955b68 100644
--- a/dev-ruby/haml/ChangeLog
+++ b/dev-ruby/haml/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/haml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.59 2011/01/02 10:05:32 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/ChangeLog,v 1.60 2011/01/09 15:47:46 graaff Exp $
+
+*haml-3.0.25-r1 (09 Jan 2011)
+
+ 09 Jan 2011; Hans de Graaff <graaff@gentoo.org> +haml-3.0.25-r1.ebuild:
+ Add dependency on dev-ruby/fssm. This was mandatory but not noticed due to
+ it being vendored. Fixes bug 350846. Dropped keywords for ppc,ppc64,x86:
+ bug 351212.
*haml-3.0.25 (02 Jan 2011)
diff --git a/dev-ruby/haml/haml-3.0.25-r1.ebuild b/dev-ruby/haml/haml-3.0.25-r1.ebuild
new file mode 100644
index 000000000000..611c33f7ddde
--- /dev/null
+++ b/dev-ruby/haml/haml-3.0.25-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/haml/haml-3.0.25-r1.ebuild,v 1.1 2011/01/09 15:47:46 graaff Exp $
+
+EAPI=2
+
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_TASK_DOC="doc"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING README.md"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb VERSION VERSION_NAME vendor"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HAML - a ruby web page templating engine"
+HOMEPAGE="http://haml-lang.com/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# TODO: haml has some emacs modes that it could be installing, in case
+IUSE=""
+
+# The html engine requires hpricot
+ruby_add_rdepend "dev-ruby/hpricot dev-ruby/fssm"
+
+# It could use merb during testing as well, but it's not mandatory
+ruby_add_bdepend "
+ test? (
+ virtual/ruby-test-unit
+ dev-ruby/erubis
+ dev-ruby/rails
+ dev-ruby/ruby_parser
+ )
+ doc? (
+ dev-ruby/yard
+ dev-ruby/maruku
+ )"