summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-05-31 06:10:03 +0000
committerHans de Graaff <graaff@gentoo.org>2010-05-31 06:10:03 +0000
commite235acc209f72c91fba2c2fae059dc7d9f8b107a (patch)
tree4aa9e25ed3ee8eaab2d8646a9b04eeaa39a9e84a /dev-ruby
parentBump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded dependency. (diff)
downloadgentoo-2-e235acc209f72c91fba2c2fae059dc7d9f8b107a.tar.gz
gentoo-2-e235acc209f72c91fba2c2fae059dc7d9f8b107a.tar.bz2
gentoo-2-e235acc209f72c91fba2c2fae059dc7d9f8b107a.zip
Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded dependency.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rails/ChangeLog8
-rw-r--r--dev-ruby/rails/rails-2.3.8.ebuild80
2 files changed, 87 insertions, 1 deletions
diff --git a/dev-ruby/rails/ChangeLog b/dev-ruby/rails/ChangeLog
index fb0868f0e858..62aca89677d1 100644
--- a/dev-ruby/rails/ChangeLog
+++ b/dev-ruby/rails/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rails
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.174 2010/05/23 11:03:14 a3li Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/ChangeLog,v 1.175 2010/05/31 06:10:03 graaff Exp $
+
+*rails-2.3.8 (31 May 2010)
+
+ 31 May 2010; Hans de Graaff <graaff@gentoo.org> +rails-2.3.8.ebuild:
+ Bump for Rails 2.3.8. Drop ppc/ppc64 keywords due to new unkeyworded
+ dependency.
*rails-2.3.5-r3 (23 May 2010)
diff --git a/dev-ruby/rails/rails-2.3.8.ebuild b/dev-ruby/rails/rails-2.3.8.ebuild
new file mode 100644
index 000000000000..67bd6d0ab34d
--- /dev/null
+++ b/dev-ruby/rails/rails-2.3.8.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rails/rails-2.3.8.ebuild,v 1.1 2010/05/31 06:10:03 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ree18"
+
+RUBY_FAKEGEM_EXTRAINSTALL="builtin configs doc dispatches environments fresh_rakefile helpers html README"
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+# gem lacks tests
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="ruby on rails is a web-application and persistance framework"
+HOMEPAGE="http://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="2.3"
+KEYWORDS="~amd64 ~ia64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-rails-0.15"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.3
+ ~dev-ruby/activerecord-${PV}
+ ~dev-ruby/activeresource-${PV}
+ ~dev-ruby/activesupport-${PV}
+ ~dev-ruby/actionmailer-${PV}
+ ~dev-ruby/actionpack-${PV}"
+ruby_add_bdepend "
+ doc? ( dev-ruby/redcloth )
+ test? ( dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -i -e '/horo/d' Rakefile || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ # fails for missing template when using the gem distribution
+ #if use doc; then
+ # pushd guides
+ # ruby rails_guides.rb || die "guide generation failed"
+ # popd
+ #fi
+}
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rails rails-${PV}
+
+ if use doc; then
+ #pushd guides/output
+ #docinto guides
+ #dohtml -r *
+ #popd
+
+ pushd doc
+ docinto api
+ dohtml -r *
+ popd
+ fi
+}
+
+pkg_postinst() {
+ elog "To select between slots of rails, use:"
+ elog "\teselect rails"
+
+ eselect rails update
+}
+
+pkg_postrm() {
+ eselect rails update
+}