summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2009-07-16 08:53:04 +0000
committerHans de Graaff <graaff@gentoo.org>2009-07-16 08:53:04 +0000
commite4690a6f5e878533959188eb6efaac257ac15770 (patch)
tree0e3a51a7ff4342a56f5827282284ec297bce3945 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-e4690a6f5e878533959188eb6efaac257ac15770.tar.gz
gentoo-2-e4690a6f5e878533959188eb6efaac257ac15770.tar.bz2
gentoo-2-e4690a6f5e878533959188eb6efaac257ac15770.zip
Version bump.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ruby-gnomeprintui/ChangeLog10
-rw-r--r--dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.0.ebuild25
2 files changed, 33 insertions, 2 deletions
diff --git a/dev-ruby/ruby-gnomeprintui/ChangeLog b/dev-ruby/ruby-gnomeprintui/ChangeLog
index 7796366e6432..a3e446ae60de 100644
--- a/dev-ruby/ruby-gnomeprintui/ChangeLog
+++ b/dev-ruby/ruby-gnomeprintui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/ruby-gnomeprintui
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnomeprintui/ChangeLog,v 1.11 2008/12/09 14:30:07 fmccor Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnomeprintui/ChangeLog,v 1.12 2009/07/16 08:53:04 graaff Exp $
+
+*ruby-gnomeprintui-0.19.0 (16 Jul 2009)
+
+ 16 Jul 2009; Hans de Graaff <graaff@gentoo.org>
+ +ruby-gnomeprintui-0.19.0.ebuild:
+ Version bump for ruby-gnome2 0.19.0.
09 Dec 2008; Ferris McCormick <fmccor@gentoo.org>
ruby-gnomeprintui-0.16.0.ebuild:
diff --git a/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.0.ebuild b/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.0.ebuild
new file mode 100644
index 000000000000..aecfe84197ba
--- /dev/null
+++ b/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gnomeprintui/ruby-gnomeprintui-0.19.0.ebuild,v 1.1 2009/07/16 08:53:04 graaff Exp $
+
+inherit ruby ruby-gnome2
+
+DESCRIPTION="Ruby bindings for gnomeprintui"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE=""
+USE_RUBY="ruby18"
+DEPEND=">=gnome-base/libgnomeprintui-2.8
+ dev-util/pkgconfig"
+RDEPEND=">=gnome-base/libgnomeprintui-2.8
+ >=dev-ruby/ruby-gnomeprint-${PV}
+ >=dev-ruby/ruby-gtk2-${PV}"
+
+# Needed to generate rblibgnomeprintversion.h
+src_compile() {
+ cd "${WORKDIR}"/ruby-gnome2-all-${PV}/gnomeprint
+ ruby extconf.rb || die "ruby-libgnomeprint's extconf.rb failed"
+
+ cd "${WORKDIR}"/ruby-gnome2-all-${PV}/gnomeprintui
+ ruby extconf.rb || die "ruby-libgnomeprintui's extconf.rb failed"
+ emake CC=${CC:-gcc} CXX=${CXX:-g++} || die "emake failed"
+}