summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
committerJerry Alexandratos <jerry@gentoo.org>2000-11-17 08:22:05 +0000
commite9e5400092458ce2ac5e8e8e392f09fdfc7bcde8 (patch)
tree28014ea8be64a846251a7462553db444823ad771 /dev-ruby
parentInitial import of Ruby, the OO scripting lang, into the portage tree. (diff)
downloadgentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.gz
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.tar.bz2
gentoo-2-e9e5400092458ce2ac5e8e8e392f09fdfc7bcde8.zip
Initial import of a slew or Ruby modules. This is the base for
generating RD (similar to Perl's POD) files. Hey, we might as well start with the ability to document the code we write. 8) The modules installed are: amstd -- standard libraries for Ruby optparse -- an option parser racc -- lexical parser strscan -- fast string formatter/scanner rdtool -- RD doc formatter
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/amstd/amstd-1.9.5.ebuild25
-rw-r--r--dev-ruby/amstd/files/digest-amstd-1.9.51
-rw-r--r--dev-ruby/optparse/files/digest-optparse-0.7.51
-rw-r--r--dev-ruby/optparse/optparse-0.7.5.ebuild27
-rw-r--r--dev-ruby/racc/files/digest-racc-1.2.41
-rw-r--r--dev-ruby/racc/racc-1.2.4.ebuild26
-rw-r--r--dev-ruby/rdtool/files/digest-rdtool-0.6.61
-rw-r--r--dev-ruby/rdtool/rdtool-0.6.6.ebuild31
-rw-r--r--dev-ruby/strscan/files/digest-strscan-0.5.81
-rw-r--r--dev-ruby/strscan/strscan-0.5.8.ebuild26
10 files changed, 140 insertions, 0 deletions
diff --git a/dev-ruby/amstd/amstd-1.9.5.ebuild b/dev-ruby/amstd/amstd-1.9.5.ebuild
new file mode 100644
index 000000000000..0a4d29a6569b
--- /dev/null
+++ b/dev-ruby/amstd/amstd-1.9.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/amstd/amstd-1.9.5.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard libraries for Ruby"
+SRC_URI="http://www1.u-netsurf.ne.jp/~brew/mine/soft/${A}"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1"
+
+src_compile() {
+ cd ${S}
+ try ruby setup.rb config
+ try ruby setup.rb setup
+}
+
+src_install () {
+ cd ${S}
+ try ruby setup.rb install --bin-dir=${D}/usr/bin \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 \
+ --so-dir=${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+}
diff --git a/dev-ruby/amstd/files/digest-amstd-1.9.5 b/dev-ruby/amstd/files/digest-amstd-1.9.5
new file mode 100644
index 000000000000..5e49a59828aa
--- /dev/null
+++ b/dev-ruby/amstd/files/digest-amstd-1.9.5
@@ -0,0 +1 @@
+MD5 fb4f9bba17d759b59fb6a2ac4f836dcc amstd-1.9.5.tar.gz
diff --git a/dev-ruby/optparse/files/digest-optparse-0.7.5 b/dev-ruby/optparse/files/digest-optparse-0.7.5
new file mode 100644
index 000000000000..5f120155511a
--- /dev/null
+++ b/dev-ruby/optparse/files/digest-optparse-0.7.5
@@ -0,0 +1 @@
+MD5 6b4a5e1957f62c030b81d8041dc1f63a optparse-0.7.5.tar.gz
diff --git a/dev-ruby/optparse/optparse-0.7.5.ebuild b/dev-ruby/optparse/optparse-0.7.5.ebuild
new file mode 100644
index 000000000000..345c8ae45073
--- /dev/null
+++ b/dev-ruby/optparse/optparse-0.7.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/optparse/optparse-0.7.5.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Yet another option parser for Ruby"
+SRC_URI=" http://member.nifty.ne.jp/nokada/archive/${A}"
+HOMEPAGE=" http://member.nifty.ne.jp/nokada/ruby.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1"
+
+#src_compile() {
+# cd ${S}
+# try ruby setup.rb config --without=amstd
+# try ruby setup.rb setup
+#}
+
+src_install () {
+ cd ${S}
+ insinto /usr/lib/ruby/site_ruby/1.6
+ doins optparse.rb
+
+ insinto /usr/lib/ruby/site_ruby/1.6/optparse
+ doins optparse/*
+}
diff --git a/dev-ruby/racc/files/digest-racc-1.2.4 b/dev-ruby/racc/files/digest-racc-1.2.4
new file mode 100644
index 000000000000..bbdb6b29c555
--- /dev/null
+++ b/dev-ruby/racc/files/digest-racc-1.2.4
@@ -0,0 +1 @@
+MD5 70f6983f8bb04dd3403aa6b34efa8b18 racc-1.2.4.tar.gz
diff --git a/dev-ruby/racc/racc-1.2.4.ebuild b/dev-ruby/racc/racc-1.2.4.ebuild
new file mode 100644
index 000000000000..d58e307ac807
--- /dev/null
+++ b/dev-ruby/racc/racc-1.2.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/racc/racc-1.2.4.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="LALR parser generator for Ruby"
+SRC_URI="http://www1.u-netsurf.ne.jp/~brew/mine/soft/${A}"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/amstd-1.9.5"
+
+src_compile() {
+ cd ${S}
+ try ruby setup.rb config --without=amstd
+ try ruby setup.rb setup
+}
+
+src_install () {
+ cd ${S}
+ try ruby setup.rb install --bin-dir=${D}/usr/bin \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 \
+ --so-dir=${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+}
diff --git a/dev-ruby/rdtool/files/digest-rdtool-0.6.6 b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
new file mode 100644
index 000000000000..51689b7bcd91
--- /dev/null
+++ b/dev-ruby/rdtool/files/digest-rdtool-0.6.6
@@ -0,0 +1 @@
+MD5 36faf95bd070d560cf752b095ad4ea21 rdtool-0.6.6.tar.gz
diff --git a/dev-ruby/rdtool/rdtool-0.6.6.ebuild b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
new file mode 100644
index 000000000000..1ff00901a518
--- /dev/null
+++ b/dev-ruby/rdtool/rdtool-0.6.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rdtool/rdtool-0.6.6.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Fast string scanning library for Ruby"
+SRC_URI="http://www2.pos.to/~tosh/ruby/rdtool/archive/${A}"
+HOMEPAGE="http://www2.pos.to/~tosh/ruby/rdtool/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/racc-1.2.4
+ >=dev-ruby/strscan-0.5.8
+ >=dev-ruby/optparse-0.7.5"
+
+src_compile() {
+ cd ${S}
+ try ruby rdtoolconf.rb
+ try make
+}
+
+src_install () {
+ cd ${S}
+ chmod 755 rd2
+ dobin rd2
+
+ cd ${S}/rd
+ insinto /usr/lib/ruby/site_ruby/1.6/rd
+ doins dot.rd2rc *.rb
+}
diff --git a/dev-ruby/strscan/files/digest-strscan-0.5.8 b/dev-ruby/strscan/files/digest-strscan-0.5.8
new file mode 100644
index 000000000000..f3475ecf8c1f
--- /dev/null
+++ b/dev-ruby/strscan/files/digest-strscan-0.5.8
@@ -0,0 +1 @@
+MD5 b92dbd46a187b85c1b408215f5907762 strscan-0.5.8.tar.gz
diff --git a/dev-ruby/strscan/strscan-0.5.8.ebuild b/dev-ruby/strscan/strscan-0.5.8.ebuild
new file mode 100644
index 000000000000..9138f9542fdc
--- /dev/null
+++ b/dev-ruby/strscan/strscan-0.5.8.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/strscan/strscan-0.5.8.ebuild,v 1.1 2000/11/17 08:22:04 jerry Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Fast string scanning library for Ruby"
+SRC_URI="http://www1.u-netsurf.ne.jp/~brew/mine/soft/${A}"
+HOMEPAGE="http://www1.u-netsurf.ne.jp/~brew/mine/en/index.html"
+
+DEPEND=">=dev-lang/ruby-1.6.1
+ >=dev-ruby/amstd-1.9.5"
+
+src_compile() {
+ cd ${S}
+ try ruby setup.rb config --without=amstd
+ try ruby setup.rb setup
+}
+
+src_install () {
+ cd ${S}
+ try ruby setup.rb install --bin-dir=${D}/usr/bin \
+ --rb-dir=${D}/usr/lib/ruby/site_ruby/1.6 \
+ --so-dir=${D}/usr/lib/ruby/site_ruby/1.6/i686-linux-gnu
+}