summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-12-27 09:46:12 +0000
committerHans de Graaff <graaff@gentoo.org>2014-12-27 09:46:12 +0000
commitecf192eba603c065f27aa8d2852ca3dc9434bfd5 (patch)
tree3f3fe96ffdeeea143f9d60fa6579c1af8ecce10e /dev-ruby
parentMaintenance release (diff)
downloadgentoo-2-ecf192eba603c065f27aa8d2852ca3dc9434bfd5.tar.gz
gentoo-2-ecf192eba603c065f27aa8d2852ca3dc9434bfd5.tar.bz2
gentoo-2-ecf192eba603c065f27aa8d2852ca3dc9434bfd5.zip
Create a stable candidate with the rspec-2 wrapper.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/rspec-core/ChangeLog8
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild4
-rw-r--r--dev-ruby/rspec-core/rspec-core-2.14.8-r3.ebuild84
3 files changed, 93 insertions, 3 deletions
diff --git a/dev-ruby/rspec-core/ChangeLog b/dev-ruby/rspec-core/ChangeLog
index 10950e752174..bb4ac5d02731 100644
--- a/dev-ruby/rspec-core/ChangeLog
+++ b/dev-ruby/rspec-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/rspec-core
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.84 2014/12/07 07:32:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/ChangeLog,v 1.85 2014/12/27 09:46:12 graaff Exp $
+
+*rspec-core-2.14.8-r3 (27 Dec 2014)
+
+ 27 Dec 2014; Hans de Graaff <graaff@gentoo.org> rspec-core-2.14.8-r2.ebuild,
+ +rspec-core-2.14.8-r3.ebuild:
+ Create a stable candidate with the rspec-2 wrapper.
*rspec-core-2.99.2-r1 (07 Dec 2014)
*rspec-core-2.14.8-r2 (07 Dec 2014)
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild
index 5b0e51f73ce0..f9b1008d0d29 100644
--- a/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild
+++ b/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild,v 1.1 2014/12/07 07:32:24 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.8-r2.ebuild,v 1.2 2014/12/27 09:46:12 graaff Exp $
EAPI=5
-USE_RUBY="ruby19 ruby20 ruby21"
+USE_RUBY="ruby19 ruby20"
RUBY_FAKEGEM_TASK_TEST="none"
RUBY_FAKEGEM_TASK_DOC="none"
diff --git a/dev-ruby/rspec-core/rspec-core-2.14.8-r3.ebuild b/dev-ruby/rspec-core/rspec-core-2.14.8-r3.ebuild
new file mode 100644
index 000000000000..9f9a6d62d09d
--- /dev/null
+++ b/dev-ruby/rspec-core/rspec-core-2.14.8-r3.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/rspec-core/rspec-core-2.14.8-r3.ebuild,v 1.1 2014/12/27 09:46:12 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="none"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+# Also install this custom path since internal paths depend on it.
+RUBY_FAKEGEM_EXTRAINSTALL="exe"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-core.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? (
+ >=dev-ruby/nokogiri-1.5.2
+ dev-ruby/syntax
+ >=dev-ruby/zentest-4.6.2
+ >=dev-ruby/rspec-expectations-2.14.0:2
+ >=dev-ruby/rspec-mocks-2.12.0:2
+ )"
+
+# Skip yard for ruby20 for now since we don't support ruby20 eselected
+# yet and we can't bootstrap otherwise.
+USE_RUBY=${USE_RUBY/ruby20/} ruby_add_bdepend "doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Avoid dependency on cucumber since we can't run the features anyway.
+ sed -i -e '/[Cc]ucumber/ s:^:#:' Rakefile || die
+
+ # Cover all released versions of ruby 2.1.x. This should be reported
+ # upstream since ruby 2.1.x uses semantic versioning and the file
+ # should not have the full version number.
+ cp spec/rspec/core/formatters/text_mate_formatted-2.1.0.html spec/rspec/core/formatters/text_mate_formatted-2.1.1.html|| die
+
+ # Duplicate exe also in bin. We can't change it since internal stuff
+ # also depends on this and fixing that is going to be fragile. This
+ # way we can at least install proper bin scripts.
+ cp -R exe bin || die
+
+ # Avoid unneeded dependency on git.
+ sed -i -e '/git ls-files/ s:^:#:' rspec-core.gemspec || die
+
+ # Avoid aruba dependency so that we don't end up in dependency hell.
+ sed -i -e '/aruba/ s:^:#:' -e '104,106 s:^:#:' spec/spec_helper.rb || die
+ rm spec/command_line/order_spec.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -e:'${RUBY}' -e:' spec/rspec/core_spec.rb || die
+}
+
+all_ruby_compile() {
+ if use doc ; then
+ yardoc || die
+ fi
+}
+
+each_ruby_test() {
+ PATH="${S}/bin:${PATH}" RUBYLIB="${S}/lib" ${RUBY} -Ilib bin/rspec spec || die "Tests failed."
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ ruby_fakegem_binwrapper rspec /usr/bin/rspec-2 'gem "rspec", "~>2.0"'
+}