summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-09-16 06:26:39 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-09-16 06:26:39 +0000
commitf0fec61b1ad45c7dd6fc72e98dbfdcbac5fede98 (patch)
tree943f02fb6b502c36824697f84439c65b99c42606 /dev-ruby
parentfixes for bug 459290 and verbump to 2.2.4 (diff)
downloadgentoo-2-f0fec61b1ad45c7dd6fc72e98dbfdcbac5fede98.tar.gz
gentoo-2-f0fec61b1ad45c7dd6fc72e98dbfdcbac5fede98.tar.bz2
gentoo-2-f0fec61b1ad45c7dd6fc72e98dbfdcbac5fede98.zip
update of 1.6 facter to 1.6.18
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/facter/ChangeLog7
-rw-r--r--dev-ruby/facter/facter-1.6.18.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-ruby/facter/ChangeLog b/dev-ruby/facter/ChangeLog
index 1426263f3eb8..3efbf278f63b 100644
--- a/dev-ruby/facter/ChangeLog
+++ b/dev-ruby/facter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/facter
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.84 2013/09/16 05:54:27 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.85 2013/09/16 06:26:39 prometheanfire Exp $
+
+*facter-1.6.18 (16 Sep 2013)
+
+ 16 Sep 2013; Matthew Thode <prometheanfire@gentoo.org> +facter-1.6.18.ebuild:
+ update of 1.6 facter to 1.6.18
*facter-1.7.3 (16 Sep 2013)
diff --git a/dev-ruby/facter/facter-1.6.18.ebuild b/dev-ruby/facter/facter-1.6.18.ebuild
new file mode 100644
index 000000000000..a79b35a875b9
--- /dev/null
+++ b/dev-ruby/facter/facter-1.6.18.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.6.18.ebuild,v 1.1 2013/09/16 06:26:39 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby18 ruby19 ree18 jruby"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+dmi"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ >=sys-apps/net-tools-1.60_p20120127084908
+ dmi? ( sys-apps/dmidecode )
+ sys-apps/lsb-release
+ sys-apps/pciutils"
+
+RDEPEND+=" ${CDEPEND}"
+DEPEND+=" test? ( ${CDEPEND} )"
+
+ruby_add_bdepend "test? ( =dev-ruby/mocha-0.10.5 )"
+
+ruby_all_prepare() {
+ # Provide explicit path since /sbin is not in the default PATH on
+ # Gentoo.
+ sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb || die
+}