summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-02-11 07:51:54 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-02-11 07:51:54 +0000
commitf11a967bf023b410f5b74d0982c7977755e16803 (patch)
tree03a7fd9426fe0c30b8b7de247b7496164da1bb59 /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-f11a967bf023b410f5b74d0982c7977755e16803.tar.gz
gentoo-2-f11a967bf023b410f5b74d0982c7977755e16803.tar.bz2
gentoo-2-f11a967bf023b410f5b74d0982c7977755e16803.zip
bup
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/facter/ChangeLog7
-rw-r--r--dev-ruby/facter/facter-2.4.1.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/dev-ruby/facter/ChangeLog b/dev-ruby/facter/ChangeLog
index 94c92216272c..f88fdb4254cf 100644
--- a/dev-ruby/facter/ChangeLog
+++ b/dev-ruby/facter/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/facter
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.118 2015/01/28 06:45:53 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.119 2015/02/11 07:51:54 prometheanfire Exp $
+
+*facter-2.4.1 (11 Feb 2015)
+
+ 11 Feb 2015; Matthew Thode <prometheanfire@gentoo.org> +facter-2.4.1.ebuild:
+ bup
*facter-2.4.0 (28 Jan 2015)
diff --git a/dev-ruby/facter/facter-2.4.1.ebuild b/dev-ruby/facter/facter-2.4.1.ebuild
new file mode 100644
index 000000000000..4af8f2b54982
--- /dev/null
+++ b/dev-ruby/facter/facter-2.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-2.4.1.ebuild,v 1.1 2015/02/11 07:51:54 prometheanfire Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+dmi +pciutils +virt"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ app-emulation/virt-what
+ sys-apps/net-tools
+ sys-apps/lsb-release
+ dmi? ( sys-apps/dmidecode )
+ pciutils? ( sys-apps/pciutils )"
+
+RDEPEND+=" ${CDEPEND}"
+DEPEND+=" test? ( ${CDEPEND} )"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha:1.0 )"
+
+all_ruby_prepare() {
+ # Provide explicit path since /sbin is not in the default PATH on
+ # Gentoo.
+ sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
+
+ # Ensure the correct version of mocha is used without using bundler.
+ sed -i -e '1igem "mocha", "~>1.0"' spec/spec_helper.rb || die
+
+ # Avoid because tests try to access outside stuff, e.g. /sys/block
+ sed -i -e '/should load facts on the facter search path only once/,/^ end/ s:^:#:' spec/unit/util/loader_spec.rb || die
+
+ # Allow specs to work with newer rspec 2.x versions.
+ sed -i -e '1irequire "rspec-expectations"' spec/puppetlabs_spec/matchers.rb || die
+
+ # Avoid specs specific to macosx requiring cfpropertylist which is
+ # not available anymore.
+ rm spec/unit/util/macosx_spec.rb || die
+ sed -i -e '/macosx/ s:^:#:' \
+ -e '/on Darwin/,/^ end/ s:^:#:' spec/unit/virtual_spec.rb || die
+ sed -i -e '/Facter::Processors::Darwin/,/^end/ s:^:#:' spec/unit/processors/os_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create the directory for custom facts.
+ keepdir /etc/facter/facts.d
+}