summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-06-26 06:50:09 +0000
committerHans de Graaff <graaff@gentoo.org>2010-06-26 06:50:09 +0000
commitf139a5d37a6d74dc17556a3419f94366b23cc7ea (patch)
tree4fb61a560da22841cbfcbe34012b163bb8c7b783 /dev-ruby
parentRemove old version. (diff)
downloadgentoo-2-f139a5d37a6d74dc17556a3419f94366b23cc7ea.tar.gz
gentoo-2-f139a5d37a6d74dc17556a3419f94366b23cc7ea.tar.bz2
gentoo-2-f139a5d37a6d74dc17556a3419f94366b23cc7ea.zip
Convert to ruby-fakegem.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/mash/ChangeLog9
-rw-r--r--dev-ruby/mash/mash-0.1.1-r1.ebuild23
2 files changed, 30 insertions, 2 deletions
diff --git a/dev-ruby/mash/ChangeLog b/dev-ruby/mash/ChangeLog
index c82a1873d145..7cd17727eba6 100644
--- a/dev-ruby/mash/ChangeLog
+++ b/dev-ruby/mash/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/mash
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mash/ChangeLog,v 1.3 2009/12/09 19:41:39 graaff Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mash/ChangeLog,v 1.4 2010/06/26 06:50:09 graaff Exp $
+
+*mash-0.1.1-r1 (26 Jun 2010)
+
+ 26 Jun 2010; Hans de Graaff <graaff@gentoo.org> +mash-0.1.1-r1.ebuild:
+ Convert to ruby-fakegem.
09 Dec 2009; Hans de Graaff <graaff@gentoo.org> -mash-0.0.3.ebuild:
Remove old version.
diff --git a/dev-ruby/mash/mash-0.1.1-r1.ebuild b/dev-ruby/mash/mash-0.1.1-r1.ebuild
new file mode 100644
index 000000000000..bb16e532ea07
--- /dev/null
+++ b/dev-ruby/mash/mash-0.1.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/mash/mash-0.1.1-r1.ebuild,v 1.1 2010/06/26 06:50:09 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="History.txt README.txt"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mash is an extended Hash that gives simple pseudo-object functionality."
+HOMEPAGE="http://github.com/mbleigh/mash"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec )"