summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-07-20 17:22:48 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-07-20 17:22:48 +0000
commitfc51f64c4f4206b92362434d7878b52f0bbb75c5 (patch)
treefe5ec5ccacb53cf066ca78938d7a5f8f9861733e /dev-ruby
parentVersion bump. (diff)
downloadgentoo-2-fc51f64c4f4206b92362434d7878b52f0bbb75c5.tar.gz
gentoo-2-fc51f64c4f4206b92362434d7878b52f0bbb75c5.tar.bz2
gentoo-2-fc51f64c4f4206b92362434d7878b52f0bbb75c5.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ox/ChangeLog7
-rw-r--r--dev-ruby/ox/ox-2.1.2.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-ruby/ox/ChangeLog b/dev-ruby/ox/ChangeLog
index 62ad074deea7..d5bca0c455f6 100644
--- a/dev-ruby/ox/ChangeLog
+++ b/dev-ruby/ox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/ox
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ChangeLog,v 1.7 2014/04/24 20:23:25 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ChangeLog,v 1.8 2014/07/20 17:22:48 mrueg Exp $
+
+*ox-2.1.2 (20 Jul 2014)
+
+ 20 Jul 2014; Manuel Rüger <mrueg@gentoo.org> +ox-2.1.2.ebuild:
+ Version bump.
24 Apr 2014; Manuel Rüger <mrueg@gentoo.org> -ox-2.0.12.ebuild,
-ox-2.1.0.ebuild, ox-2.1.1.ebuild:
diff --git a/dev-ruby/ox/ox-2.1.2.ebuild b/dev-ruby/ox/ox-2.1.2.ebuild
new file mode 100644
index 000000000000..b450545e93be
--- /dev/null
+++ b/dev-ruby/ox/ox-2.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ox/ox-2.1.2.ebuild,v 1.1 2014/07/20 17:22:48 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="http://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64"
+SLOT="0"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ox extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ox
+ cp ext/ox/ox$(get_modname) lib/ || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}