summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-01-13 05:30:26 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-01-13 05:30:26 +0000
commitff82a444e9a837c8f1f755c3309c791a0c6a22df (patch)
treed313207eeac8fc6a3b00b66b6cc3f4ba1e058d8a /dev-ruby
parentNMU: Version bump. Fixes bug #478496. (diff)
downloadgentoo-2-ff82a444e9a837c8f1f755c3309c791a0c6a22df.tar.gz
gentoo-2-ff82a444e9a837c8f1f755c3309c791a0c6a22df.tar.bz2
gentoo-2-ff82a444e9a837c8f1f755c3309c791a0c6a22df.zip
Version bump.
(Portage version: 2.2.8/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/pkg-config/ChangeLog9
-rw-r--r--dev-ruby/pkg-config/pkg-config-1.1.5.ebuild37
2 files changed, 44 insertions, 2 deletions
diff --git a/dev-ruby/pkg-config/ChangeLog b/dev-ruby/pkg-config/ChangeLog
index a2d94e2753c7..984313fa729e 100644
--- a/dev-ruby/pkg-config/ChangeLog
+++ b/dev-ruby/pkg-config/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/pkg-config
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.21 2013/12/05 09:57:18 naota Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/ChangeLog,v 1.22 2014/01/13 05:30:26 mrueg Exp $
+
+*pkg-config-1.1.5 (13 Jan 2014)
+
+ 13 Jan 2014; Manuel Rüger <mrueg@gentoo.org> +pkg-config-1.1.5.ebuild:
+ Version bump.
05 Dec 2013; Naohiro Aota <naota@gentoo.org> pkg-config-1.1.4-r1.ebuild:
Add ruby20 support
diff --git a/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
new file mode 100644
index 000000000000..72f4ff44cffa
--- /dev/null
+++ b/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/pkg-config/pkg-config-1.1.5.ebuild,v 1.1 2014/01/13 05:30:26 mrueg Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19 ruby20"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc NEWS"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A pkg-config implementation by Ruby"
+HOMEPAGE="https://github.com/rcairo/pkg-config"
+LICENSE="|| ( LGPL-2 LGPL-2.1 LGPL-3 )"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/test-unit-2.5.1-r1 )"
+# this is used for testing
+DEPEND+=" test? ( x11-libs/cairo )"
+RDEPEND+=" virtual/pkgconfig"
+
+all_ruby_prepare() {
+# drop failing tests
+ sed -i -e "/test_cflags/,/end/d"\
+ -e "/test_cflags_only_I/,/end/d" test/test_pkg_config.rb || die
+}
+
+each_ruby_test() {
+ ruby-ng_testrb-2 -Ilib test/test_${PN/-/_}.rb
+}