summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarijn Schouten <hkbst@gentoo.org>2009-01-28 16:46:59 +0000
committerMarijn Schouten <hkbst@gentoo.org>2009-01-28 16:46:59 +0000
commit9327f6d1c54a2d5e3553c08d1d58b19799185027 (patch)
treec83324ae45994a411c81d4e50fab4c3bb7818938 /dev-scheme/gambit
parentFix --as-needed bug #247284 (diff)
downloadgentoo-2-9327f6d1c54a2d5e3553c08d1d58b19799185027.tar.gz
gentoo-2-9327f6d1c54a2d5e3553c08d1d58b19799185027.tar.bz2
gentoo-2-9327f6d1c54a2d5e3553c08d1d58b19799185027.zip
rm cruft
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-scheme/gambit')
-rw-r--r--dev-scheme/gambit/ChangeLog7
-rw-r--r--dev-scheme/gambit/gambit-4.0.0.ebuild125
-rw-r--r--dev-scheme/gambit/gambit-4.0.1.ebuild125
-rw-r--r--dev-scheme/gambit/gambit-4.0_beta22.ebuild109
-rw-r--r--dev-scheme/gambit/gambit-4.1.0.ebuild126
-rw-r--r--dev-scheme/gambit/gambit-4.1.1.ebuild107
-rw-r--r--dev-scheme/gambit/gambit-4.1.2.ebuild102
-rw-r--r--dev-scheme/gambit/gambit-4.4.0.ebuild3
-rw-r--r--dev-scheme/gambit/metadata.xml4
9 files changed, 8 insertions, 700 deletions
diff --git a/dev-scheme/gambit/ChangeLog b/dev-scheme/gambit/ChangeLog
index 10ff57740f17..30145ebb4ddd 100644
--- a/dev-scheme/gambit/ChangeLog
+++ b/dev-scheme/gambit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-scheme/gambit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.20 2009/01/05 21:16:19 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/ChangeLog,v 1.21 2009/01/28 16:46:59 hkbst Exp $
+
+ 28 Jan 2009; Marijn Schouten <hkBst@gentoo.org> -gambit-4.0_beta22.ebuild,
+ -gambit-4.0.0.ebuild, -gambit-4.0.1.ebuild, -gambit-4.1.0.ebuild,
+ -gambit-4.1.1.ebuild, -gambit-4.1.2.ebuild:
+ rm cruft
05 Jan 2009; Marijn Schouten <hkBst@gentoo.org> gambit-4.4.0.ebuild:
enable single-host by default and remove option to enable gcc-opts
diff --git a/dev-scheme/gambit/gambit-4.0.0.ebuild b/dev-scheme/gambit/gambit-4.0.0.ebuild
deleted file mode 100644
index 2ca1c35238e2..000000000000
--- a/dev-scheme/gambit/gambit-4.0.0.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.0.ebuild,v 1.4 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v4.0/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="big-iron emacs static"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
- ewarn "NOT compiling syntax-case macro system"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
- ewarn "compiling syntax-case macro system"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-# cp configure.ac configure.ac.old
- sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
- -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
- #don't force -O1
- sed 's:$DASH_O1::' -i configure.ac
- eautoreconf
-# diff -u configure.ac.old configure.ac
-}
-
-src_compile() {
- econf $(if use static; then echo --disable-shared; else echo --enable-shared; fi) \
- $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-
- # compile syntax-case
- if use big-iron; then
- einfo "compiling syntax-case.scm..."
- LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
- fi
-}
-
-src_test() {
- vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
- if ! GAMBCOPT="=." emake -j1 check; then
- hasq test $FEATURES && die "Make test failed. See above for details."
- hasq test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
-
- rm ${D}/usr/current
-
- use big-iron && dolib syntax-case.*
- mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r ${D}/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
-# dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
- echo "GAMBCOPT=\"=/usr/\"" > "${T}/50gambit" && doenvd "${T}/50gambit"
-
- ewarn "syntax-case will be automatically loaded for R5RS+ goodness"
- ewarn "edit /etc/gambcext if you want to set your own options"
- dosym /etc/gambcext /usr/gambcext
- echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/etc/gambcext
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.0.1.ebuild b/dev-scheme/gambit/gambit-4.0.1.ebuild
deleted file mode 100644
index 5c00ae8e6d19..000000000000
--- a/dev-scheme/gambit/gambit-4.0.1.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0.1.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v4.0/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="big-iron emacs static"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
- ewarn "NOT compiling syntax-case macro system"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
- ewarn "compiling syntax-case macro system"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-# cp configure.ac configure.ac.old
- sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
- -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
- #don't force -O1
- sed 's:$DASH_O1::' -i configure.ac
- eautoreconf
-# diff -u configure.ac.old configure.ac
-}
-
-src_compile() {
- econf $(if use static; then echo --disable-shared; else echo --enable-shared; fi) \
- $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-
- # compile syntax-case
- if use big-iron; then
- einfo "compiling syntax-case.scm..."
- LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
- fi
-}
-
-src_test() {
- vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
- if ! GAMBCOPT="=." emake -j1 check; then
- hasq test $FEATURES && die "Make test failed. See above for details."
- hasq test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
-
- rm ${D}/usr/current
-
- use big-iron && dolib syntax-case.*
- mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r ${D}/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
-# dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
- echo "GAMBCOPT=\"=/usr/\"" > "${T}/50gambit" && doenvd "${T}/50gambit"
-
- ewarn "syntax-case will be automatically loaded for R5RS+ goodness"
- ewarn "edit /etc/gambcext if you want to set your own options"
- dosym /etc/gambcext /usr/gambcext
- echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/etc/gambcext
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.0_beta22.ebuild b/dev-scheme/gambit/gambit-4.0_beta22.ebuild
deleted file mode 100644
index a91cadc0ed7b..000000000000
--- a/dev-scheme/gambit/gambit-4.0_beta22.ebuild
+++ /dev/null
@@ -1,109 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.0_beta22.ebuild,v 1.9 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//_beta/b}
-MY_P=${MY_PN}-${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/4.0/source/${MY_P}.tar.gz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="emacs big-iron"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "not using gcc specific optimizations and not compiling syntax-case macro system"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "using gcc specific optimizations and compiling syntax-case macro system"
- ewarn "this will cause approximately 2GB ram to be used instead of 0.5GB."
- ewarn "this will cause heavy thrashing of your system unless your system is big iron"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
- sed -e "s:PACKAGE_SUBDIR=\"/${MY_PV}\":PACKAGE_SUBDIR=\"/\":" -i configure.ac
- eautoreconf
-}
-
-src_compile() {
- econf --enable-shared --enable-single-host $(use_enable big-iron gcc-opts)
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-
- # compile syntax-case
- if use big-iron; then
- einfo "compiling syntax-case.scm..."
- LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
- fi
-}
-
-src_test() {
- vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
- if ! GAMBCOPT="=." emake -j1 check; then
- hasq test $FEATURES && die "Make test failed. See above for details."
- hasq test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
-
- rm ${D}/usr/current
-
- use big-iron && dolib syntax-case.*
- mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r ${D}/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
- # automatically load syntax-case for r5rs+ goodness
- dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
- echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/usr/gambcext
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.1.0.ebuild b/dev-scheme/gambit/gambit-4.1.0.ebuild
deleted file mode 100644
index ee47ce38d271..000000000000
--- a/dev-scheme/gambit/gambit-4.1.0.ebuild
+++ /dev/null
@@ -1,126 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.0.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="big-iron emacs static"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
-# ewarn "NOT compiling syntax-case macro system"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
-# ewarn "compiling syntax-case macro system"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-# cp configure.ac configure.ac.old
- sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
- -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
- #don't force -O1
- sed 's:$DASH_O1::' -i configure.ac
- eautoreconf
-# diff -u configure.ac.old configure.ac
-}
-
-src_compile() {
-# econf $(if use static; then echo --disable-shared; else echo --enable-shared; fi) \
- econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
-
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-
- # compile syntax-case
-# if use big-iron; then
-# einfo "compiling syntax-case.scm..."
-# LD_LIBRARY_PATH="lib/" GAMBCOPT="=." gsc/gsc misc/syntax-case.scm
-# fi
-}
-
-_src_test() {
- vecho ">>> Test phase [check]: ${CATEGORY}/${PF}"
- if ! GAMBCOPT="=." emake -j1 check; then
- hasq test $FEATURES && die "Make test failed. See above for details."
- hasq test $FEATURES || eerror "Make test failed. See above for details."
- fi
-}
-
-src_install() {
- einstall docdir=${D}/usr/share/doc/${PF} || die "einstall failed"
-
- rm ${D}/usr/current
-
-# use big-iron && dolib syntax-case.*
- mv ${D}/usr/syntax-case.scm ${D}/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv ${D}/usr/bin/gsc ${D}/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r ${D}/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install ${FILESDIR}/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
-# dodir /etc/env.d/ && echo "GAMBCOPT=\"=/usr/\"" > ${D}/etc/env.d/50gambit
- echo "GAMBCOPT=\"=/usr/\"" > "${T}/50gambit" && doenvd "${T}/50gambit"
-
-# ewarn "syntax-case will be automatically loaded for R5RS+ goodness"
-# ewarn "edit /etc/gambcext if you want to set your own options"
-# dosym /etc/gambcext /usr/gambcext
-# echo "(load \"/usr/$(get_libdir)/syntax-case\")" > ${D}/etc/gambcext
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.1.1.ebuild b/dev-scheme/gambit/gambit-4.1.1.ebuild
deleted file mode 100644
index c889b95dd1cb..000000000000
--- a/dev-scheme/gambit/gambit-4.1.1.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.1.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="big-iron emacs static"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
-# ewarn "NOT compiling syntax-case macro system"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
-# ewarn "compiling syntax-case macro system"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-# cp configure.ac configure.ac.old
- sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
- -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
- #don't force -O1
- sed 's:$DASH_O1::' -i configure.ac
- eautoreconf
-# diff -u configure.ac.old configure.ac
-}
-
-src_compile() {
- econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
-
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-
- #workaround
- mv gsi/libgambcgsi.so gsc/libgambcgsc.so lib/
-}
-
-src_install() {
- einstall docdir="${D}"/usr/share/doc/${PF} || die "einstall failed"
-
- rm "${D}"/usr/current
-
- mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r "${D}"/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
- echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.1.2.ebuild b/dev-scheme/gambit/gambit-4.1.2.ebuild
deleted file mode 100644
index 857b257f6416..000000000000
--- a/dev-scheme/gambit/gambit-4.1.2.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.1.2.ebuild,v 1.2 2008/08/28 17:41:15 ulm Exp $
-
-inherit eutils elisp-common check-reqs autotools multilib
-
-MY_PN=gambc
-MY_PV=${PV//./_}
-MY_P=${MY_PN}-v${MY_PV}
-
-DESCRIPTION="Gambit-C is a native Scheme to C compiler and interpreter."
-HOMEPAGE="http://www.iro.umontreal.ca/~gambit/"
-SRC_URI="http://www.iro.umontreal.ca/~gambit/download/gambit/v${PV%.*}/source/${MY_P}.tgz"
-
-LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc64 ~x86"
-
-DEPEND="emacs? ( virtual/emacs )"
-
-SITEFILE="50gambit-gentoo.el"
-
-S=${WORKDIR}/${MY_P}
-
-IUSE="big-iron emacs static"
-
-pkg_setup() {
- if ! use big-iron; then
- ewarn "NOT compiling each Scheme module as a single C function"
- ewarn "NOT using gcc specific optimizations"
- ewarn "approximately 0.5GB ram will be needed"
- ewarn "if you experience thrashing, try disabling parallel building or setting -O1"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="768" check_reqs
- else
- ewarn "compiling each Scheme module as a single C function"
- ewarn "using gcc specific optimizations"
- ewarn "approximately 2GB ram will be needed instead of 0.5GB"
- ewarn "this will cause heavy thrashing of your system"
- ewarn "and may cause your compiler to crash when it runs out of memory"
- ewarn "unless your system is BIG IRON"
- # need this much memory in MBytes (does *not* check swap)
- CHECKREQS_MEMORY="2560" check_reqs
- fi
-}
-
-src_unpack() {
- unpack ${A}; cd "${S}"
-# cp configure.ac configure.ac.old
- sed -e 's:PACKAGE_SUBDIR="/$PACKAGE_VERSION"::' \
- -e 's:#PACKAGE_SUBDIR="":PACKAGE_SUBDIR="":' -i configure.ac
- #don't force -O1
- sed 's:$DASH_O1::' -i configure.ac
- eautoreconf
-# diff -u configure.ac.old configure.ac
-}
-
-src_compile() {
- econf $(use_enable !static shared) $(use_enable big-iron single-host) $(use_enable big-iron gcc-opts)
-
- emake || die "emake failed"
-
- if use emacs; then
- elisp-compile misc/*.el || die "elisp-compile failed"
- fi
-}
-
-src_install() {
- einstall docdir="${D}"/usr/share/doc/${PF} || die "einstall failed"
-
- rm "${D}"/usr/current
-
- mv "${D}"/usr/syntax-case.scm "${D}"/usr/$(get_libdir)
-
- # rename the /usr/bin/gsc to avoid collision with gsc from ghostscript
- mv "${D}"/usr/bin/gsc "${D}"/usr/bin/gsc-gambit
-
- # remove emacs/site-lisp/gambit.el
- rm -r "${D}"/usr/share/emacs
- if use emacs; then
- elisp-install ${PN} misc/*.{el,elc}
- elisp-site-file-install "${FILESDIR}"/${SITEFILE}
- fi
-
- dodoc INSTALL.txt README
- insinto /usr/share/doc/${PF}
- doins -r examples
-
- # create some more explicit names
- dosym gsc-gambit usr/bin/gambit-compiler
- dosym gsi usr/bin/gambit-interpreter
-
- echo "GAMBCOPT=\"=/usr/\"" > "${T}"/50gambit && doenvd "${T}"/50gambit
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}
diff --git a/dev-scheme/gambit/gambit-4.4.0.ebuild b/dev-scheme/gambit/gambit-4.4.0.ebuild
index bdbd6fab6d5f..1a1738e66373 100644
--- a/dev-scheme/gambit/gambit-4.4.0.ebuild
+++ b/dev-scheme/gambit/gambit-4.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.3 2009/01/05 21:16:19 hkbst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-scheme/gambit/gambit-4.4.0.ebuild,v 1.4 2009/01/28 16:46:59 hkbst Exp $
inherit eutils elisp-common check-reqs multilib
@@ -17,6 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~x86"
DEPEND="emacs? ( virtual/emacs )"
+RDEPEND=""
SITEFILE="50gambit-gentoo.el"
diff --git a/dev-scheme/gambit/metadata.xml b/dev-scheme/gambit/metadata.xml
index 546d853bfb72..6dc936ce2d1c 100644
--- a/dev-scheme/gambit/metadata.xml
+++ b/dev-scheme/gambit/metadata.xml
@@ -2,8 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>scheme</herd>
-<use>
- <flag name='big-iron'>Use expensive GCC optimizations and compile syntax-case macro
- system, try only if you have more than 2GB RAM</flag>
-</use>
</pkgmetadata>