summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-08-15 17:32:55 +0000
committerJustin Lecher <jlec@gentoo.org>2011-08-15 17:32:55 +0000
commit292158b9e3aed8e55920b1aac2c346b939c8bafb (patch)
tree0a998065f49471ea767e6aa60f3f822fd31fc4ce /dev-tcltk/itk
parentCorrected usage of python mod compilation and removed old (diff)
downloadgentoo-2-292158b9e3aed8e55920b1aac2c346b939c8bafb.tar.gz
gentoo-2-292158b9e3aed8e55920b1aac2c346b939c8bafb.tar.bz2
gentoo-2-292158b9e3aed8e55920b1aac2c346b939c8bafb.zip
Install itkConfig.sh, #379243, thanks Priit Laes for the patch
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/itk')
-rw-r--r--dev-tcltk/itk/ChangeLog9
-rw-r--r--dev-tcltk/itk/files/itk-3.4_pre20090417-install.patch104
-rw-r--r--dev-tcltk/itk/itk-3.4_pre20090417-r1.ebuild46
-rw-r--r--dev-tcltk/itk/itk-3.4_pre20090417.ebuild6
-rw-r--r--dev-tcltk/itk/metadata.xml2
5 files changed, 163 insertions, 4 deletions
diff --git a/dev-tcltk/itk/ChangeLog b/dev-tcltk/itk/ChangeLog
index d275ace2b316..7f3d31eefdf2 100644
--- a/dev-tcltk/itk/ChangeLog
+++ b/dev-tcltk/itk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tcltk/itk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itk/ChangeLog,v 1.31 2011/06/04 18:58:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itk/ChangeLog,v 1.32 2011/08/15 17:32:55 jlec Exp $
+
+*itk-3.4_pre20090417-r1 (15 Aug 2011)
+
+ 15 Aug 2011; Justin Lecher <jlec@gentoo.org> itk-3.4_pre20090417.ebuild,
+ +itk-3.4_pre20090417-r1.ebuild, +files/itk-3.4_pre20090417-install.patch,
+ metadata.xml:
+ Install itkConfig.sh, #379243, thanks Priit Laes for the patch
04 Jun 2011; Raúl Porcel <armin76@gentoo.org> itk-3.4_pre20090417.ebuild:
alpha/ia64/sparc stable wrt #363991
diff --git a/dev-tcltk/itk/files/itk-3.4_pre20090417-install.patch b/dev-tcltk/itk/files/itk-3.4_pre20090417-install.patch
new file mode 100644
index 000000000000..a6965bc1fd37
--- /dev/null
+++ b/dev-tcltk/itk/files/itk-3.4_pre20090417-install.patch
@@ -0,0 +1,104 @@
+@@ -, +, @@
+ itk/Makefile.in | 2 +-
+ itk/configure.in | 23 +++++++++++++++++++++++
+ itk/itkConfig.sh.in | 28 +++++++++++-----------------
+ 3 files changed, 35 insertions(+), 18 deletions(-)
+--- a/itk/Makefile.in
++++ a/itk/Makefile.in
+@@ -395,7 +395,7 @@ install-lib-binaries:
+ fi; \
+ done
+ $(INSTALL_DATA) pkgIndex.tcl $(DESTDIR)$(pkglibdir)
+- : $(INSTALL_DATA) itkConfig.sh $(DESTDIR)$(libdir)
++ $(INSTALL_DATA) itkConfig.sh $(DESTDIR)$(libdir)
+
+ #========================================================================
+ # Install binary executables (e.g. .exe files)
+--- a/itk/configure.in
++++ a/itk/configure.in
+@@ -219,6 +219,7 @@ fi
+ # library.
+ #--------------------------------------------------------------------
+
++itk_LIB_FILE=${PKG_LIB_FILE}
+ AC_SUBST(itkstub_LIB_FILE)
+ AC_SUBST(itk_LIB_FILE)
+
+@@ -234,6 +235,28 @@ TEA_PROG_TCLSH
+ TEA_PROG_WISH
+
+ #--------------------------------------------------------------------
++# These are for itkConfig.sh
++#--------------------------------------------------------------------
++
++# pkglibdir must be a fully qualified path and (not ${exec_prefix}/lib)
++eval pkglibdir="${libdir}/${PACKAGE_NAME}${PACKAGE_VERSION}"
++if test "${TCL_LIB_VERSIONS_OK}" = "ok"; then
++ eval itk_LIB_FLAG="-litk${PACKAGE_VERSION}${DBGX}"
++else
++ eval itk_LIB_FLAG="-litk`echo ${PACKAGE_VERSION} | tr -d .`${DBGX}"
++fi
++itk_BUILD_LIB_SPEC="-L`pwd` ${itk_LIB_FLAG}"
++itk_LIB_SPEC="-L${pkglibdir} ${itk_LIB_FLAG}"
++
++AC_SUBST(itk_BUILD_LIB_SPEC)
++AC_SUBST(itk_LIB_SPEC)
++
++# itk_SRC_DIR must be a fully qualified path
++eval itk_SRC_DIR="$srcdir"
++itk_SRC_DIR=`cd "${itk_SRC_DIR}"; pwd`
++AC_SUBST(itk_SRC_DIR)
++
++#--------------------------------------------------------------------
+ # Finally, substitute all of the various values into the Makefile.
+ #--------------------------------------------------------------------
+
+--- a/itk/itkConfig.sh.in
++++ a/itk/itkConfig.sh.in
+@@ -11,30 +11,23 @@
+ #
+ # The information in this file is specific to a single platform.
+
+-# Itcl's version number.
+-ITCL_VERSION='@ITCL_VERSION@'
++# Itk's version number.
++itk_VERSION='@PACKAGE_VERSION@'
++ITK_VERSION='@PACKAGE_VERSION@'
+
+ # The name of the Itk library (may be either a .a file or a shared library):
+-ITK_LIB_FILE=@ITK_LIB_FILE@
++itk_LIB_FILE=@itk_LIB_FILE@
++ITK_LIB_FILE=@itk_LIB_FILE@
+
+ # String to pass to linker to pick up the Itk library from its
+ # build directory.
+-ITK_BUILD_LIB_SPEC='@ITK_BUILD_LIB_SPEC@'
++itk_BUILD_LIB_SPEC='@itk_BUILD_LIB_SPEC@'
++ITK_BUILD_LIB_SPEC='@itk_BUILD_LIB_SPEC@'
+
+ # String to pass to linker to pick up the Itk library from its
+ # installed directory.
+-ITK_LIB_SPEC='@ITK_LIB_SPEC@'
+-
+-# The name of the Itk stub library (a .a file):
+-ITK_STUB_LIB_FILE=@ITK_STUB_LIB_FILE@
+-
+-# String to pass to linker to pick up the Itk stub library from its
+-# build directory.
+-ITK_BUILD_STUB_LIB_SPEC='@ITK_BUILD_STUB_LIB_SPEC@'
+-
+-# String to pass to linker to pick up the Itk stub library from its
+-# installed directory.
+-ITK_STUB_LIB_SPEC='@ITK_STUB_LIB_SPEC@'
++itk_LIB_SPEC='@itk_LIB_SPEC@'
++ITK_LIB_SPEC='@itk_LIB_SPEC@'
+
+ # Location of the top-level source directories from which [incr Tk]
+ # was built. This is the directory that contains a README file as well
+@@ -42,4 +35,5 @@ ITK_STUB_LIB_SPEC='@ITK_STUB_LIB_SPEC@'
+ # compiled in a different place than the directory containing the source
+ # files, this points to the location of the sources, not the location
+ # where [incr Tk] was compiled.
+-ITK_SRC_DIR='@ITK_SRC_DIR@'
++itk_SRC_DIR='@itk_SRC_DIR@'
++ITK_SRC_DIR='@itk_SRC_DIR@'
diff --git a/dev-tcltk/itk/itk-3.4_pre20090417-r1.ebuild b/dev-tcltk/itk/itk-3.4_pre20090417-r1.ebuild
new file mode 100644
index 000000000000..386803dec1c5
--- /dev/null
+++ b/dev-tcltk/itk/itk-3.4_pre20090417-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itk/itk-3.4_pre20090417-r1.ebuild,v 1.1 2011/08/15 17:32:55 jlec Exp $
+
+EAPI=4
+
+inherit autotools eutils multilib versionator
+
+MY_PN="incrTcl"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
+HOMEPAGE="http://incrtcl.sourceforge.net/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+IUSE=""
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ dev-lang/tk
+ ~dev-tcltk/itcl-3.4_beta1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_PN}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-install.patch
+ AT_M4DIR=.. eautoconf
+ sed 's:-pipe::g' -i configure || die
+}
+
+src_compile() {
+ emake CFLAGS_DEFAULT="${CFLAGS}"
+}
+
+src_install() {
+ default
+ dodoc ../{CHANGES,ChangeLog,INCOMPATIBLE,README,TODO}
+
+ cat >> "${T}"/34${PN} <<- EOF
+ LDPATH="${EPREFIX}/usr/$(get_libdir)/${PN}$(get_version_component_range 1-2)/"
+ EOF
+ doenvd "${T}"/34${PN}
+}
diff --git a/dev-tcltk/itk/itk-3.4_pre20090417.ebuild b/dev-tcltk/itk/itk-3.4_pre20090417.ebuild
index c50078ae2f4a..0a11692f01f1 100644
--- a/dev-tcltk/itk/itk-3.4_pre20090417.ebuild
+++ b/dev-tcltk/itk/itk-3.4_pre20090417.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itk/itk-3.4_pre20090417.ebuild,v 1.10 2011/06/04 18:58:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/itk/itk-3.4_pre20090417.ebuild,v 1.11 2011/08/15 17:32:55 jlec Exp $
+
+EAPI=3
-EAPI="3"
inherit multilib versionator
MY_PN="incrTcl"
MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="Object Oriented Enhancements for Tcl/Tk"
HOMEPAGE="http://incrtcl.sourceforge.net/"
SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
diff --git a/dev-tcltk/itk/metadata.xml b/dev-tcltk/itk/metadata.xml
index d9408d8ab078..815cc916f2b6 100644
--- a/dev-tcltk/itk/metadata.xml
+++ b/dev-tcltk/itk/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>tcltk</herd>
+ <herd>tcltk</herd>
</pkgmetadata>