summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-09-27 23:02:09 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-09-27 23:02:09 +0000
commitbe351b7ba8c4059773847ab815c77954597452de (patch)
treeb6c14419a0df17985afeadb19f0e35c99d0a4cf4 /dev-tcltk/tcllib/tcllib-1.6.1.ebuild
parentAdded to ~amd64. (Manifest recommit) (diff)
downloadgentoo-2-be351b7ba8c4059773847ab815c77954597452de.tar.gz
gentoo-2-be351b7ba8c4059773847ab815c77954597452de.tar.bz2
gentoo-2-be351b7ba8c4059773847ab815c77954597452de.zip
Version bumped.
Diffstat (limited to 'dev-tcltk/tcllib/tcllib-1.6.1.ebuild')
-rw-r--r--dev-tcltk/tcllib/tcllib-1.6.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-tcltk/tcllib/tcllib-1.6.1.ebuild b/dev-tcltk/tcllib/tcllib-1.6.1.ebuild
new file mode 100644
index 000000000000..372b740e2bd5
--- /dev/null
+++ b/dev-tcltk/tcllib/tcllib-1.6.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tcllib/tcllib-1.6.1.ebuild,v 1.1 2004/09/27 23:02:09 matsuu Exp $
+
+DESCRIPTION="Tcl Standard Library."
+HOMEPAGE="http://www.tcl.tk/software/tcllib/"
+SRC_URI="mirror://sourceforge/tcllib/${P}.tar.gz"
+IUSE="X doc"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~amd64 ~ia64 ~s390"
+
+DEPEND=">=dev-lang/tcl-8.3.3
+ X? ( >=dev-lang/tk-8.3.3 )"
+
+src_compile() {
+ econf || die
+ make || die
+}
+
+src_install() {
+ einstall || die
+ dodoc ChangeLog README license.terms
+ use doc && dohtml -r doc/html/*
+}