summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2004-08-28 17:20:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2004-08-28 17:20:12 +0000
commit01b46ff2deb82180600a46a22f6285d372581ebf (patch)
tree6e5ee5c46376bafb3d6f4977ae0120a05fbef7b3 /dev-tcltk
parentbump to net-im/amsn-0.93 (Manifest recommit) (diff)
downloadgentoo-2-01b46ff2deb82180600a46a22f6285d372581ebf.tar.gz
gentoo-2-01b46ff2deb82180600a46a22f6285d372581ebf.tar.bz2
gentoo-2-01b46ff2deb82180600a46a22f6285d372581ebf.zip
fixed double compiling of library
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/otcl/ChangeLog8
-rw-r--r--dev-tcltk/otcl/Manifest6
-rw-r--r--dev-tcltk/otcl/files/digest-otcl-1.8-r31
-rw-r--r--dev-tcltk/otcl/otcl-1.8-r3.ebuild46
4 files changed, 58 insertions, 3 deletions
diff --git a/dev-tcltk/otcl/ChangeLog b/dev-tcltk/otcl/ChangeLog
index a229badcddad..c9315f2721c6 100644
--- a/dev-tcltk/otcl/ChangeLog
+++ b/dev-tcltk/otcl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/otcl
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.12 2004/08/26 14:06:21 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/ChangeLog,v 1.13 2004/08/28 17:20:12 cardoe Exp $
+
+*otcl-1.8-r3 (28 Aug 2004)
+
+ 28 Aug 2004; Doug Goldstein <cardoe@gentoo.org> +otcl-1.8-r3.ebuild:
+ ebuild incorrectly attempted to recompile the shared library after the
+ fact causing a failure. bug #61639
26 Aug 2004; Ferris McCormick <fmccor@gentoo.org> otcl-1.8-r2.ebuild:
Stable for sparc.
diff --git a/dev-tcltk/otcl/Manifest b/dev-tcltk/otcl/Manifest
index 357dbe12bfb0..b4fd307d0bb0 100644
--- a/dev-tcltk/otcl/Manifest
+++ b/dev-tcltk/otcl/Manifest
@@ -1,7 +1,9 @@
-MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 08286e1ef9899977742b19cfc3758b83 otcl-1.8-r1.ebuild 1067
+MD5 d4309f12aa072fabeda7cdb8025edf83 otcl-1.8-r3.ebuild 1156
MD5 b541d6fb00bbdab66e5a36ca2a4385ef otcl-1.8-r2.ebuild 1207
+MD5 dffd46174e78b327c834fc3e4b1cf848 metadata.xml 160
MD5 e2fcf91778f0cac84b534d6032ad067b ChangeLog 1461
-MD5 64a71b4bb60017c2d8802e771d31cedc files/digest-otcl-1.8-r1 60
+MD5 64a71b4bb60017c2d8802e771d31cedc files/digest-otcl-1.8-r3 60
MD5 090aa64d1486dc3d916b9b5176179d30 files/otcl-1.8-badfreefix.patch 7469
MD5 64a71b4bb60017c2d8802e771d31cedc files/digest-otcl-1.8-r2 60
+MD5 64a71b4bb60017c2d8802e771d31cedc files/digest-otcl-1.8-r1 60
diff --git a/dev-tcltk/otcl/files/digest-otcl-1.8-r3 b/dev-tcltk/otcl/files/digest-otcl-1.8-r3
new file mode 100644
index 000000000000..f435025fe842
--- /dev/null
+++ b/dev-tcltk/otcl/files/digest-otcl-1.8-r3
@@ -0,0 +1 @@
+MD5 88a4b94b3a128867d3fe13b77f3b5496 otcl-1.8.tar.gz 300954
diff --git a/dev-tcltk/otcl/otcl-1.8-r3.ebuild b/dev-tcltk/otcl/otcl-1.8-r3.ebuild
new file mode 100644
index 000000000000..a5d2a067c14a
--- /dev/null
+++ b/dev-tcltk/otcl/otcl-1.8-r3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/otcl/otcl-1.8-r3.ebuild,v 1.1 2004/08/28 17:20:12 cardoe Exp $
+
+inherit eutils
+
+DESCRIPTION="MIT Object extension to Tcl"
+SF_PN="otcl-tclcl"
+HOMEPAGE="http://sourceforge.net/projects/${SF_PN}/"
+SRC_URI="mirror://sourceforge/${SF_PN}/${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc"
+IUSE=""
+DEPEND=">=dev-lang/tcl-8.3.2
+ >=dev-lang/tk-8.3.2"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/otcl-1.8-badfreefix.patch
+}
+
+src_compile() {
+ local tclv tkv myconf
+ tclv=$(grep TCL_VER /usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
+ tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
+ myconf="--with-tcl-ver=${tclv} --with-tk-ver=${tkv}"
+ CFLAGS="${CFLAGS} -I/usr/lib/tcl${tkv}/include/generic"
+ econf ${myconf} || die "econf failed"
+ emake all || die "emake all failed"
+}
+
+src_install() {
+ into /usr
+ dobin otclsh owish
+ dolib libotcl.so
+ dolib.a libotcl.a
+ insinto /usr/include
+ doins otcl.h
+
+ # docs
+ dodoc VERSION
+ dohtml README.html CHANGES.html
+ docinto doc
+ dodoc doc/*
+}