summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-23 10:44:12 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-23 10:44:12 +0000
commit150c77bdd9bdf7b1a62d12e035c71a7ec56d7137 (patch)
treea612a8d6f472c1cc74454faf40102fa03bbf5ea3 /dev-tcltk
parentVersion bump. (diff)
downloadgentoo-2-150c77bdd9bdf7b1a62d12e035c71a7ec56d7137.tar.gz
gentoo-2-150c77bdd9bdf7b1a62d12e035c71a7ec56d7137.tar.bz2
gentoo-2-150c77bdd9bdf7b1a62d12e035c71a7ec56d7137.zip
Reintroduced USE=X again on request of aballier
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/expect/ChangeLog6
-rw-r--r--dev-tcltk/expect/expect-5.43.0-r1.ebuild20
-rw-r--r--dev-tcltk/expect/expect-5.44.1.15.ebuild38
3 files changed, 44 insertions, 20 deletions
diff --git a/dev-tcltk/expect/ChangeLog b/dev-tcltk/expect/ChangeLog
index 7820975d0c6e..9d02aec9ac0b 100644
--- a/dev-tcltk/expect/ChangeLog
+++ b/dev-tcltk/expect/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tcltk/expect
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.70 2010/04/17 13:40:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/ChangeLog,v 1.71 2010/04/23 10:44:12 jlec Exp $
+
+ 23 Apr 2010; Justin Lecher <jlec@gentoo.org> expect-5.43.0-r1.ebuild,
+ expect-5.44.1.15.ebuild:
+ Reintroduced USE=X again on request of aballier
17 Apr 2010; Justin Lecher <jlec@gentoo.org> expect-5.43.0-r1.ebuild,
expect-5.44.1.15.ebuild:
diff --git a/dev-tcltk/expect/expect-5.43.0-r1.ebuild b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
index 66e2f54523c5..3494353aaf2b 100644
--- a/dev-tcltk/expect/expect-5.43.0-r1.ebuild
+++ b/dev-tcltk/expect/expect-5.43.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0-r1.ebuild,v 1.2 2010/04/17 13:40:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.43.0-r1.ebuild,v 1.3 2010/04/23 10:44:12 jlec Exp $
EAPI="3"
@@ -14,11 +14,12 @@ SRC_URI="http://expect.nist.gov/src/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="doc"
+IUSE="doc X"
# We need dejagnu for src_test, but dejagnu needs expect
# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tk-8.2"
+DEPEND=">=dev-lang/tcl-8.2
+ X? ( >=dev-lang/tk-8.2 )"
RDEPEND="${DEPEND}"
NON_MICRO_V=${PN}-$(get_version_component_range 1-2)
@@ -61,13 +62,20 @@ src_prepare() {
src_configure() {
local myconf
local tcl_version
- tcl_version="$(best_version dev-lang/tk | cut -d- -f3 | cut -d. -f1,2)"
+ tcl_version="$(best_version dev-lang/tcl | cut -d- -f3 | cut -d. -f1,2)"
TCL_HDIR="${EPREFIX}/usr/$(get_libdir)/tcl${tcl_version}/include"
-
#configure needs to find the file tclConfig.sh is
myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${TCL_HDIR}"
- myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir)"
+ if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=/usr/$(get_libdir)"
+ else
+ #configure knows that tk depends on X so just disable X
+ myconf="$myconf --without-x"
+ fi
econf $myconf --enable-shared
}
diff --git a/dev-tcltk/expect/expect-5.44.1.15.ebuild b/dev-tcltk/expect/expect-5.44.1.15.ebuild
index f5d1ff702a97..f8a8e0daf74e 100644
--- a/dev-tcltk/expect/expect-5.44.1.15.ebuild
+++ b/dev-tcltk/expect/expect-5.44.1.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.3 2010/04/17 13:40:36 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/expect/expect-5.44.1.15.ebuild,v 1.4 2010/04/23 10:44:12 jlec Exp $
EAPI="3"
@@ -14,11 +14,12 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~x86-solaris"
-IUSE="doc"
+IUSE="debug doc threads X"
# We need dejagnu for src_test, but dejagnu needs expect
# to compile/run, so we cant add dejagnu to DEPEND :/
-DEPEND=">=dev-lang/tk-8.2"
+DEPEND=">=dev-lang/tcl-8.2[threads?]
+ X? ( >=dev-lang/tk-8.2[threads?] )"
RDEPEND="${DEPEND}"
src_prepare() {
@@ -49,14 +50,25 @@ src_configure() {
# version number.
tclv=$(grep TCL_VER ${EPREFIX}/usr/include/tcl.h | sed 's/^.*"\(.*\)".*/\1/')
#tkv isn't really needed, included for symmetry and the future
- #tkv=$(grep TK_VER /usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
-
- #configure needs to find the files tclConfig.sh and tclInt.h
+ #tkv=$(grep TK_VER ${EPREFIX}/usr/include/tk.h | sed 's/^.*"\(.*\)".*/\1/')
myconf="--with-tcl=${EPREFIX}/usr/$(get_libdir) --with-tclinclude=${EPREFIX}/usr/$(get_libdir)/tcl${tclv}/include/generic"
- myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
-
- econf $myconf --enable-shared || die "econf failed"
+# if use X ; then
+ #--with-x is enabled by default
+ #configure needs to find the file tkConfig.sh and tk.h
+ #tk.h is in /usr/lib so don't need to explicitly set --with-tkinclude
+ myconf="$myconf --with-tk=${EPREFIX}/usr/$(get_libdir) --with-tkinclude=${EPREFIX}/usr/include"
+# else
+# #configure knows that tk depends on X so just disable X
+# myconf="$myconf --without-x"
+# fi
+
+ econf \
+ $myconf \
+ --enable-shared \
+ $(use_enable threads) \
+ $(use_enable amd64 64bit) \
+ $(use_enable debug symbols)
}
src_test() {
@@ -76,11 +88,11 @@ src_install() {
if use doc ; then
docinto examples
local scripts=$(make -qp | \
- sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
- exeinto /usr/share/doc/${PF}/examples
- doexe ${scripts}
+ sed -e 's/^SCRIPTS = //' -et -ed | head -n1)
+ insinto /usr/share/doc/${PF}/examples
+ doins ${scripts} || die
local scripts_manpages=$(make -qp | \
- sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
+ sed -e 's/^_SCRIPTS_MANPAGES = //' -et -ed | head -n1)
for m in ${scripts_manpages}; do
dodoc example/${m}.man
done