summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-11-17 09:31:58 +0000
committerJustin Lecher <jlec@gentoo.org>2013-11-17 09:31:58 +0000
commit2670927fcfd2181ca1c775618a48d4004d94431b (patch)
tree6d3bac3a4638245f7a5e81833f5f85d132936251 /dev-tcltk
parentgoa-3.8 needs gst-3.8, that needs systemd that cannot be keyworded yet on ia6... (diff)
downloadgentoo-2-2670927fcfd2181ca1c775618a48d4004d94431b.tar.gz
gentoo-2-2670927fcfd2181ca1c775618a48d4004d94431b.tar.bz2
gentoo-2-2670927fcfd2181ca1c775618a48d4004d94431b.zip
dev-tcltk/tclreadline: Fix the totally borked attempt to fix underlinking issues, #440648; fix linking with ncurses[tinfo]
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tclreadline/ChangeLog8
-rw-r--r--dev-tcltk/tclreadline/tclreadline-2.1.0-r3.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-tcltk/tclreadline/ChangeLog b/dev-tcltk/tclreadline/ChangeLog
index 888a96101a7b..56af51f58f66 100644
--- a/dev-tcltk/tclreadline/ChangeLog
+++ b/dev-tcltk/tclreadline/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tclreadline
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclreadline/ChangeLog,v 1.24 2013/04/27 06:50:43 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclreadline/ChangeLog,v 1.25 2013/11/17 09:31:58 jlec Exp $
+
+*tclreadline-2.1.0-r3 (17 Nov 2013)
+
+ 17 Nov 2013; Justin Lecher <jlec@gentoo.org> +tclreadline-2.1.0-r3.ebuild:
+ Fix the totally borked attempt to fix underlinking issues, #440648; fix
+ linking with ncurses[tinfo]
27 Apr 2013; Patrick Lauer <patrick@gentoo.org> tclreadline-2.1.0-r2.ebuild:
Automake 1.13 fix
diff --git a/dev-tcltk/tclreadline/tclreadline-2.1.0-r3.ebuild b/dev-tcltk/tclreadline/tclreadline-2.1.0-r3.ebuild
new file mode 100644
index 000000000000..f726540eac93
--- /dev/null
+++ b/dev-tcltk/tclreadline/tclreadline-2.1.0-r3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclreadline/tclreadline-2.1.0-r3.ebuild,v 1.1 2013/11/17 09:31:58 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils multilib toolchain-funcs
+
+DESCRIPTION="Readline extension to TCL"
+HOMEPAGE="http://tclreadline.sf.net/"
+SRC_URI="mirror://sourceforge/tclreadline/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="
+ dev-lang/tcl
+ sys-libs/readline"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/${P}-gold.patch )
+
+src_prepare() {
+ sed \
+ -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" \
+ -i configure.in || die
+ mv configure.{in,ac} || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --with-tcl="${EPREFIX}/usr/$(get_libdir)"
+ --with-tcl-includes="${EPREFIX}/usr/include"
+ --with-readline-includes="${EPREFIX}/usr/include"
+ --with-readline-library="${EPREFIX}/usr/$(get_libdir)"
+ --with-tlib-library="$($(tc-getPKG_CONFIG) --libs ncurses)"
+ )
+ autotools-utils_src_configure
+}