summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFederico Ferri <mescalinum@gentoo.org>2009-04-17 20:22:50 +0000
committerFederico Ferri <mescalinum@gentoo.org>2009-04-17 20:22:50 +0000
commitf2d0706aadd7bcfe3c4323327332c8653796ec35 (patch)
tree33f3808e0822aea640b320944011e08944e3d126 /dev-tcltk
parentMigrate to gen-2 java eclasses, bug #161426. (diff)
downloadgentoo-2-f2d0706aadd7bcfe3c4323327332c8653796ec35.tar.gz
gentoo-2-f2d0706aadd7bcfe3c4323327332c8653796ec35.tar.bz2
gentoo-2-f2d0706aadd7bcfe3c4323327332c8653796ec35.zip
add tcl85 patch. fixes bug #250354
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/tix/ChangeLog10
-rw-r--r--dev-tcltk/tix/files/tix-8.4.2-tcl85.patch26
-rw-r--r--dev-tcltk/tix/tix-8.4.2-r2.ebuild43
3 files changed, 77 insertions, 2 deletions
diff --git a/dev-tcltk/tix/ChangeLog b/dev-tcltk/tix/ChangeLog
index 4bfd5d95d9ff..172c3b37285b 100644
--- a/dev-tcltk/tix/ChangeLog
+++ b/dev-tcltk/tix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-tcltk/tix
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.23 2008/04/27 20:09:05 maekke Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/ChangeLog,v 1.24 2009/04/17 20:22:49 mescalinum Exp $
+
+*tix-8.4.2-r2 (17 Apr 2009)
+
+ 17 Apr 2009; Federico Ferri <mescalinum@gentoo.org>
+ +files/tix-8.4.2-tcl85.patch, +tix-8.4.2-r2.ebuild:
+ add tcl85 patch. fixes bug #250354
27 Apr 2008; Markus Meier <maekke@gentoo.org> tix-8.4.2-r1.ebuild:
amd64 stable, bug #211972
diff --git a/dev-tcltk/tix/files/tix-8.4.2-tcl85.patch b/dev-tcltk/tix/files/tix-8.4.2-tcl85.patch
new file mode 100644
index 000000000000..aaf995e0b6e2
--- /dev/null
+++ b/dev-tcltk/tix/files/tix-8.4.2-tcl85.patch
@@ -0,0 +1,26 @@
+Source: Mandriva - posted on http://bugs.gentoo.org/show_bug.cgi?id=250354
+Index: generic/tixPort.h
+===================================================================
+--- generic/tixPort.h
++++ generic/tixPort.h 2007-05-13 19:33:49.000000000 +0200
+@@ -21,6 +21,7 @@
+ #ifndef _TCL
+ #include "tcl.h"
+ #endif
++#include "tclInt.h"
+
+ #ifndef _TK
+ #include "tk.h"
+Index: generic/tixWidget.c
+===================================================================
+--- generic/tixWidget.c
++++ generic/tixWidget.c 2007-05-13 19:38:07.000000000 +0200
+@@ -228,7 +228,7 @@
+ Tcl_SetVar2(interp, "errorCode", NULL, oldErrorCode,
+ TCL_GLOBAL_ONLY);
+ }
+- iPtr->flags |= ERR_IN_PROGRESS;
++ iPtr->flags |= INTERP_TRACE_IN_PROGRESS;
+ }
+ if (rootCmd) {
+ ckfree(rootCmd);
diff --git a/dev-tcltk/tix/tix-8.4.2-r2.ebuild b/dev-tcltk/tix/tix-8.4.2-r2.ebuild
new file mode 100644
index 000000000000..3c5a76784f6d
--- /dev/null
+++ b/dev-tcltk/tix/tix-8.4.2-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tix/tix-8.4.2-r2.ebuild,v 1.1 2009/04/17 20:22:49 mescalinum Exp $
+
+EAPI="2"
+
+inherit eutils multilib
+
+MY_P="Tix${PV}"
+DESCRIPTION="A widget library for Tcl/Tk. Has been ported to Python and Perl, too."
+HOMEPAGE="http://tix.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tix/${MY_P}-src.tar.gz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RESTRICT="test"
+
+DEPEND=">=sys-apps/sed-4
+ >=dev-lang/tk-8.4
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/"${P}-tcl85.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # Bug 168897
+ insinto /usr/include; doins generic/tix.h
+ # Bug 201138
+ dosym ${MY_P}/lib${MY_P}.so /usr/$(get_libdir)/lib${MY_P}.so || die
+
+ dodoc ChangeLog README.txt docs/*.txt
+ dohtml -r index.html ABOUT.html docs/
+}