summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-08-19 14:02:21 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-08-19 14:02:21 +0000
commitcb77f53ef7adf5ab0c8d6f1412c2e5d0e36b203e (patch)
tree50b25238db8e20bbc7dfbc1b5e01b50d166196ec /dev-tex/bibtex2html
parentremove old (diff)
downloadgentoo-2-cb77f53ef7adf5ab0c8d6f1412c2e5d0e36b203e.tar.gz
gentoo-2-cb77f53ef7adf5ab0c8d6f1412c2e5d0e36b203e.tar.bz2
gentoo-2-cb77f53ef7adf5ab0c8d6f1412c2e5d0e36b203e.zip
eapi5 and add := dep on ocaml
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-tex/bibtex2html')
-rw-r--r--dev-tex/bibtex2html/ChangeLog7
-rw-r--r--dev-tex/bibtex2html/bibtex2html-1.97.ebuild22
2 files changed, 16 insertions, 13 deletions
diff --git a/dev-tex/bibtex2html/ChangeLog b/dev-tex/bibtex2html/ChangeLog
index f1b3b3834770..99c42a336d36 100644
--- a/dev-tex/bibtex2html/ChangeLog
+++ b/dev-tex/bibtex2html/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-tex/bibtex2html
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.30 2012/06/12 12:46:57 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/ChangeLog,v 1.31 2013/08/19 14:02:21 aballier Exp $
+
+ 19 Aug 2013; Alexis Ballier <aballier@gentoo.org> bibtex2html-1.97.ebuild:
+ eapi5 and add := dep on ocaml
12 Jun 2012; Alexis Ballier <aballier@gentoo.org> -bibtex2html-1.96.ebuild:
remove old
diff --git a/dev-tex/bibtex2html/bibtex2html-1.97.ebuild b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
index e15b83e89b86..52cb944b73c3 100644
--- a/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
+++ b/dev-tex/bibtex2html/bibtex2html-1.97.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/bibtex2html-1.97.ebuild,v 1.3 2012/05/21 21:09:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/bibtex2html/bibtex2html-1.97.ebuild,v 1.4 2013/08/19 14:02:21 aballier Exp $
-EAPI=2
+EAPI=5
inherit eutils
@@ -21,7 +21,7 @@ RESTRICT="test"
# With use doc we need a latex compiler to generate manual.pdf
# hevea is used for manual.html
# manual.tex needs fullpage.sty
-DEPEND=">=dev-lang/ocaml-3.10[ocamlopt?]
+DEPEND=">=dev-lang/ocaml-3.10:=[ocamlopt?]
doc? ( virtual/latex-base
dev-texlive/texlive-latexextra
dev-tex/hevea )"
@@ -39,20 +39,20 @@ src_prepare() {
src_compile() {
export VARTEXFONTS="${T}/fonts"
if use ocamlopt ; then
- emake opt || die
+ emake opt
else
- emake byte || die
+ emake byte
fi
if use doc; then
- emake doc || die "failed to create doc"
+ emake doc
fi
}
src_install() {
- emake DESTDIR="${D}" install || die "failed to install"
- dodoc README CHANGES || die
+ emake DESTDIR="${D}" install
+ dodoc README CHANGES
if use doc; then
- dodoc manual.pdf || die
- dohtml manual.html || die
+ dodoc manual.pdf
+ dohtml manual.html
fi
}