summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-02-28 22:10:39 +0000
committerMamoru Komachi <usata@gentoo.org>2004-02-28 22:10:39 +0000
commitff7e589fcbbe109e5a90e7118753b647ee9b7b6c (patch)
tree44de900de8a8aeff3e709b9711dea5c6060ced87 /dev-tex/envlab/envlab-1.2.ebuild
parentfix version issues #43212 (diff)
downloadgentoo-2-ff7e589fcbbe109e5a90e7118753b647ee9b7b6c.tar.gz
gentoo-2-ff7e589fcbbe109e5a90e7118753b647ee9b7b6c.tar.bz2
gentoo-2-ff7e589fcbbe109e5a90e7118753b647ee9b7b6c.zip
Initial import. Ebuild submitted by Matt T. Proud <khanreaper@nerp.net>, closing bug #38353
Diffstat (limited to 'dev-tex/envlab/envlab-1.2.ebuild')
-rw-r--r--dev-tex/envlab/envlab-1.2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-tex/envlab/envlab-1.2.ebuild b/dev-tex/envlab/envlab-1.2.ebuild
new file mode 100644
index 000000000000..bf9c748d4a50
--- /dev/null
+++ b/dev-tex/envlab/envlab-1.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/envlab/envlab-1.2.ebuild,v 1.1 2004/02/28 22:10:39 usata Exp $
+
+S="${WORKDIR}/${PN}"
+LICENSE="LPPL-1.2"
+DESCRIPTION="A LaTeX module to format envelopes"
+HOMEPAGE="http://planck.psu.edu/~boris/"
+# downloaded from
+# ftp://ftp.ctan.org/pub/tex-archive/macros/latex/contrib/${PN}.tar.gz
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+SLOT="0"
+DEPEND="virtual/tetex"
+KEYWORDS="~x86"
+
+src_compile() {
+ ebegin "Compiling ${PN}"
+ latex envlab.ins || die
+ pdflatex elguide.tex || die
+ pdflatex envlab.drv || die
+ eend
+}
+
+src_install() {
+ ebegin "Installing ${PN}"
+ dodir /usr/share/texmf/tex/latex/envlab
+ cp -Rv envlab.{cfg,sty} ${D}/usr/share/texmf/tex/latex/envlab
+ dodoc elguide.pdf envlab.pdf readme.v12
+ eend
+}
+
+pkg_postinst() {
+ ebegin "Updating LaTeX Module Index"
+ texhash
+ eend
+}
+
+pkg_postrm() {
+ ebegin "Updating LaTeX Module Index"
+ texhash
+ eend
+}