summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2004-06-22 17:03:18 +0000
committerMamoru Komachi <usata@gentoo.org>2004-06-22 17:03:18 +0000
commit356f19eaf93e95509b5265de66182b37af8a0d81 (patch)
tree4533521d6efe417fbf12cf6e408882d7c4ed2ab5 /dev-tex/preview-latex
parentLicense for upcoming app-sci/vienna-rna package (diff)
downloadgentoo-2-356f19eaf93e95509b5265de66182b37af8a0d81.tar.gz
gentoo-2-356f19eaf93e95509b5265de66182b37af8a0d81.tar.bz2
gentoo-2-356f19eaf93e95509b5265de66182b37af8a0d81.zip
Force emake -j1 and fix xemacs IUSE flag, closing bug #54706
Diffstat (limited to 'dev-tex/preview-latex')
-rw-r--r--dev-tex/preview-latex/ChangeLog6
-rw-r--r--dev-tex/preview-latex/preview-latex-0.7.8.ebuild53
-rw-r--r--dev-tex/preview-latex/preview-latex-0.8.1.ebuild53
3 files changed, 57 insertions, 55 deletions
diff --git a/dev-tex/preview-latex/ChangeLog b/dev-tex/preview-latex/ChangeLog
index 32bd1206ba5c..3c32719ae4d4 100644
--- a/dev-tex/preview-latex/ChangeLog
+++ b/dev-tex/preview-latex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-tex/preview-latex
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/ChangeLog,v 1.7 2004/06/19 08:10:55 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/ChangeLog,v 1.8 2004/06/22 17:03:18 usata Exp $
+
+ 23 Jun 2004; Mamoru KOMACHI <usata@gentoo.org> preview-latex-0.7.8.ebuild,
+ preview-latex-0.8.1.ebuild:
+ Force emake -j1 and fix xemacs IUSE flag, closing bug #54706
19 Jun 2004; Mamoru KOMACHI <usata@gentoo.org> preview-latex-0.7.8.ebuild,
preview-latex-0.8.1.ebuild:
diff --git a/dev-tex/preview-latex/preview-latex-0.7.8.ebuild b/dev-tex/preview-latex/preview-latex-0.7.8.ebuild
index f3b4223a474d..f5334d956638 100644
--- a/dev-tex/preview-latex/preview-latex-0.7.8.ebuild
+++ b/dev-tex/preview-latex/preview-latex-0.7.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/preview-latex-0.7.8.ebuild,v 1.5 2004/06/19 08:10:55 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/preview-latex-0.7.8.ebuild,v 1.6 2004/06/22 17:03:18 usata Exp $
inherit latex-package elisp-common
@@ -13,9 +13,13 @@ KEYWORDS="x86"
IUSE="emacs xemacs"
# if you don't have either emacs or xemacs, defaults to emacs. bug #54183
-DEPEND="emacs? ( virtual/emacs >=app-emacs/auctex-11.14 )
- xemacs? ( virtual/xemacs >=app-xemacs/auctex-1.32 )
- !emacs? ( !xemacs? ( virtual/emacs >=app-emacs/auctex-11.14 ) )
+DEPEND="emacs? ( virtual/emacs
+ >=app-emacs/auctex-11.14 )
+ xemacs? ( virtual/xemacs
+ >=app-xemacs/auctex-1.32
+ app-xemacs/fsf-compat )
+ !xemacs? ( virtual/emacs
+ >=app-emacs/auctex-11.14 )
virtual/ghostscript
virtual/tetex"
@@ -27,40 +31,35 @@ src_unpack() {
src_compile() {
local myconf
- if use emacs || use xemacs; then
- if use emacs; then
- econf --with-emacs \
- --with-lispdir=${D}/usr/share/emacs/site-lisp/${PN} \
- || die
- emake || die
- fi
- if use xemacs; then
- cd ${T}
- econf --with-xemacs \
- --with-packagedir=${D}/usr/lib/xemacs/site-packages \
- || die
- emake || die
- fi
- else
- econf || die
- emake || die
+ if use emacs || ! use xemacs ; then
+ econf --with-emacs \
+ --with-lispdir=${D}/usr/share/emacs/site-lisp/${PN} \
+ || die
+ emake -j1 || die "make ${PN} for emacs failed"
+ fi
+ if use xemacs; then
+ cd ${T}
+ econf --with-xemacs \
+ --with-packagedir=${D}/usr/lib/xemacs/site-packages \
+ || die
+ emake -j1 || die "make ${PN} for xemacs failed"
fi
}
src_install() {
- # hack.- we cant call texhash within the make install because of
- # sandbox violations. doing it later by hand
- einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
- dodoc ChangeLog FAQ INSTALL PROBLEMS README RELEASE TODO doc/preview-latex.dvi
- if use emacs ; then
+ if use emacs || ! use xemacs ; then
+ # hack.- we cant call texhash within the make install because of
+ # sandbox violations. doing it later by hand
+ einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
elisp-site-file-install ${FILESDIR}/60preview-latex-gentoo.el
fi
-
if use xemacs; then
cd ${T}
einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
fi
+
+ dodoc ChangeLog FAQ INSTALL PROBLEMS README RELEASE TODO doc/preview-latex.dvi
}
pkg_postinst() {
diff --git a/dev-tex/preview-latex/preview-latex-0.8.1.ebuild b/dev-tex/preview-latex/preview-latex-0.8.1.ebuild
index f9959c27cd35..f34a2f343d07 100644
--- a/dev-tex/preview-latex/preview-latex-0.8.1.ebuild
+++ b/dev-tex/preview-latex/preview-latex-0.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/preview-latex-0.8.1.ebuild,v 1.5 2004/06/19 08:10:55 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/preview-latex/preview-latex-0.8.1.ebuild,v 1.6 2004/06/22 17:03:18 usata Exp $
inherit latex-package elisp-common
@@ -15,9 +15,13 @@ KEYWORDS="x86 ~sparc"
IUSE="emacs xemacs"
# if you don't have either emacs or xemacs, defaults to emacs. bug #54183
-DEPEND="emacs? ( virtual/emacs >=app-emacs/auctex-11.14 )
- xemacs? ( virtual/xemacs >=app-xemacs/auctex-1.32 )
- !emacs? ( !xemacs? ( virtual/emacs >=app-emacs/auctex-11.14 ) )
+DEPEND="emacs? ( virtual/emacs
+ >=app-emacs/auctex-11.14 )
+ xemacs? ( virtual/xemacs
+ >=app-xemacs/auctex-1.32
+ app-xemacs/fsf-compat )
+ !xemacs? ( virtual/emacs
+ >=app-emacs/auctex-11.14 )
virtual/ghostscript
virtual/tetex"
@@ -30,40 +34,35 @@ src_compile() {
local myconf
export LC_ALL=en_US.ISO8859-1
- if use emacs || use xemacs; then
- if use emacs; then
- econf --with-emacs \
- --with-lispdir=${D}/usr/share/emacs/site-lisp/${PN} \
- || die
- emake || die
- fi
- if use xemacs; then
- cd ${T}
- econf --with-xemacs \
- --with-packagedir=${D}/usr/lib/xemacs/site-packages \
- || die
- emake || die
- fi
- else
- econf || die
- emake || die
+ if use emacs || ! use xemacs ; then
+ econf --with-emacs \
+ --with-lispdir=${D}/usr/share/emacs/site-lisp/${PN} \
+ || die
+ emake -j1 || die "make ${PN} for emacs failed"
+ fi
+ if use xemacs; then
+ cd ${T}
+ econf --with-xemacs \
+ --with-packagedir=${D}/usr/lib/xemacs/site-packages \
+ || die
+ emake -j1 || die "make ${PN} for xemacs failed"
fi
}
src_install() {
- # hack.- we cant call texhash within the make install because of
- # sandbox violations. doing it later by hand
- einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
- dodoc ChangeLog FAQ INSTALL PROBLEMS README RELEASE TODO doc/preview-latex.dvi
- if use emacs ; then
+ if use emacs || ! use xemacs ; then
+ # hack.- we cant call texhash within the make install because of
+ # sandbox violations. doing it later by hand
+ einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
elisp-site-file-install ${FILESDIR}/60preview-latex-gentoo.el
fi
-
if use xemacs; then
cd ${T}
einstall texmfdir=${D}${TEXMF} TEXHASH=/bin/true || die
fi
+
+ dodoc ChangeLog FAQ INSTALL PROBLEMS README RELEASE TODO doc/preview-latex.dvi
}
pkg_postinst() {