summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-10-25 01:12:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-10-25 01:12:57 +0000
commitc2aea98875d00d3e8e3d55738b3b484609744277 (patch)
tree8f0abf621048f1ea54bff734ba7cbbb519b041c0 /dev-tex
parentbump glossaries dep to the latest (diff)
downloadgentoo-2-c2aea98875d00d3e8e3d55738b3b484609744277.tar.gz
gentoo-2-c2aea98875d00d3e8e3d55738b3b484609744277.tar.bz2
gentoo-2-c2aea98875d00d3e8e3d55738b3b484609744277.zip
version bump
(Portage version: 2.2.0_alpha1/cvs/Linux x86_64)
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/mh/ChangeLog7
-rw-r--r--dev-tex/mh/mh-20101024.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-tex/mh/ChangeLog b/dev-tex/mh/ChangeLog
index b716e70f6e03..eced9d96ae1f 100644
--- a/dev-tex/mh/ChangeLog
+++ b/dev-tex/mh/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-tex/mh
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.21 2010/01/03 11:40:06 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/ChangeLog,v 1.22 2010/10/25 01:12:57 aballier Exp $
+
+*mh-20101024 (25 Oct 2010)
+
+ 25 Oct 2010; Alexis Ballier <aballier@gentoo.org> +mh-20101024.ebuild:
+ version bump
03 Jan 2010; Christian Faulhammer <fauli@gentoo.org> mh-20080903.ebuild:
Transfer Prefix keywords
diff --git a/dev-tex/mh/mh-20101024.ebuild b/dev-tex/mh/mh-20101024.ebuild
new file mode 100644
index 000000000000..74adc878899a
--- /dev/null
+++ b/dev-tex/mh/mh-20101024.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tex/mh/mh-20101024.ebuild,v 1.1 2010/10/25 01:12:57 aballier Exp $
+
+inherit latex-package
+
+DESCRIPTION="Additional LaTeX math tools."
+HOMEPAGE="http://www.ctan.org/tex-archive/macros/latex/contrib/mh/"
+SRC_URI="mirror://gentoo/${P}.zip"
+LICENSE="LPPL-1.3"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+
+RDEPEND="dev-tex/xcolor
+ >=dev-texlive/texlive-latex3-2008"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}/${PN}
+TEXMF=/usr/share/texmf-site
+
+src_compile() {
+ # To avoid sandbox violations
+ export VARTEXFONTS="${T}/fonts"
+
+ # Unpacking *.dtx
+ for i in *.dtx; do
+ tex ${i} || die "TeXing ${i} failed"
+ done
+
+ latex-package_src_compile
+}
+
+src_install() {
+ latex-package_src_doinstall styles fonts bin
+
+ insinto "${TEXMF}/tex/latex/${PN}"
+ doins *.sym
+
+ use doc && latex-package_src_doinstall doc
+ dodoc README
+}