summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2010-03-24 19:14:04 +0000
committerMounir Lamouri <volkmar@gentoo.org>2010-03-24 19:14:04 +0000
commit94cc6300ddff5b257f0bc6757dbd04aed3ca0fcb (patch)
tree7d4826e88d37e42394f0e5e269a80c0877217b67 /dev-util/bam/bam-0.2.0.ebuild
parentstable x86, bug 310183 (diff)
downloadgentoo-2-94cc6300ddff5b257f0bc6757dbd04aed3ca0fcb.tar.gz
gentoo-2-94cc6300ddff5b257f0bc6757dbd04aed3ca0fcb.tar.bz2
gentoo-2-94cc6300ddff5b257f0bc6757dbd04aed3ca0fcb.zip
Initial commit.
Package required for teeworlds, bug 206287. (Portage version: 15511-svn/cvs/Linux i686)
Diffstat (limited to 'dev-util/bam/bam-0.2.0.ebuild')
-rw-r--r--dev-util/bam/bam-0.2.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/bam/bam-0.2.0.ebuild b/dev-util/bam/bam-0.2.0.ebuild
new file mode 100644
index 000000000000..e734a5283c0f
--- /dev/null
+++ b/dev-util/bam/bam-0.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bam/bam-0.2.0.ebuild,v 1.1 2010/03/24 19:14:04 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="Fast and flexible Lua-based build system"
+HOMEPAGE="http://matricks.github.com/bam/"
+SRC_URI="http://github.com/downloads/matricks/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-gentoo.tar.bz2"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc test"
+
+RDEPEND="dev-lang/lua"
+DEPEND="${RDEPEND}
+ doc? ( dev-lang/python )
+ test? ( dev-lang/python )"
+
+src_prepare() {
+ cp "${WORKDIR}"/Makefile "${S}"/Makefile || die "cp failed"
+
+ if use test; then
+ epatch "${WORKDIR}"/${P}-test.py.patch
+ fi
+}
+
+src_compile() {
+ emake txt2c || die "emake failed"
+ emake internal_base || die "emake failed"
+ emake ${PN} || die "emake failed"
+
+ if use doc; then
+ python scripts/gendocs.py || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ dobin src/${PN} || die "dobin failed"
+ doman "${WORKDIR}"/${PN}.1 || die "doman failed"
+
+ if use doc; then
+ dohtml docs/${PN}{.html,_logo.png} || die "dohtml failed"
+ fi
+}