summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-01-23 00:20:15 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-01-23 00:20:15 +0000
commit26e0b3a362dd921d43c7b92d455896aefe1fb0fb (patch)
treea8a5e299f41f9fa1aba2e432c2931e8945ddaea9 /dev-util/bazaar/bazaar-1.1.1.ebuild
parentSetting virtual/x11 DEPEND based on X USE flag and closing bug #77826. (diff)
downloadgentoo-2-26e0b3a362dd921d43c7b92d455896aefe1fb0fb.tar.gz
gentoo-2-26e0b3a362dd921d43c7b92d455896aefe1fb0fb.tar.bz2
gentoo-2-26e0b3a362dd921d43c7b92d455896aefe1fb0fb.zip
new version
(Portage version: 2.0.51-r14)
Diffstat (limited to 'dev-util/bazaar/bazaar-1.1.1.ebuild')
-rw-r--r--dev-util/bazaar/bazaar-1.1.1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/dev-util/bazaar/bazaar-1.1.1.ebuild b/dev-util/bazaar/bazaar-1.1.1.ebuild
new file mode 100644
index 000000000000..3d8822778fd8
--- /dev/null
+++ b/dev-util/bazaar/bazaar-1.1.1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bazaar/bazaar-1.1.1.ebuild,v 1.1 2005/01/23 00:20:15 arj Exp $
+
+S="${WORKDIR}/${P}/src/=build"
+DESCRIPTION="Bazaar is a user-interface branch of tla"
+SRC_URI="http://bazaar.canonical.com/releases/src/bazaar_${PV}.tar.gz"
+HOMEPAGE="http://bazaar.canonical.com/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DIR="thelove@canonical.com---dists--bazaar--1.1"
+
+DEPEND="sys-apps/coreutils
+ sys-apps/diffutils
+ sys-devel/patch
+ sys-apps/findutils
+ sys-apps/gawk
+ app-arch/tar
+ sys-apps/util-linux
+ sys-apps/debianutils
+ sys-devel/make
+ >=net-misc/neon-0.24.7"
+
+src_unpack() {
+ unpack "${A}"
+ mv ${DIR} ${P}
+ mkdir "${P}/src/=build"
+}
+
+src_compile() {
+ ../configure \
+ --prefix="/usr" \
+ --with-posix-shell="/bin/bash" || die "configure failed"
+ # parallel make may cause problems with this package
+ make || die "make failed"
+}
+
+src_install () {
+ make install prefix="${D}/usr" \
+ || die "make install failed"
+
+ cd ${WORKDIR}/${P}/
+ dodoc =ARCH-USERS-README
+ cd ${WORKDIR}/${P}/src
+ dodoc COPYING
+ cd docs-baz
+ dodoc =README
+ docinto ps
+ dodoc ps/*.ps
+ docinto html
+ dohtml -r html/
+}