summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-08-14 06:35:54 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-08-14 06:35:54 +0000
commit94c770f2bd45f017c1f4ba5837913c8f848e74b9 (patch)
treee454d7e88a53d7a578d73ce6cf8847718cc387ed /dev-util/boost-build/boost-build-1.35.0-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-94c770f2bd45f017c1f4ba5837913c8f848e74b9.tar.gz
gentoo-2-94c770f2bd45f017c1f4ba5837913c8f848e74b9.tar.bz2
gentoo-2-94c770f2bd45f017c1f4ba5837913c8f848e74b9.zip
Fix build failures when compiler flags contain whitespace (bug #293652 by
Sebastian Luther). (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/boost-build/boost-build-1.35.0-r1.ebuild')
-rw-r--r--dev-util/boost-build/boost-build-1.35.0-r1.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-util/boost-build/boost-build-1.35.0-r1.ebuild b/dev-util/boost-build/boost-build-1.35.0-r1.ebuild
index 39190cb64cc7..04376254fcbe 100644
--- a/dev-util/boost-build/boost-build-1.35.0-r1.ebuild
+++ b/dev-util/boost-build/boost-build-1.35.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0-r1.ebuild,v 1.10 2009/05/15 14:48:21 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/boost-build/boost-build-1.35.0-r1.ebuild,v 1.11 2010/08/14 06:35:54 dirtyepic Exp $
inherit flag-o-matic toolchain-funcs versionator
@@ -66,6 +66,7 @@ src_compile() {
CC=$(tc-getCC) ./build.sh ${toolset} $(use_with python) \
|| die "building bjam failed"
else
+ LDFLAGS=$(echo ${LDFLAGS}) # 293652
LIBS=${LDFLAGS} CC=$(tc-getCC) ./build.sh ${toolset} \
$(use_with python) || die "building bjam failed"
fi