summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-08-17 23:13:40 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-08-17 23:13:40 +0000
commitb09a47ebacf6079074a4bdd52983a53200e1a066 (patch)
tree6c1250b7d700c2eb73b17c2523731aedb9683b9d /dev-util/bouml
parentUpgraded cacheupdate.sh, bug #162313 (diff)
downloadgentoo-2-b09a47ebacf6079074a4bdd52983a53200e1a066.tar.gz
gentoo-2-b09a47ebacf6079074a4bdd52983a53200e1a066.tar.bz2
gentoo-2-b09a47ebacf6079074a4bdd52983a53200e1a066.zip
Version bump, fixes bug #189045
(Portage version: 2.1.2.11)
Diffstat (limited to 'dev-util/bouml')
-rw-r--r--dev-util/bouml/ChangeLog7
-rw-r--r--dev-util/bouml/bouml-2.30.2.ebuild33
-rw-r--r--dev-util/bouml/files/digest-bouml-2.30.23
3 files changed, 42 insertions, 1 deletions
diff --git a/dev-util/bouml/ChangeLog b/dev-util/bouml/ChangeLog
index fc35b5107871..5e8024b291f3 100644
--- a/dev-util/bouml/ChangeLog
+++ b/dev-util/bouml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/bouml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.29 2007/06/06 12:14:43 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/ChangeLog,v 1.30 2007/08/17 23:13:40 ferdy Exp $
+
+*bouml-2.30.2 (17 Aug 2007)
+
+ 17 Aug 2007; Fernando J. Pereda <ferdy@gentoo.org> +bouml-2.30.2.ebuild:
+ Version bump, fixes bug #189045
*bouml-2.27 (06 Jun 2007)
diff --git a/dev-util/bouml/bouml-2.30.2.ebuild b/dev-util/bouml/bouml-2.30.2.ebuild
new file mode 100644
index 000000000000..0daaf9f6b5bc
--- /dev/null
+++ b/dev-util/bouml/bouml-2.30.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-2.30.2.ebuild,v 1.1 2007/08/17 23:13:40 ferdy Exp $
+
+inherit qt3 toolchain-funcs multilib eutils
+
+MY_P="${PN}_${PV}"
+
+DESCRIPTION="Free UML 2 tool box with C++, Java and Idl code generation"
+HOMEPAGE="http://bouml.free.fr/"
+SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake QMAKE="${QTDIR}/bin/qmake" \
+ CC="$(tc-getCC) ${CFLAGS}" \
+ CXX="$(tc-getCXX) ${CXXFLAGS}" \
+ LINK="$(tc-getCXX) ${LDFLAGS}" \
+ || die "emake failed"
+}
+
+src_install() {
+ emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/dev-util/bouml/files/digest-bouml-2.30.2 b/dev-util/bouml/files/digest-bouml-2.30.2
new file mode 100644
index 000000000000..11c360f6e06c
--- /dev/null
+++ b/dev-util/bouml/files/digest-bouml-2.30.2
@@ -0,0 +1,3 @@
+MD5 1232a026271cb09fa02b6763a739b8d4 bouml_2.30.2.tar.gz 3951873
+RMD160 1bf15d0264a7f2f506158f13a1eb6eb54be5bff1 bouml_2.30.2.tar.gz 3951873
+SHA256 cd96076dec6f4d4c57177bb9dd8ce2cc15522276bd60baff0d672f0cc91eec39 bouml_2.30.2.tar.gz 3951873