summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-11-24 08:35:29 +0000
committerSamuli Suominen <drac@gentoo.org>2007-11-24 08:35:29 +0000
commitb2ec5fb348f8c3d2c5d110f600c6dc0a75baa239 (patch)
tree6b8ce26692bc663786f3e52ee38443bfdbc05cc6 /dev-util/bunny/bunny-0.92.ebuild
parentversion bump (diff)
downloadgentoo-2-b2ec5fb348f8c3d2c5d110f600c6dc0a75baa239.tar.gz
gentoo-2-b2ec5fb348f8c3d2c5d110f600c6dc0a75baa239.tar.bz2
gentoo-2-b2ec5fb348f8c3d2c5d110f600c6dc0a75baa239.zip
Initial commit, ebuild by drear from freenode.
(Portage version: 2.1.4_rc2)
Diffstat (limited to 'dev-util/bunny/bunny-0.92.ebuild')
-rw-r--r--dev-util/bunny/bunny-0.92.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/bunny/bunny-0.92.ebuild b/dev-util/bunny/bunny-0.92.ebuild
new file mode 100644
index 000000000000..533bbb51999c
--- /dev/null
+++ b/dev-util/bunny/bunny-0.92.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bunny/bunny-0.92.ebuild,v 1.1 2007/11/24 08:35:28 drac Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A small general purpose fuzzer for C programs."
+HOMEPAGE="http://code.google.com/p/bunny-the-fuzzer"
+SRC_URI="http://bunny-the-fuzzer.googlecode.com/files/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ || die "emake failed"
+}
+
+src_test() {
+ emake test1 || die "emake test1 failed."
+ emake test2 || die "emake test2 failed."
+ emake test3 || die "emake test3 failed."
+}
+
+src_install() {
+ dobin ${PN}-{exec,flow,gcc,main,trace}
+ dodoc CHANGES README
+}