summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2015-08-02 19:14:53 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2015-08-02 19:14:53 +0000
commita4e192b1a3cea1356b9e84e419e813c84fc3a7d4 (patch)
tree7bc40d7f04aadccb1df84989075eaa7a695c3669 /dev-util/bustle
parentBinding to the Gtk+-3 graphical user interface library, a depend for dev-util... (diff)
downloadgentoo-2-a4e192b1a3cea1356b9e84e419e813c84fc3a7d4.tar.gz
gentoo-2-a4e192b1a3cea1356b9e84e419e813c84fc3a7d4.tar.bz2
gentoo-2-a4e192b1a3cea1356b9e84e419e813c84fc3a7d4.zip
Version bump.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-util/bustle')
-rw-r--r--dev-util/bustle/ChangeLog8
-rw-r--r--dev-util/bustle/bustle-0.5.1.ebuild70
-rw-r--r--dev-util/bustle/metadata.xml7
3 files changed, 81 insertions, 4 deletions
diff --git a/dev-util/bustle/ChangeLog b/dev-util/bustle/ChangeLog
index d2e577da37b3..ce66eb639d32 100644
--- a/dev-util/bustle/ChangeLog
+++ b/dev-util/bustle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/bustle
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.26 2015/07/21 21:00:26 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/ChangeLog,v 1.27 2015/08/02 19:14:53 slyfox Exp $
+
+*bustle-0.5.1 (02 Aug 2015)
+
+ 02 Aug 2015; Sergei Trofimovich <slyfox@gentoo.org> +bustle-0.5.1.ebuild,
+ metadata.xml:
+ Version bump.
21 Jul 2015; Manuel Rüger <mrueg@gentoo.org> -bustle-0.2.3.ebuild,
-bustle-0.4.0.ebuild, -bustle-0.4.2.ebuild:
diff --git a/dev-util/bustle/bustle-0.5.1.ebuild b/dev-util/bustle/bustle-0.5.1.ebuild
new file mode 100644
index 000000000000..7ea22b872f79
--- /dev/null
+++ b/dev-util/bustle/bustle-0.5.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.5.1.ebuild,v 1.1 2015/08/02 19:14:53 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="bin test-suite"
+inherit eutils haskell-cabal
+
+DESCRIPTION="Draw sequence diagrams of D-Bus traffic"
+HOMEPAGE="http://hackage.haskell.org/package/bustle"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="interactivetests +threaded"
+
+RDEPEND="dev-haskell/cairo:=
+ >=dev-haskell/dbus-0.10:=
+ dev-haskell/gio:=
+ dev-haskell/glib:=
+ >=dev-haskell/gtk3-0.13.7:0=
+ >=dev-haskell/hgettext-0.1.5:=
+ dev-haskell/mtl:=
+ dev-haskell/pango:=
+ dev-haskell/parsec:=
+ dev-haskell/pcap:=
+ dev-haskell/setlocale:=
+ dev-haskell/text:=
+ >=dev-lang/ghc-7.4.1:=
+ dev-libs/glib:2
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ virtual/pkgconfig
+ test? ( dev-haskell/hunit
+ dev-haskell/quickcheck
+ dev-haskell/test-framework
+ dev-haskell/test-framework-hunit )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag interactivetests interactivetests) \
+ $(cabal_flag threaded threaded)
+}
+
+src_compile() {
+ # compile haskell part
+ cabal_src_compile || die "could not build haskell parts"
+
+ # compile C part
+ emake \
+ "CC=$(tc-getCC)" \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}"
+}
+
+src_install() {
+ # install haskell part
+ cabal_src_install || die "could not install haskell parts"
+
+ dobin "${S}"/dist/build/bustle-pcap
+ doman bustle-pcap.1
+ dodoc README.md HACKING.md NEWS.md
+}
diff --git a/dev-util/bustle/metadata.xml b/dev-util/bustle/metadata.xml
index c7324b97b3e2..d2e02d93825d 100644
--- a/dev-util/bustle/metadata.xml
+++ b/dev-util/bustle/metadata.xml
@@ -2,10 +2,11 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>haskell</herd>
- <maintainer>
- <email>haskell@gentoo.org</email>
- </maintainer>
<longdescription>
Draw pretty sequence diagrams of D-Bus traffic
</longdescription>
+ <use>
+ <flag name="interactivetests">Build interactive test programs</flag>
+ <flag name="threaded">Build with support for multithreaded execution.</flag>
+ </use>
</pkgmetadata>