summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZack Welch <zwelch@gentoo.org>2003-02-26 19:26:37 +0000
committerZack Welch <zwelch@gentoo.org>2003-02-26 19:26:37 +0000
commit8671877baf56cfe8944e5d289a0d366d286d2e41 (patch)
tree087ef5d15f9691a2ca3cfe261a4a18db139d21df /dev-util/ccache
parentbug 12393: addwrite QTDIr/etc/settings if needed (diff)
downloadgentoo-2-8671877baf56cfe8944e5d289a0d366d286d2e41.tar.gz
gentoo-2-8671877baf56cfe8944e5d289a0d366d286d2e41.tar.bz2
gentoo-2-8671877baf56cfe8944e5d289a0d366d286d2e41.zip
add new version of ccache
Diffstat (limited to 'dev-util/ccache')
-rw-r--r--dev-util/ccache/ChangeLog7
-rw-r--r--dev-util/ccache/ccache-2.2.ebuild69
-rw-r--r--dev-util/ccache/files/digest-ccache-2.21
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-util/ccache/ChangeLog b/dev-util/ccache/ChangeLog
index c9c0344e7249..6de63d7d3b7f 100644
--- a/dev-util/ccache/ChangeLog
+++ b/dev-util/ccache/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/ccache
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.17 2003/02/25 20:18:02 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ChangeLog,v 1.18 2003/02/26 19:26:37 zwelch Exp $
+
+*ccache-2.2 (26 Feb 2003)
+
+ 26 Feb 2003; Zach Welch <zwelch@gentoo.org> ccache-2.2.ebuild files/digest-ccache-2.2 :
+ Bump to new version; see bug 15100
*ccache-2.1.1-r2 (24 Feb 2003)
diff --git a/dev-util/ccache/ccache-2.2.ebuild b/dev-util/ccache/ccache-2.2.ebuild
new file mode 100644
index 000000000000..57fa930cb572
--- /dev/null
+++ b/dev-util/ccache/ccache-2.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ccache/ccache-2.2.ebuild,v 1.1 2003/02/26 19:26:37 zwelch Exp $
+
+DESCRIPTION="ccache is a fast compiler cache. It is used as a front end to your
+compiler to safely cache compilation output. When the same code is compiled
+again the cached output is used giving a significant speedup."
+SRC_URI="http://ccache.samba.org/ftp/ccache/${P}.tar.gz"
+HOMEPAGE="http://ccache.samba.org/"
+
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha arm"
+DEPEND="virtual/glibc \
+ >=sys-apps/portage-2.0.46-r11"
+
+# Note: this version is designed to be auto-detected and used if
+# you happen to have Portage 2.0.X+ installed.
+
+src_compile() {
+ econf || die
+ emake || die
+}
+
+src_install () {
+ exeinto /usr/bin
+ doexe ccache
+ doman ccache.1
+ dodoc COPYING README
+
+ diropts -m0755
+ dodir /usr/lib/ccache/bin
+ keepdir /usr/lib/ccache/bin
+
+ exeinto /usr/bin
+ doexe ${FILESDIR}/ccache-config
+
+ diropts -m0700
+ dodir /root/.ccache
+ keepdir /root/.ccache
+}
+
+pkg_preinst() {
+ # Portage doesn't handle replacing a non-empty dir with a file!
+ [ -e /usr/bin/ccache ] && rm -rf /usr/bin/ccache
+ [ -e /usr/bin/ccache.backup ] && rm -rf /usr/bin/ccache.backup
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Scanning for compiler front-ends..."
+ /usr/bin/ccache-config --install-links
+ /usr/bin/ccache-config --install-links ${CHOST}
+ else
+ ewarn "Install is incomplete; you must run the following commands:"
+ ewarn " # ccache-config --install-links"
+ ewarn " # ccache-config --install-links ${CHOST}"
+ ewarn "after booting or chrooting to ${ROOT} to complete installation."
+ fi
+
+ einfo "To use ccache with **non-Portage** C compiling, add"
+ einfo "/usr/lib/ccache/bin to the beginning of your path, before /usr/bin."
+ einfo "Portage 2.0.46-r11+ will automatically take advantage of ccache with"
+ einfo "no additional steps. If this is your first install of ccache, type"
+ einfo "something like this to set a maximum cache size of 2GB:"
+ einfo "# ccache -M 2G"
+}
+
diff --git a/dev-util/ccache/files/digest-ccache-2.2 b/dev-util/ccache/files/digest-ccache-2.2
new file mode 100644
index 000000000000..0d99f4079869
--- /dev/null
+++ b/dev-util/ccache/files/digest-ccache-2.2
@@ -0,0 +1 @@
+MD5 3b98afe5e966ccd37f4d2b102d6ac8ac ccache-2.2.tar.gz 81666