summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2013-05-27 06:07:23 +0000
committerTiziano Müller <dev-zero@gentoo.org>2013-05-27 06:07:23 +0000
commita622b4c7c0c12047900161158e54aaf350ca5b92 (patch)
treeb47c9a42a0cc4d9dff625fb89679b188442d69a9 /dev-util/cflow/cflow-1.4.ebuild
parentCleanup. (diff)
downloadgentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.tar.gz
gentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.tar.bz2
gentoo-2-a622b4c7c0c12047900161158e54aaf350ca5b92.zip
Version bump (bug #469172) including EAPI-5 bump/usage and dependency fixes. Drop old.
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0x1E0CA85F!)
Diffstat (limited to 'dev-util/cflow/cflow-1.4.ebuild')
-rw-r--r--dev-util/cflow/cflow-1.4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/cflow/cflow-1.4.ebuild b/dev-util/cflow/cflow-1.4.ebuild
new file mode 100644
index 000000000000..c872bc80d005
--- /dev/null
+++ b/dev-util/cflow/cflow-1.4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cflow/cflow-1.4.ebuild,v 1.1 2013/05/27 06:07:23 dev-zero Exp $
+
+EAPI="5"
+
+inherit elisp-common eutils
+
+DESCRIPTION="C function call hierarchy analyzer"
+HOMEPAGE="http://www.gnu.org/software/cflow/"
+SRC_URI="ftp://download.gnu.org.ua/pub/release/cflow/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug emacs nls"
+
+RDEPEND="emacs? ( virtual/emacs )
+ nls? ( virtual/libintl virtual/libiconv )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-info-direntry.patch"
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ EMACS=no
+}
+
+src_compile() {
+ default
+
+ if use emacs; then
+ elisp-compile elisp/cflow-mode.el
+ fi
+}
+
+src_install() {
+ default
+ doinfo doc/cflow.info
+
+ if use emacs; then
+ elisp-install ${PN} elisp/cflow-mode.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}