summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-09-12 20:03:36 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-09-12 20:03:36 +0000
commit77364c27f1542b14a63a98a8a1da07c5eb5094f5 (patch)
treecee5d1f7d1541219a97dd52a752ff2ddc97595b5 /dev-util/checkstyle
parentCorrected metadata.xml to match DTD. (Manifest recommit) (diff)
downloadgentoo-2-77364c27f1542b14a63a98a8a1da07c5eb5094f5.tar.gz
gentoo-2-77364c27f1542b14a63a98a8a1da07c5eb5094f5.tar.bz2
gentoo-2-77364c27f1542b14a63a98a8a1da07c5eb5094f5.zip
no longer uses packed jars, bug 63306
Diffstat (limited to 'dev-util/checkstyle')
-rw-r--r--dev-util/checkstyle/ChangeLog7
-rw-r--r--dev-util/checkstyle/Manifest12
-rw-r--r--dev-util/checkstyle/checkstyle-3.4-r1.ebuild62
-rw-r--r--dev-util/checkstyle/files/digest-checkstyle-3.4-r11
4 files changed, 71 insertions, 11 deletions
diff --git a/dev-util/checkstyle/ChangeLog b/dev-util/checkstyle/ChangeLog
index 222e7deddb84..3571d128142b 100644
--- a/dev-util/checkstyle/ChangeLog
+++ b/dev-util/checkstyle/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/checkstyle
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.4 2004/08/30 18:28:06 zx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/ChangeLog,v 1.5 2004/09/12 20:03:36 axxo Exp $
+
+*checkstyle-3.4-r1 (12 Sep 2004)
+
+ 12 Sep 2004; Thomas Matthijs <axxo@gentoo.org> +checkstyle-3.4-r1.ebuild:
+ no longer uses packed jars, bug 63306
*checkstyle-3.4 (30 Aug 2004)
diff --git a/dev-util/checkstyle/Manifest b/dev-util/checkstyle/Manifest
index b69e81ec77ad..4659520d2dd4 100644
--- a/dev-util/checkstyle/Manifest
+++ b/dev-util/checkstyle/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 5a0af06c66e04fe8eddc9d6e0a827d15 checkstyle-3.4-r1.ebuild 1754
MD5 670082724fff8fc0675c6b047a102726 checkstyle-3.4.ebuild 1402
MD5 946d15e4a0e7ee14cd7d065c05128b68 checkstyle-3.3.ebuild 1381
MD5 b87b7e76dbd53c3448ffe1291dc5906c ChangeLog 659
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 3bfc61fcf1ab108f7cf96aef2c3acd0e files/digest-checkstyle-3.3 71
MD5 ee7955e25b09c5307250330d16910077 files/digest-checkstyle-3.4 71
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBOenW/rLF9B432nYRAiKSAKCEeAtowSh6/HjA0gbIXQrBIT3uWQCeLxQZ
-5sviPa2Ya+Vq8O20dr+7IPI=
-=+Vxf
------END PGP SIGNATURE-----
+MD5 ee7955e25b09c5307250330d16910077 files/digest-checkstyle-3.4-r1 71
diff --git a/dev-util/checkstyle/checkstyle-3.4-r1.ebuild b/dev-util/checkstyle/checkstyle-3.4-r1.ebuild
new file mode 100644
index 000000000000..0500a341d33c
--- /dev/null
+++ b/dev-util/checkstyle/checkstyle-3.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/checkstyle/checkstyle-3.4-r1.ebuild,v 1.1 2004/09/12 20:03:36 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="A development tool to help programmers write Java code that adheres to a coding standard."
+HOMEPAGE="http://checkstyle.sourceforge.net"
+SRC_URI="mirror://sourceforge/checkstyle/${PN}-src-${PV}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc"
+IUSE="doc jikes"
+RESTRICT="nomirror"
+
+S=${WORKDIR}/${PN}-src-${PV}
+
+DEPEND=">=virtual/jdk-1.4
+ >=dev-java/ant-1.5
+ jikes? ( dev-java/jikes )"
+
+RDEPEND=">=virtual/jre-1.3
+ dev-java/antlr
+ dev-java/commons-beanutils
+ =dev-java/commons-cli-1*
+ dev-java/commons-collections
+ dev-java/commons-logging
+ >=dev-java/regexp-1.3-r1"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/lib
+ java-pkg_jar-from antlr
+ java-pkg_jar-from commons-beanutils
+ java-pkg_jar-from commons-cli-1
+ java-pkg_jar-from commons-collections
+ java-pkg_jar-from commons-logging
+ java-pkg_jar-from regexp regexp.jar jakarta-regexp-1.3.jar
+ #if use junit; then
+ # java-pkg_jar-from junit
+ #else
+ rm junit.jar
+ #fi
+}
+
+src_compile() {
+ local antflags="compile.checkstyle"
+ use doc && antflags="${antflags} javadoc"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "ant :("
+}
+
+src_install() {
+ insinto /usr/share/checkstyle
+ jar cfm ${P}.jar config/manifest.mf -C target/checkstyle .
+ java-pkg_dojar ${P}.jar
+ use doc && dohtml -r docs/*
+ dodoc README RIGHTS.antlr TODO
+ mv docs/checkstyle_checks.xml ${D}/usr/share/checkstyle/checkstyle_checks.xml
+ mv docs/sun_checks.xml ${D}/usr/share/checkstyle/sun_checks.xml
+ mv contrib ${D}/usr/share/checkstyle
+}
diff --git a/dev-util/checkstyle/files/digest-checkstyle-3.4-r1 b/dev-util/checkstyle/files/digest-checkstyle-3.4-r1
new file mode 100644
index 000000000000..8756cf5ecc04
--- /dev/null
+++ b/dev-util/checkstyle/files/digest-checkstyle-3.4-r1
@@ -0,0 +1 @@
+MD5 39b7e55c7e2103b485e061ab5e42c292 checkstyle-src-3.4.tar.gz 1323474