summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-05-06 15:50:39 +0000
committerPacho Ramos <pacho@gentoo.org>2012-05-06 15:50:39 +0000
commit658ad40ea150bd74779c5783f9632a42c505344a (patch)
tree289b835ce625ddb78ed70b66e41c80b14d84577a /dev-util/ciabot-svn
parentvdr-plugin-2.eclass (diff)
downloadgentoo-2-658ad40ea150bd74779c5783f9632a42c505344a.tar.gz
gentoo-2-658ad40ea150bd74779c5783f9632a42c505344a.tar.bz2
gentoo-2-658ad40ea150bd74779c5783f9632a42c505344a.zip
Let it work with python3 as main interpreter.
(Portage version: 2.1.10.57/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ciabot-svn')
-rw-r--r--dev-util/ciabot-svn/ChangeLog7
-rw-r--r--dev-util/ciabot-svn/ciabot-svn-1.15.ebuild24
2 files changed, 20 insertions, 11 deletions
diff --git a/dev-util/ciabot-svn/ChangeLog b/dev-util/ciabot-svn/ChangeLog
index 379ee2402eb1..d9e3a3364e61 100644
--- a/dev-util/ciabot-svn/ChangeLog
+++ b/dev-util/ciabot-svn/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/ciabot-svn
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ChangeLog,v 1.5 2010/12/18 17:00:24 fauli Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ChangeLog,v 1.6 2012/05/06 15:50:39 pacho Exp $
+
+ 06 May 2012; Pacho Ramos <pacho@gentoo.org> ciabot-svn-1.15.ebuild:
+ Let it work with python3 as main interpreter.
18 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
ciabot-svn-1.15.ebuild:
diff --git a/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild b/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild
index 193b93dce973..eab8861a88b6 100644
--- a/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild
+++ b/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild
@@ -1,8 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild,v 1.5 2010/12/18 17:00:24 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ciabot-svn/ciabot-svn-1.15.ebuild,v 1.6 2012/05/06 15:50:39 pacho Exp $
-inherit eutils
+EAPI="4"
+PYTHON_DEPEND="2"
+
+inherit eutils python
DESCRIPTION="CIA-bot script for Subversion repositories"
HOMEPAGE="http://cia.navi.cx/doc/clients"
@@ -13,20 +16,25 @@ SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
IUSE=""
-DEPEND="dev-lang/python"
+DEPEND=""
+RDEPEND="${DEPEND}"
S=${WORKDIR}
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_install() {
+ python_convert_shebangs -r 2 .
dodir /etc/${PN}
insinto /etc/${PN}
doins "${FILESDIR}"/config.py
-
- newbin ${P}.py ${PN} || die
+ newbin ${P}.py ${PN}
}
pkg_postinst() {
- echo
elog "This ciabot-svn script should be called from your repository's post-commit"
elog "hook with the repository and revision as arguments. For example,"
elog "you could copy this script into your repository's \"hooks\" directory"
@@ -42,6 +50,4 @@ pkg_postinst() {
elog "hook:"
elog ""
elog " /usr/bin/ciabot-svn \"\$REPOS\" \"\$REV\" \"ProjectName\" &"
- echo
- epause
}