summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2006-01-16 10:28:52 +0000
committerLisa M. Seelye <lisa@gentoo.org>2006-01-16 10:28:52 +0000
commit1bfd08482267ca0b1113369d54f8857950814238 (patch)
tree66a5bfc6c3aaf90bddc29a14b6b1f9714f275dac /dev-util/cmake
parentarm/hppa/s390/sh stable (diff)
downloadgentoo-2-1bfd08482267ca0b1113369d54f8857950814238.tar.gz
gentoo-2-1bfd08482267ca0b1113369d54f8857950814238.tar.bz2
gentoo-2-1bfd08482267ca0b1113369d54f8857950814238.zip
Version bump to solve bug #118822
(Portage version: 2.0.54)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/Manifest3
-rw-r--r--dev-util/cmake/cmake-2.2.3.ebuild48
-rw-r--r--dev-util/cmake/files/cmake-2.2.3-rpath-fix.patch11
-rw-r--r--dev-util/cmake/files/digest-cmake-2.2.31
5 files changed, 71 insertions, 2 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 905cf7890a8b..14ab969a22e3 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cmake
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.27 2005/11/08 18:34:00 lisa Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.28 2006/01/16 10:28:52 lisa Exp $
+
+*cmake-2.2.3 (16 Jan 2006)
+
+ 16 Jan 2006; Lisa Seelye <lisa@gentoo.org>
+ +files/cmake-2.2.3-rpath-fix.patch, +cmake-2.2.3.ebuild:
+ Version bump to solve bug #118822
*cmake-2.2.2 (08 Nov 2005)
diff --git a/dev-util/cmake/Manifest b/dev-util/cmake/Manifest
index 0dfd1445747f..a0e7b40735eb 100644
--- a/dev-util/cmake/Manifest
+++ b/dev-util/cmake/Manifest
@@ -3,12 +3,15 @@ MD5 a1898a629719df413be3d7e90ed84322 cmake-2.0.6-r1.ebuild 1004
MD5 a959a6103f04ad2383ccec8c6d0936e8 cmake-2.2.0-r1.ebuild 1223
MD5 0c26b9e9e59ce6a1d2b04334add4e156 cmake-2.2.1.ebuild 1218
MD5 5f9f962830f9997c84e9dd9d3581bd21 cmake-2.2.2.ebuild 1217
+MD5 5f9f962830f9997c84e9dd9d3581bd21 cmake-2.2.3.ebuild 1217
MD5 cc142b07505b203f41d024728adb130f files/cmake-2.0.6-rpath-fix.patch 526
MD5 dd14e025d4b768e7ea416902ddc0b756 files/cmake-2.2.0-rpath-fix.patch 448
MD5 c47657a48f7a256e7cd145d89274b9f1 files/cmake-2.2.1-rpath-fix.patch 444
MD5 4c641d177972ed1be807ccb36d2be4b1 files/cmake-2.2.2-rpath-fix.patch 468
+MD5 495f32261642ab7384a7799fd7ea95aa files/cmake-2.2.3-rpath-fix.patch 468
MD5 beb07080ff2955d2e023b17bc15e6b67 files/digest-cmake-2.0.6-r1 64
MD5 6b3e76d4d01f10ed7f93bb39cc603f8c files/digest-cmake-2.2.0-r1 64
MD5 a1a51ec90e30f352bb6f0aa3822083e7 files/digest-cmake-2.2.1 64
MD5 9368ae4e7af6a751bd768e05ac5ffbca files/digest-cmake-2.2.2 64
+MD5 f05c3286551810b5b0fb9350486b3de4 files/digest-cmake-2.2.3 64
MD5 c7008534123f6886fbc11f82417c0b39 metadata.xml 347
diff --git a/dev-util/cmake/cmake-2.2.3.ebuild b/dev-util/cmake/cmake-2.2.3.ebuild
new file mode 100644
index 000000000000..d4665ab47160
--- /dev/null
+++ b/dev-util/cmake/cmake-2.2.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.2.3.ebuild,v 1.1 2006/01/16 10:28:52 lisa Exp $
+
+inherit debug flag-o-matic qt3 toolchain-funcs eutils
+
+SHORT_PV=2.2
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v${SHORT_PV}/${P}.tar.gz"
+
+LICENSE="CMake"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${P}-rpath-fix.patch
+ sed -i -e "s:g++:$(tc-getCXX):" \
+ ${S}/Modules/CMakeCXXInformation.cmake
+ sed -i -e "s:gcc:$(tc-getCC):" \
+ ${S}/Modules/CMakeCInformation.cmake
+}
+
+src_compile() {
+ strip-flags
+ ./bootstrap \
+ --prefix=/usr \
+ --docdir=/share/doc/${PN} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man || die "./bootstrap failed"
+ emake -j1 || die
+}
+
+src_test() {
+ einfo "Self tests broken"
+ make test || \
+ einfo "note test failure on qtwrapping was expected - nature of portage rather than a true failure"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install failed"
+ mv ${D}usr/share/doc/cmake ${D}usr/share/doc/${PF}
+}
diff --git a/dev-util/cmake/files/cmake-2.2.3-rpath-fix.patch b/dev-util/cmake/files/cmake-2.2.3-rpath-fix.patch
new file mode 100644
index 000000000000..d1e8cae2712d
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.2.3-rpath-fix.patch
@@ -0,0 +1,11 @@
+--- cmake-2.2.3/Modules/CMakeGenericSystem.cmake.orig 2006-01-16 10:03:54.000000000 +0000
++++ cmake-2.2.3/Modules/CMakeGenericSystem.cmake 2006-01-16 10:04:16.000000000 +0000
+@@ -21,7 +21,7 @@
+ SET(CMAKE_SHARED_LIBRARY_CXX_FLAGS "-fPIC") # -pic
+ ENDIF(CMAKE_COMPILER_IS_GNUCXX)
+
+-SET (CMAKE_SKIP_RPATH "NO" CACHE BOOL
++SET (CMAKE_SKIP_RPATH "YES" CACHE BOOL
+ "If set, runtime paths are not added when using shared libraries.")
+
+ SET(CMAKE_INIT_VALUE FALSE)
diff --git a/dev-util/cmake/files/digest-cmake-2.2.3 b/dev-util/cmake/files/digest-cmake-2.2.3
new file mode 100644
index 000000000000..60d4499385fd
--- /dev/null
+++ b/dev-util/cmake/files/digest-cmake-2.2.3
@@ -0,0 +1 @@
+MD5 d29377b76fbab6a74107c49adc9e6457 cmake-2.2.3.tar.gz 2427300