summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-28 16:30:34 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-07-28 16:30:34 +0000
commit80a7dd0236f23583f514c1d911071ef0f48494f3 (patch)
tree55dd405c98048a5cbb88d7983717f36e38283be9 /dev-util/cmake
parentAdjust mask for ati-drivers to mask also ati-drivers-extra (diff)
downloadgentoo-2-80a7dd0236f23583f514c1d911071ef0f48494f3.tar.gz
gentoo-2-80a7dd0236f23583f514c1d911071ef0f48494f3.tar.bz2
gentoo-2-80a7dd0236f23583f514c1d911071ef0f48494f3.zip
Add "python3" USE flag.
(Portage version: 13851-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog10
-rw-r--r--dev-util/cmake/cmake-2.6.4-r2.ebuild158
-rw-r--r--dev-util/cmake/files/cmake-FindPythonInterp.patch2
-rw-r--r--dev-util/cmake/files/cmake-FindPythonLibs.patch2
-rw-r--r--dev-util/cmake/files/cmake-python-3.patch22
-rw-r--r--dev-util/cmake/metadata.xml3
6 files changed, 194 insertions, 3 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 91f706714d4d..b724e7687ee2 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.105 2009/07/26 20:41:23 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.106 2009/07/28 16:30:34 arfrever Exp $
+
+*cmake-2.6.4-r2 (28 Jul 2009)
+
+ 28 Jul 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +cmake-2.6.4-r2.ebuild, +files/cmake-python-3.patch,
+ files/cmake-FindPythonInterp.patch, files/cmake-FindPythonLibs.patch,
+ metadata.xml:
+ Add "python3" USE flag.
26 Jul 2009; Marcus D. Hanwell <cryos@gentoo.org> cmake-2.6.4.ebuild,
cmake-2.6.4-r1.ebuild:
diff --git a/dev-util/cmake/cmake-2.6.4-r2.ebuild b/dev-util/cmake/cmake-2.6.4-r2.ebuild
new file mode 100644
index 000000000000..ba8d8e55554d
--- /dev/null
+++ b/dev-util/cmake/cmake-2.6.4-r2.ebuild
@@ -0,0 +1,158 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.4-r2.ebuild,v 1.1 2009/07/28 16:30:34 arfrever Exp $
+
+EAPI="2"
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic cmake-utils
+
+MY_PV="${PV/rc/RC-}"
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+SLOT="0"
+IUSE="emacs python3 qt4 vim-syntax"
+
+DEPEND="
+ >=net-misc/curl-7.16.4
+ >=dev-libs/expat-2.0.1
+ >=dev-libs/libxml2-2.6.28
+ >=dev-libs/xmlrpc-c-1.06.27[curl]
+ emacs? ( virtual/emacs )
+ qt4? ( x11-libs/qt-gui:4 )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+RDEPEND="${DEPEND}"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}/${PN}-FindJNI.patch"
+ "${FILESDIR}/${PN}-FindPythonLibs.patch"
+ "${FILESDIR}/${PN}-FindPythonInterp.patch"
+ "${FILESDIR}/${P}-FindBoost.patch"
+)
+
+pkg_setup() {
+ if use python3; then
+ ewarn "Support for Python 3 is experimental."
+ ewarn "Please include patches in bug reports!"
+ ebeep 6
+ fi
+}
+
+src_prepare() {
+ base_src_prepare
+
+ use python3 && epatch "${FILESDIR}/${PN}-python-3.patch"
+}
+
+src_configure() {
+ local qt_arg par_arg
+
+ if [[ "$(gcc-major-version)" -eq "3" ]] ; then
+ append-flags "-fno-stack-protector"
+ fi
+
+ bootstrap=0
+ has_version ">=dev-util/cmake-2.6.1" || bootstrap=1
+ if [[ ${bootstrap} = 0 ]]; then
+ # Required version of CMake found, now test if it works
+ cmake --version &> /dev/null
+ if ! [[ $? = 0 ]]; then
+ bootstrap=1
+ fi
+ fi
+
+ if [[ ${bootstrap} = 1 ]]; then
+ tc-export CC CXX LD
+
+ if use qt4; then
+ qt_arg="--qt-gui"
+ else
+ qt_arg="--no-qt-gui"
+ fi
+
+ echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo $MAKEOPTS | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ ./bootstrap \
+ --system-libs \
+ --prefix=/usr \
+ --docdir=/share/doc/${PF} \
+ --datadir=/share/${PN} \
+ --mandir=/share/man \
+ "$qt_arg" \
+ "$par_arg" || die "./bootstrap failed"
+ else
+ # this is way much faster so we should preffer it if some cmake is
+ # around.
+ use qt4 && qt_arg="ON" || qt_arg="OFF"
+ mycmakeargs="-DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ -DBUILD_CursesDialog=ON
+ -DBUILD_QtDialog=${qt_arg}"
+ cmake-utils_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ einfo "Please note that test \"58 - SimpleInstall-Stage2\" might fail."
+ einfo "If any package installs with cmake, it means test failed but cmake work."
+ emake test
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/Docs/cmake-syntax.vim
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins "${S}"/Docs/cmake-indent.vim
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-FindPythonInterp.patch b/dev-util/cmake/files/cmake-FindPythonInterp.patch
index 91ecc6fe5a5e..2e4c47d6806f 100644
--- a/dev-util/cmake/files/cmake-FindPythonInterp.patch
+++ b/dev-util/cmake/files/cmake-FindPythonInterp.patch
@@ -5,7 +5,7 @@
FIND_PROGRAM(PYTHON_EXECUTABLE
- NAMES python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5 python
-+ NAMES python python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
++ NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
PATHS
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]
[HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.4\\InstallPath]
diff --git a/dev-util/cmake/files/cmake-FindPythonLibs.patch b/dev-util/cmake/files/cmake-FindPythonLibs.patch
index 433ba31c5a70..7981140296da 100644
--- a/dev-util/cmake/files/cmake-FindPythonLibs.patch
+++ b/dev-util/cmake/files/cmake-FindPythonLibs.patch
@@ -5,7 +5,7 @@
CMAKE_FIND_FRAMEWORKS(Python)
-FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
-+FOREACH(_CURRENT_VERSION 3.2 3.1 3.0 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
++FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
IF(WIN32)
FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
diff --git a/dev-util/cmake/files/cmake-python-3.patch b/dev-util/cmake/files/cmake-python-3.patch
new file mode 100644
index 000000000000..0fdcd0ca1922
--- /dev/null
+++ b/dev-util/cmake/files/cmake-python-3.patch
@@ -0,0 +1,22 @@
+--- Modules/FindPythonInterp.cmake
++++ Modules/FindPythonInterp.cmake
+@@ -7,7 +7,7 @@
+ #
+
+ FIND_PROGRAM(PYTHON_EXECUTABLE
+- NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
++ NAMES python python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
+ PATHS
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]
+ [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]
+--- Modules/FindPythonLibs.cmake
++++ Modules/FindPythonLibs.cmake
+@@ -13,7 +13,7 @@
+ # Search for the python framework on Apple.
+ CMAKE_FIND_FRAMEWORKS(Python)
+
+-FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
++FOREACH(_CURRENT_VERSION 3.2 3.1 3.0 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
+ STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
+ IF(WIN32)
+ FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
diff --git a/dev-util/cmake/metadata.xml b/dev-util/cmake/metadata.xml
index a23f444b67d6..48b26285a0ca 100644
--- a/dev-util/cmake/metadata.xml
+++ b/dev-util/cmake/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+ <use>
+ <flag name="python3">Enable experimental support for Python 3</flag>
+ </use>
</pkgmetadata>