summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-12-25 17:05:11 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-12-25 17:05:11 +0000
commit9dab81e32a94a42f6f19808313582b026254e912 (patch)
tree2d8b55a6bd887506225fec49b465cec386c1e466 /dev-util/cmake
parentFix dependencies. Set SUPPORT_PYTHON_ABIS. Avoid breaking strict-aliasing rules. (diff)
downloadgentoo-2-9dab81e32a94a42f6f19808313582b026254e912.tar.gz
gentoo-2-9dab81e32a94a42f6f19808313582b026254e912.tar.bz2
gentoo-2-9dab81e32a94a42f6f19808313582b026254e912.zip
Fix ruby finding per bug #345993 and buffer overflowing per bug #329043.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog9
-rw-r--r--dev-util/cmake/cmake-2.8.3-r1.ebuild148
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-buffer_overflow.patch12
-rw-r--r--dev-util/cmake/files/cmake-2.8.3-ruby_libname.patch12
4 files changed, 180 insertions, 1 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 437eacf0059b..c1a869e0290e 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.147 2010/12/20 13:40:01 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.148 2010/12/25 17:05:11 scarabeus Exp $
+
+*cmake-2.8.3-r1 (25 Dec 2010)
+
+ 25 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> +cmake-2.8.3-r1.ebuild,
+ +files/cmake-2.8.3-buffer_overflow.patch,
+ +files/cmake-2.8.3-ruby_libname.patch:
+ Fix ruby finding per bug #345993 and buffer overflowing per bug #329043.
20 Dec 2010; Tomáš Chvátal <scarabeus@gentoo.org> cmake-2.8.3.ebuild:
Fix dependency on libarchive version. Fixes bug #348887.
diff --git a/dev-util/cmake/cmake-2.8.3-r1.ebuild b/dev-util/cmake/cmake-2.8.3-r1.ebuild
new file mode 100644
index 000000000000..1325acbabe28
--- /dev/null
+++ b/dev-util/cmake/cmake-2.8.3-r1.ebuild
@@ -0,0 +1,148 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.3-r1.ebuild,v 1.1 2010/12/25 17:05:11 scarabeus Exp $
+
+EAPI="3"
+
+inherit elisp-common toolchain-funcs eutils versionator flag-o-matic base cmake-utils
+
+MY_P="${PN}-$(replace_version_separator 3 - ${MY_PV})"
+
+DESCRIPTION="Cross platform Make"
+HOMEPAGE="http://www.cmake.org/"
+SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.tar.gz"
+
+LICENSE="CMake"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~sparc-fbsd ~x86-fbsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="emacs ncurses qt4 vim-syntax"
+
+DEPEND="
+ >=app-arch/libarchive-2.8.0
+ >=net-misc/curl-7.20.0-r1[ssl]
+ >=dev-libs/expat-2.0.1
+ sys-libs/zlib
+ ncurses? ( sys-libs/ncurses )
+ qt4? ( x11-libs/qt-gui:4 )
+"
+RDEPEND="${DEPEND}
+ emacs? ( virtual/emacs )
+ vim-syntax? (
+ || (
+ app-editors/vim
+ app-editors/gvim
+ )
+ )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+VIMFILE="${PN}.vim"
+
+S="${WORKDIR}/${MY_P}"
+
+CMAKE_BINARY="${S}/Bootstrap.cmk/cmake"
+CMAKE_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.6.3-darwin-bundle.patch
+ "${FILESDIR}"/${PN}-2.6.3-no-duplicates-in-rpath.patch
+ "${FILESDIR}"/${PN}-2.6.3-fix_broken_lfs_on_aix.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-default-install_name.patch
+ "${FILESDIR}"/${PN}-2.8.0-darwin-no-app-with-qt.patch
+ "${FILESDIR}"/${PN}-2.8.1-FindBoost.patch
+ "${FILESDIR}"/${PN}-2.8.1-libform.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindLibArchive.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindPythonLibs.patch
+ "${FILESDIR}"/${PN}-2.8.3-FindPythonInterp.patch
+ "${FILESDIR}"/${PN}-2.8.3-more-no_host_paths.patch
+ "${FILESDIR}"/${PN}-2.8.3-ruby_libname.patch
+ "${FILESDIR}"/${PN}-2.8.3-buffer_overflow.patch
+)
+_src_bootstrap() {
+ echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' > /dev/null
+ if [ $? -eq 0 ]; then
+ par_arg=$(echo ${MAKEOPTS} | egrep -o '(\-j|\-\-jobs)(=?|[[:space:]]*)[[:digit:]]+' | egrep -o '[[:digit:]]+')
+ par_arg="--parallel=${par_arg}"
+ else
+ par_arg="--parallel=1"
+ fi
+
+ tc-export CC CXX LD
+
+ ./bootstrap \
+ --prefix="${T}/cmakestrap/" \
+ ${par_arg} \
+ || die "Bootstrap failed"
+}
+
+src_prepare() {
+ base_src_prepare
+
+ # disable bootstrap cmake and make run, we use eclass for that
+ sed -i \
+ -e '/"${cmake_bootstrap_dir}\/cmake"/s/^/#DONOTRUN /' \
+ bootstrap || die "sed failed"
+
+ # Add gcc libs to the default link paths
+ sed -i \
+ -e "s|@GENTOO_PORTAGE_GCCLIBDIR@|${EPREFIX}/usr/${CHOST}/lib/|g" \
+ -e "s|@GENTOO_PORTAGE_EPREFIX@|${EPREFIX}/|g" \
+ Modules/Platform/{UnixPaths,Darwin}.cmake || die "sed failed"
+
+ _src_bootstrap
+}
+
+src_configure() {
+ # make things work with gentoo java setup
+ # in case java-config cannot be run, the variable just becomes unset
+ # per bug #315229
+ export JAVA_HOME=$(java-config -g JAVA_HOME 2> /dev/null)
+
+ local mycmakeargs=(
+ -DCMAKE_USE_SYSTEM_LIBRARIES=ON
+ -DCMAKE_INSTALL_PREFIX="${EPREFIX}"/usr
+ -DCMAKE_DOC_DIR=/share/doc/${PF}
+ -DCMAKE_MAN_DIR=/share/man
+ -DCMAKE_DATA_DIR=/share/${PN}
+ $(cmake-utils_use_build ncurses CursesDialog)
+ $(cmake-utils_use_build qt4 QtDialog)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use emacs; then
+ elisp-compile Docs/cmake-mode.el || die "elisp compile failed"
+ fi
+}
+
+src_test() {
+ emake test || die "Tests failed"
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use emacs; then
+ elisp-install ${PN} Docs/cmake-mode.el Docs/cmake-mode.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins Docs/cmake-syntax.vim || die
+
+ insinto /usr/share/vim/vimfiles/indent
+ doins Docs/cmake-indent.vim || die
+
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${FILESDIR}/${VIMFILE}" || die
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cmake/files/cmake-2.8.3-buffer_overflow.patch b/dev-util/cmake/files/cmake-2.8.3-buffer_overflow.patch
new file mode 100644
index 000000000000..6bc5a6641a09
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-buffer_overflow.patch
@@ -0,0 +1,12 @@
+diff -urN cmake-2.8.3.orig//Source/kwsys/SystemInformation.cxx cmake-2.8.3//Source/kwsys/SystemInformation.cxx
+--- cmake-2.8.3.orig//Source/kwsys/SystemInformation.cxx 2010-12-25 16:56:42.609163498 +0100
++++ cmake-2.8.3//Source/kwsys/SystemInformation.cxx 2010-12-25 17:25:18.002163499 +0100
+@@ -152,7 +152,7 @@
+
+ public:
+ #define VENDOR_STRING_LENGTH (12 + 1)
+-#define CHIPNAME_STRING_LENGTH (48 + 1)
++#define CHIPNAME_STRING_LENGTH (68 + 1)
+ #define SERIALNUMBER_STRING_LENGTH (29 + 1)
+
+ typedef struct tagID
diff --git a/dev-util/cmake/files/cmake-2.8.3-ruby_libname.patch b/dev-util/cmake/files/cmake-2.8.3-ruby_libname.patch
new file mode 100644
index 000000000000..45d2b162c5b7
--- /dev/null
+++ b/dev-util/cmake/files/cmake-2.8.3-ruby_libname.patch
@@ -0,0 +1,12 @@
+diff -urN cmake-2.8.3.orig//Modules/FindRuby.cmake cmake-2.8.3//Modules/FindRuby.cmake
+--- cmake-2.8.3.orig//Modules/FindRuby.cmake 2010-12-25 16:56:42.597163498 +0100
++++ cmake-2.8.3//Modules/FindRuby.cmake 2010-12-25 16:57:55.207163499 +0100
+@@ -180,7 +180,7 @@
+
+
+ # Determine the list of possible names for the ruby library
+-SET(_RUBY_POSSIBLE_LIB_NAMES ruby ruby-static ruby${_RUBY_VERSION_SHORT})
++SET(_RUBY_POSSIBLE_LIB_NAMES ruby ruby-static ruby${_RUBY_VERSION_SHORT} ruby${_RUBY_VERSION_SHORT_NODOT})
+
+ IF(WIN32)
+ SET( _RUBY_MSVC_RUNTIME "" )