summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 18:10:15 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-01 18:10:15 +0000
commita2ae90a7de82f1e46b60a77e6e201927abd5fe3c (patch)
treefb0d1f914a382cae495dbb98291f3c7d329b0162 /dev-util/cmake
parentia64/sparc stable wrt #279386 (diff)
downloadgentoo-2-a2ae90a7de82f1e46b60a77e6e201927abd5fe3c.tar.gz
gentoo-2-a2ae90a7de82f1e46b60a77e6e201927abd5fe3c.tar.bz2
gentoo-2-a2ae90a7de82f1e46b60a77e6e201927abd5fe3c.zip
FindPythonLibs.cmake should use currently active Python version (bug #287143). Remove no longer needed "python3" USE flag.
(Portage version: 14469-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cmake')
-rw-r--r--dev-util/cmake/ChangeLog11
-rw-r--r--dev-util/cmake/cmake-2.6.4-r3.ebuild (renamed from dev-util/cmake/cmake-2.6.4-r2.ebuild)18
-rw-r--r--dev-util/cmake/cmake-2.8.0_rc1.ebuild18
-rw-r--r--dev-util/cmake/files/cmake-FindPythonLibs.patch17
-rw-r--r--dev-util/cmake/files/cmake-python-3.patch22
-rw-r--r--dev-util/cmake/metadata.xml3
6 files changed, 18 insertions, 71 deletions
diff --git a/dev-util/cmake/ChangeLog b/dev-util/cmake/ChangeLog
index 056198038323..0ed4cf9ba750 100644
--- a/dev-util/cmake/ChangeLog
+++ b/dev-util/cmake/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/cmake
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.107 2009/10/01 13:35:02 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/ChangeLog,v 1.108 2009/10/01 18:10:14 arfrever Exp $
+
+*cmake-2.6.4-r3 (01 Oct 2009)
+
+ 01 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -cmake-2.6.4-r2.ebuild, +cmake-2.6.4-r3.ebuild, cmake-2.8.0_rc1.ebuild,
+ -files/cmake-python-3.patch, files/cmake-FindPythonLibs.patch,
+ metadata.xml:
+ FindPythonLibs.cmake should use currently active Python version (bug
+ #287143). Remove no longer needed "python3" USE flag.
*cmake-2.8.0_rc1 (01 Oct 2009)
diff --git a/dev-util/cmake/cmake-2.6.4-r2.ebuild b/dev-util/cmake/cmake-2.6.4-r3.ebuild
index ba8d8e55554d..945b819778fb 100644
--- a/dev-util/cmake/cmake-2.6.4-r2.ebuild
+++ b/dev-util/cmake/cmake-2.6.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.4-r2.ebuild,v 1.1 2009/07/28 16:30:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.6.4-r3.ebuild,v 1.1 2009/10/01 18:10:14 arfrever Exp $
EAPI="2"
@@ -16,7 +16,7 @@ SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.
LICENSE="CMake"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
SLOT="0"
-IUSE="emacs python3 qt4 vim-syntax"
+IUSE="emacs qt4 vim-syntax"
DEPEND="
>=net-misc/curl-7.16.4
@@ -48,20 +48,6 @@ PATCHES=(
"${FILESDIR}/${P}-FindBoost.patch"
)
-pkg_setup() {
- if use python3; then
- ewarn "Support for Python 3 is experimental."
- ewarn "Please include patches in bug reports!"
- ebeep 6
- fi
-}
-
-src_prepare() {
- base_src_prepare
-
- use python3 && epatch "${FILESDIR}/${PN}-python-3.patch"
-}
-
src_configure() {
local qt_arg par_arg
diff --git a/dev-util/cmake/cmake-2.8.0_rc1.ebuild b/dev-util/cmake/cmake-2.8.0_rc1.ebuild
index 75e1f69f527e..ece284370551 100644
--- a/dev-util/cmake/cmake-2.8.0_rc1.ebuild
+++ b/dev-util/cmake/cmake-2.8.0_rc1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.0_rc1.ebuild,v 1.1 2009/10/01 13:35:02 cryos Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cmake/cmake-2.8.0_rc1.ebuild,v 1.2 2009/10/01 18:10:14 arfrever Exp $
EAPI="2"
@@ -15,7 +15,7 @@ SRC_URI="http://www.cmake.org/files/v$(get_version_component_range 1-2)/${MY_P}.
LICENSE="CMake"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
SLOT="0"
-IUSE="emacs python3 qt4 vim-syntax"
+IUSE="emacs qt4 vim-syntax"
DEPEND="
>=net-misc/curl-7.16.4
@@ -46,20 +46,6 @@ PATCHES=(
"${FILESDIR}/${PN}-FindPythonInterp.patch"
)
-pkg_setup() {
- if use python3; then
- ewarn "Support for Python 3 is experimental."
- ewarn "Please include patches in bug reports!"
- ebeep 6
- fi
-}
-
-src_prepare() {
- base_src_prepare
-
- use python3 && epatch "${FILESDIR}/${PN}-python-3.patch"
-}
-
src_configure() {
local qt_arg par_arg
diff --git a/dev-util/cmake/files/cmake-FindPythonLibs.patch b/dev-util/cmake/files/cmake-FindPythonLibs.patch
index 7981140296da..d7f4f627be4c 100644
--- a/dev-util/cmake/files/cmake-FindPythonLibs.patch
+++ b/dev-util/cmake/files/cmake-FindPythonLibs.patch
@@ -1,22 +1,13 @@
--- Modules/FindPythonLibs.cmake
+++ Modules/FindPythonLibs.cmake
-@@ -13,7 +13,7 @@
+@@ -14,7 +14,9 @@
# Search for the python framework on Apple.
CMAKE_FIND_FRAMEWORKS(Python)
-FOREACH(_CURRENT_VERSION 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
-+FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
++EXECUTE_PROCESS(COMMAND python -c "import sys; sys.stdout.write('.'.join([str(x) for x in sys.version_info[:2]]))"
++ OUTPUT_VARIABLE _PYTHON_VERSION)
++FOREACH(_CURRENT_VERSION ${_PYTHON_VERSION})
STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
IF(WIN32)
FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
-@@ -27,10 +27,6 @@
- NAMES python${_CURRENT_VERSION_NO_DOTS} python${_CURRENT_VERSION}
- PATHS
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\${_CURRENT_VERSION}\\InstallPath]/libs
-- PATH_SUFFIXES
-- python${_CURRENT_VERSION}/config
-- # Avoid finding the .dll in the PATH. We want the .lib.
-- NO_SYSTEM_ENVIRONMENT_PATH
- )
-
- SET(PYTHON_FRAMEWORK_INCLUDES)
diff --git a/dev-util/cmake/files/cmake-python-3.patch b/dev-util/cmake/files/cmake-python-3.patch
deleted file mode 100644
index 0fdcd0ca1922..000000000000
--- a/dev-util/cmake/files/cmake-python-3.patch
+++ /dev/null
@@ -1,22 +0,0 @@
---- Modules/FindPythonInterp.cmake
-+++ Modules/FindPythonInterp.cmake
-@@ -7,7 +7,7 @@
- #
-
- FIND_PROGRAM(PYTHON_EXECUTABLE
-- NAMES python python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
-+ NAMES python python3.2 python3.1 python3.0 python2.7 python2.6 python2.5 python2.4 python2.3 python2.2 python2.1 python2.0 python1.6 python1.5
- PATHS
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.6\\InstallPath]
- [HKEY_LOCAL_MACHINE\\SOFTWARE\\Python\\PythonCore\\2.5\\InstallPath]
---- Modules/FindPythonLibs.cmake
-+++ Modules/FindPythonLibs.cmake
-@@ -13,7 +13,7 @@
- # Search for the python framework on Apple.
- CMAKE_FIND_FRAMEWORKS(Python)
-
--FOREACH(_CURRENT_VERSION 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
-+FOREACH(_CURRENT_VERSION 3.2 3.1 3.0 2.7 2.6 2.5 2.4 2.3 2.2 2.1 2.0 1.6 1.5)
- STRING(REPLACE "." "" _CURRENT_VERSION_NO_DOTS ${_CURRENT_VERSION})
- IF(WIN32)
- FIND_LIBRARY(PYTHON_DEBUG_LIBRARY
diff --git a/dev-util/cmake/metadata.xml b/dev-util/cmake/metadata.xml
index 48b26285a0ca..a23f444b67d6 100644
--- a/dev-util/cmake/metadata.xml
+++ b/dev-util/cmake/metadata.xml
@@ -2,7 +2,4 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
- <use>
- <flag name="python3">Enable experimental support for Python 3</flag>
- </use>
</pkgmetadata>