summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-06-18 17:59:52 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-06-18 17:59:52 +0000
commita522503169c4ede9d76bf06c2cf97009a919d7be (patch)
tree3af08e92a4241d295cbeede34c14dc1a525b644b /dev-util/codeblocks
parentversion bump (diff)
downloadgentoo-2-a522503169c4ede9d76bf06c2cf97009a919d7be.tar.gz
gentoo-2-a522503169c4ede9d76bf06c2cf97009a919d7be.tar.bz2
gentoo-2-a522503169c4ede9d76bf06c2cf97009a919d7be.zip
dev-util/codeblocks: version bump (1.0_pre20070618)
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-util/codeblocks')
-rw-r--r--dev-util/codeblocks/ChangeLog8
-rw-r--r--dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild64
-rw-r--r--dev-util/codeblocks/files/digest-codeblocks-1.0_pre200706183
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-util/codeblocks/ChangeLog b/dev-util/codeblocks/ChangeLog
index e81d11d2a633..d31540df926e 100644
--- a/dev-util/codeblocks/ChangeLog
+++ b/dev-util/codeblocks/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/codeblocks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.7 2007/05/15 09:10:31 bangert Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/ChangeLog,v 1.8 2007/06/18 17:59:52 jurek Exp $
+
+*codeblocks-1.0_pre20070618 (18 Jun 2007)
+
+ 18 Jun 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +codeblocks-1.0_pre20070618.ebuild:
+ Version bump
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild b/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild
new file mode 100644
index 000000000000..d7b38b057b35
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/codeblocks/codeblocks-1.0_pre20070618.ebuild,v 1.1 2007/06/18 17:59:52 jurek Exp $
+
+#
+# WARNING:
+# If you are using gtk2.8 you need to upgrade to wxGTK-2.6.2
+#
+
+inherit eutils autotools wxwidgets
+
+#needed for wxwidgets.eclass
+WX_GTK_VER="2.6"
+
+DESCRIPTION="Code::Blocks - a free cross-platform C/C++ IDE"
+HOMEPAGE="http://www.codeblocks.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="unicode contrib debug"
+
+RDEPEND="=x11-libs/wxGTK-${WX_GTK_VER}*"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/autoconf-2.5
+ >=sys-devel/automake-1.7
+ >=sys-devel/libtool-1.4"
+
+pkg_setup() {
+ if use unicode; then
+ #check for gtk2-unicode
+ need-wxwidgets unicode
+ else
+ #check for gtk2-ansi
+ need-wxwidgets gtk2
+ fi
+}
+
+src_compile() {
+ export WANT_AUTOCONF=2.5
+ export WANT_AUTOMAKE=1.7
+
+ local TMP
+
+ TMP="/usr/share/aclocal/libtool.m4"
+ einfo "Running ./bootstrap"
+ if [ -e "$TMP" ]; then
+ cp "$TMP" aclocal.m4 || die "cp failed"
+ fi
+ ./bootstrap || die "boostrap failed"
+
+ econf --with-wx-config="${WX_CONFIG}" \
+ $(use_enable contrib) \
+ $(use_enable debug) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+}
diff --git a/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070618 b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070618
new file mode 100644
index 000000000000..d896cc36264a
--- /dev/null
+++ b/dev-util/codeblocks/files/digest-codeblocks-1.0_pre20070618
@@ -0,0 +1,3 @@
+MD5 1390d14cc049d46fbc42b36b9872302d codeblocks-1.0_pre20070618.tar.bz2 8564270
+RMD160 643deba773f3a873c19c3b89fbb4866b106ff457 codeblocks-1.0_pre20070618.tar.bz2 8564270
+SHA256 19d54866991ccbfe7a4b9921f85d6289b1c948931040bf2462b92ddf8e2d8db9 codeblocks-1.0_pre20070618.tar.bz2 8564270