summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2014-10-09 23:16:33 +0000
committerMichael Weber <xmw@gentoo.org>2014-10-09 23:16:33 +0000
commitc0865b50f807003c8e59e5c99cd1cc39975dc9c4 (patch)
treeef3392ac54fc999bd680663c2a3a1fbcfaa65bb5 /dev-util/cppcheck
parentLinux patch 3.14.21 (diff)
downloadgentoo-2-c0865b50f807003c8e59e5c99cd1cc39975dc9c4.tar.gz
gentoo-2-c0865b50f807003c8e59e5c99cd1cc39975dc9c4.tar.bz2
gentoo-2-c0865b50f807003c8e59e5c99cd1cc39975dc9c4.zip
Remove bundled tinyxml2 by adjusting Makefile generator (bug 522368).
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 62EEF090)
Diffstat (limited to 'dev-util/cppcheck')
-rw-r--r--dev-util/cppcheck/ChangeLog8
-rw-r--r--dev-util/cppcheck/cppcheck-1.65-r1.ebuild93
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.65-r1-tinyxml2.patch67
3 files changed, 167 insertions, 1 deletions
diff --git a/dev-util/cppcheck/ChangeLog b/dev-util/cppcheck/ChangeLog
index 7b46c9952240..d0335e9ffe45 100644
--- a/dev-util/cppcheck/ChangeLog
+++ b/dev-util/cppcheck/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppcheck
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.52 2014/05/19 15:50:29 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/ChangeLog,v 1.53 2014/10/09 23:16:33 xmw Exp $
+
+*cppcheck-1.65-r1 (09 Oct 2014)
+
+ 09 Oct 2014; Michael Weber <xmw@gentoo.org> +cppcheck-1.65-r1.ebuild,
+ +files/cppcheck-1.65-r1-tinyxml2.patch:
+ Remove bundled tinyxml2 by adjusting Makefile generator (bug 522368).
*cppcheck-1.65 (19 May 2014)
diff --git a/dev-util/cppcheck/cppcheck-1.65-r1.ebuild b/dev-util/cppcheck/cppcheck-1.65-r1.ebuild
new file mode 100644
index 000000000000..089efb8ec4a1
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.65-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppcheck/cppcheck-1.65-r1.ebuild,v 1.1 2014/10/09 23:16:33 xmw Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+inherit distutils-r1 eutils flag-o-matic qt4-r2 toolchain-funcs
+
+DESCRIPTION="static analyzer of C/C++ code"
+HOMEPAGE="http://cppcheck.sourceforge.net"
+SRC_URI="mirror://sourceforge/cppcheck/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="htmlreport qt4"
+
+RDEPEND="htmlreport? ( ${PYTHON_DEPS} )
+ >=dev-libs/tinyxml2-2
+ qt4? ( dev-qt/qtgui:4 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # Drop bundled libs, patch Makefile generator and re-run it
+ rm -r externals || die
+ epatch "${FILESDIR}"/${PF}-tinyxml2.patch
+ emake dmake \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ ./dmake || die
+
+ epatch "${FILESDIR}"/${P}-c++0x.patch
+}
+
+src_configure() {
+ tc-export CXX
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_configure
+ popd
+ fi
+}
+
+src_compile() {
+ local my_inc=$(pkg-config --cflags-only-I tinyxml2)
+ emake CFGDIR="/usr/share/${PN}/cfg" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ INCLUDE_FOR_LIB="-Ilib ${my_inc}" \
+ INCLUDE_FOR_CLI="-Ilib ${my_inc}" \
+ INCLUDE_FOR_TEST="-Ilib -Icli ${my_inc}" \
+ LIBS="$(pkg-config --libs tinyxml2)"
+
+ if use qt4 ; then
+ pushd gui
+ qt4-r2_src_compile
+ popd
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_compile
+ popd
+ fi
+}
+
+src_test() {
+ emake check \
+ LIBS="$(pkg-config --libs tinyxml2)"
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc readme.txt
+ insinto "/usr/share/${PN}/cfg"
+ doins cfg/*.cfg
+ if use qt4 ; then
+ dobin gui/${PN}-gui
+ dodoc readme_gui.txt gui/{projectfile.txt,gui.cppcheck}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport
+ distutils-r1_src_install
+ popd
+ find "${D}" -name "*.egg-info" -delete
+ fi
+}
diff --git a/dev-util/cppcheck/files/cppcheck-1.65-r1-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.65-r1-tinyxml2.patch
new file mode 100644
index 000000000000..cb5a4ae401e2
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-1.65-r1-tinyxml2.patch
@@ -0,0 +1,67 @@
+--- cppcheck-1.65/tools/dmake.cpp
++++ cppcheck-1.65/tools/dmake.cpp
+@@ -170,7 +170,6 @@
+ }
+
+ std::vector<std::string> externalfiles;
+- getCppFiles(externalfiles, "externals/");
+
+
+ // QMAKE - lib/lib.pri
+@@ -179,10 +178,6 @@
+ if (fout1.is_open()) {
+ fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
+ fout1 << "include($$PWD/pcrerules.pri)\n";
+- fout1 << "BASEPATH = ../externals/tinyxml/\n";
+- fout1 << "include($$PWD/../externals/tinyxml/tinyxml.pri)\n";
+- fout1 << "BASEPATH = ../lib/\n";
+- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
+ fout1 << "HEADERS += $${BASEPATH}check.h \\\n";
+ for (unsigned int i = 0; i < libfiles.size(); ++i) {
+ std::string fname(libfiles[i].substr(4));
+@@ -208,7 +203,6 @@
+ std::ofstream fout1("test/testfiles.pri");
+ if (fout1.is_open()) {
+ fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
+- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
+ fout1 << "\n\nSOURCES += ";
+ for (unsigned int i = 0; i < testfiles.size(); ++i) {
+ const std::string filename(testfiles[i].substr(5));
+@@ -354,9 +348,9 @@
+
+ makeConditionalVariable(fout, "CXX", "g++");
+ makeConditionalVariable(fout, "PREFIX", "/usr");
+- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -Iexternals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -Iexternals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -Iexternals/tinyxml");
++ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib");
++ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib");
++ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli");
+
+ fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
+ fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
+@@ -394,10 +388,10 @@
+ fout << "dmake:\ttools/dmake.o cli/filelister.o lib/path.o\n";
+ fout << "\t$(CXX) $(CXXFLAGS) -std=c++0x -o dmake tools/dmake.o cli/filelister.o lib/path.o -Ilib $(LDFLAGS)\n";
+ fout << "\t./dmake\n\n";
+- fout << "reduce:\ttools/reduce.o externals/tinyxml/tinyxml2.o $(LIBOBJ)\n";
+- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -std=c++0x -g -o reduce tools/reduce.o -Ilib -Iexternals/tinyxml $(LIBOBJ) $(LIBS) externals/tinyxml/tinyxml2.o $(LDFLAGS) $(RDYNAMIC)\n\n";
++ fout << "reduce:\ttools/reduce.o $(LIBOBJ)\n";
++ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -std=c++0x -g -o reduce tools/reduce.o -Ilib $(LIBOBJ) $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
+ fout << "clean:\n";
+- fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o externals/tinyxml/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
++ fout << "\trm -f build/*.o lib/*.o cli/*.o test/*.o testrunner reduce dmake cppcheck cppcheck.1\n\n";
+ fout << "man:\tman/cppcheck.1\n\n";
+ fout << "man/cppcheck.1:\t$(MAN_SOURCE)\n\n";
+ fout << "\t$(XP) $(DB2MAN) $(MAN_SOURCE)\n\n";
+--- cppcheck-1.65/gui/gui.pro
++++ cppcheck-1.65/gui/gui.pro
+@@ -15,7 +15,7 @@
+ LIBS += -l../bin/cppcheck-core
+ DEFINES += CPPCHECKLIB_IMPORT
+ }
+-LIBS += -L../externals
++LIBS += `pkg-config --libs tinyxml2`
+
+ DESTDIR = .
+ RCC_DIR = temp