summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Buchholz <rbu@gentoo.org>2009-03-15 15:42:08 +0000
committerRobert Buchholz <rbu@gentoo.org>2009-03-15 15:42:08 +0000
commitfd3458bbfccd597cdf095c6041741779e031e5e1 (patch)
tree3327e3ad4da364f47ccc90198d42e295d1bf7399 /dev-util/cpptest
parentdepend on faac with use aac by gentoobugsie@gmail.com, bug #262565 and give -... (diff)
downloadgentoo-2-fd3458bbfccd597cdf095c6041741779e031e5e1.tar.gz
gentoo-2-fd3458bbfccd597cdf095c6041741779e031e5e1.tar.bz2
gentoo-2-fd3458bbfccd597cdf095c6041741779e031e5e1.zip
Initial ebuild by Sebastian Pipping (bug #260687)
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/cpptest')
-rw-r--r--dev-util/cpptest/ChangeLog10
-rw-r--r--dev-util/cpptest/cpptest-1.1.0.ebuild35
-rw-r--r--dev-util/cpptest/files/cpptest-1.1.0-htmldir.patch12
-rw-r--r--dev-util/cpptest/metadata.xml19
4 files changed, 76 insertions, 0 deletions
diff --git a/dev-util/cpptest/ChangeLog b/dev-util/cpptest/ChangeLog
new file mode 100644
index 000000000000..e5701f21a1f3
--- /dev/null
+++ b/dev-util/cpptest/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-util/cpptest
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cpptest/ChangeLog,v 1.1 2009/03/15 15:42:07 rbu Exp $
+
+*cpptest-1.1.0 (15 Mar 2009)
+
+ 15 Mar 2009; Robert Buchholz <rbu@gentoo.org>
+ +files/cpptest-1.1.0-htmldir.patch, +metadata.xml, +cpptest-1.1.0.ebuild:
+ Initial ebuild by Sebastian Pipping (bug #260687)
+
diff --git a/dev-util/cpptest/cpptest-1.1.0.ebuild b/dev-util/cpptest/cpptest-1.1.0.ebuild
new file mode 100644
index 000000000000..c1cce7a2d8d2
--- /dev/null
+++ b/dev-util/cpptest/cpptest-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cpptest/cpptest-1.1.0.ebuild,v 1.1 2009/03/15 15:42:07 rbu Exp $
+
+EAPI=2
+inherit autotools
+
+DESCRIPTION="Simple but powerful unit testing framework for C++"
+HOMEPAGE="http://cpptest.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-htmldir.patch"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc) \
+ --htmldir=/usr/share/doc/${PF}/html/
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS BUGS NEWS README
+}
+
diff --git a/dev-util/cpptest/files/cpptest-1.1.0-htmldir.patch b/dev-util/cpptest/files/cpptest-1.1.0-htmldir.patch
new file mode 100644
index 000000000000..cf5a9f883ff5
--- /dev/null
+++ b/dev-util/cpptest/files/cpptest-1.1.0-htmldir.patch
@@ -0,0 +1,12 @@
+Index: cpptest-1.1.0/doc/Makefile.am
+===================================================================
+--- cpptest-1.1.0.orig/doc/Makefile.am
++++ cpptest-1.1.0/doc/Makefile.am
+@@ -39,7 +39,6 @@ EXTRA_DIST = \
+ images/screenshot-text-terse.png \
+ images/screenshot-text-verbose.png
+
+-htmldir= $(pkgdatadir)/html
+ html_DATA= html/index.html
+
+ IMAGES= images/*.html images/*.png
diff --git a/dev-util/cpptest/metadata.xml b/dev-util/cpptest/metadata.xml
new file mode 100644
index 000000000000..3f93acafc0c6
--- /dev/null
+++ b/dev-util/cpptest/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>webmaster@hartwork.org</email>
+ <name>Sebastian Pipping</name>
+ </maintainer>
+ <maintainer>
+ <email>rbu@gentoo.org</email>
+ <name>Robert Buchholz</name>
+ <description>proxy maintainer</description>
+ </maintainer>
+ <longdescription lang="en">
+ CppTest is a portable and powerful, yet simple, unit testing framework for handling
+ automated tests in C++. The focus lies on usability and extendability.
+ Several output formats are supported and new ones are easily added.
+ </longdescription>
+</pkgmetadata>