summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2007-09-21 08:46:34 +0000
committerUlrich Müller <ulm@gentoo.org>2007-09-21 08:46:34 +0000
commit3c7e019df0fe2a442ec2aafe598ed865f6937eea (patch)
tree06596c0042bf5da75bc9221ece45f564dce97fc9 /dev-util/cscope
parentAdding the mapserver-5.0.0 ebuild for the foss4g 2007. (diff)
downloadgentoo-2-3c7e019df0fe2a442ec2aafe598ed865f6937eea.tar.gz
gentoo-2-3c7e019df0fe2a442ec2aafe598ed865f6937eea.tar.bz2
gentoo-2-3c7e019df0fe2a442ec2aafe598ed865f6937eea.zip
Use autoload for Emacs files (#174469). Other minor fixes.
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-util/cscope')
-rw-r--r--dev-util/cscope/ChangeLog11
-rw-r--r--dev-util/cscope/cscope-15.6-r2.ebuild70
-rw-r--r--dev-util/cscope/files/50cscope-gentoo.el37
-rw-r--r--dev-util/cscope/files/digest-cscope-15.6-r23
4 files changed, 120 insertions, 1 deletions
diff --git a/dev-util/cscope/ChangeLog b/dev-util/cscope/ChangeLog
index 05f71426658b..b8dfa8eff8ec 100644
--- a/dev-util/cscope/ChangeLog
+++ b/dev-util/cscope/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/cscope
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.95 2007/02/15 10:21:00 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/ChangeLog,v 1.96 2007/09/21 08:46:34 ulm Exp $
+
+*cscope-15.6-r2 (21 Sep 2007)
+
+ 21 Sep 2007; Ulrich Mueller <ulm@gentoo.org> +files/50cscope-gentoo.el,
+ +cscope-15.6-r2.ebuild:
+ Fix Emacs support: Use autoload (bug #174469); install files in standard
+ location ${SITELISP}/${PN}. Don't install licence and CVS directories with
+ webcscope documentation. Add GPL-2 to "LICENSE" since it applies to xcscope
+ and webcscope. Add some quotes and some messages to die commands.
15 Feb 2007; Christian Faulhammer <opfer@gentoo.org>
-cscope-15.5.20060927.ebuild, -cscope-15.5.20060927-r1.ebuild,
diff --git a/dev-util/cscope/cscope-15.6-r2.ebuild b/dev-util/cscope/cscope-15.6-r2.ebuild
new file mode 100644
index 000000000000..04713ec47f08
--- /dev/null
+++ b/dev-util/cscope/cscope-15.6-r2.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cscope/cscope-15.6-r2.ebuild,v 1.1 2007/09/21 08:46:34 ulm Exp $
+
+inherit elisp-common eutils
+
+DESCRIPTION="Interactively examine a C program"
+HOMEPAGE="http://cscope.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cscope/${P}.tar.gz"
+
+LICENSE="as-is GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="emacs"
+
+RDEPEND=">=sys-libs/ncurses-5.2"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison
+ >=sys-devel/autoconf-2.60
+ emacs? ( virtual/emacs )"
+
+SITEFILE=50${PN}-gentoo.el
+
+src_unpack() {
+ unpack ${A}
+
+ # warn users of insecure web frontend, see bug #158831
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-158831-warning_webscope.patch"
+}
+
+src_compile() {
+ STRIP="no"
+
+ econf || die "econf failed"
+ make clean || die "make clean failed"
+ emake || die "emake failed"
+
+ if use emacs ; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog NEWS README* TODO || die "dodoc failed"
+
+ if use emacs ; then
+ cd "${S}"/contrib/xcscope || die
+ elisp-install ${PN} *.el *.elc || die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}" \
+ || die "elisp-site-file-install failed"
+ dobin cscope-indexer || die "dobin failed"
+ fi
+
+ cd "${S}"/contrib/webcscope || die
+ docinto webcscope
+ dodoc INSTALL TODO cgi-lib.pl cscope hilite.c || die "dodoc failed"
+ insinto /usr/share/doc/${PF}/webcscope/icons; doins icons/*.gif
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/cscope/files/50cscope-gentoo.el b/dev-util/cscope/files/50cscope-gentoo.el
new file mode 100644
index 000000000000..bfb13da9f974
--- /dev/null
+++ b/dev-util/cscope/files/50cscope-gentoo.el
@@ -0,0 +1,37 @@
+
+;;; cscope site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'cscope-minor-mode "xcscope")
+(autoload 'cscope-display-buffer "xcscope"
+ "Display the *cscope* buffer." t)
+(autoload 'cscope-display-buffer-toggle "xcscope"
+ "Toggle cscope-display-cscope-buffer, which corresponds to
+\"Auto display *cscope* buffer\"." t)
+(autoload 'cscope-next-symbol "xcscope"
+ "Move to the next symbol in the *cscope* buffer." t)
+(autoload 'cscope-next-file "xcscope"
+ "Move to the next file in the *cscope* buffer." t)
+(autoload 'cscope-prev-symbol "xcscope"
+ "Move to the previous symbol in the *cscope* buffer." t)
+(autoload 'cscope-prev-file "xcscope"
+ "Move to the previous file in the *cscope* buffer." t)
+(autoload 'cscope-pop-mark "xcscope"
+ "Pop back to where cscope was last invoked." t)
+(autoload 'cscope-set-initial-directory "xcscope"
+ "Set the cscope-initial-directory variable." t)
+(autoload 'cscope-unset-initial-directory "xcscope"
+ "Unset the cscope-initial-directory variable." t)
+(autoload 'cscope-find-this-symbol "xcscope"
+ "Locate a symbol in source code." t)
+(autoload 'cscope-find-global-definition "xcscope"
+ "Find a symbol's global definition." t)
+(autoload 'cscope-find-global-definition-no-prompting "xcscope"
+ "Find a symbol's global definition without prompting." t)
+
+(defun cscope:hook ()
+ (cscope-minor-mode))
+(add-hook 'c-mode-hook 'cscope:hook)
+(add-hook 'c++-mode-hook 'cscope:hook)
+(add-hook 'dired-mode-hook 'cscope:hook)
diff --git a/dev-util/cscope/files/digest-cscope-15.6-r2 b/dev-util/cscope/files/digest-cscope-15.6-r2
new file mode 100644
index 000000000000..01c0b5205907
--- /dev/null
+++ b/dev-util/cscope/files/digest-cscope-15.6-r2
@@ -0,0 +1,3 @@
+MD5 db87833f90d8267b1fc0c419cfc4d219 cscope-15.6.tar.gz 391223
+RMD160 b93238d3c91782d032e028abcfde3c2a7491a9c9 cscope-15.6.tar.gz 391223
+SHA256 6d6461ef402a1d6e42e1cd40e7524c4ed19e79eacef1d83ba4ed680f7bcac5ca cscope-15.6.tar.gz 391223