summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-14 12:09:03 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-04-14 12:09:03 +0000
commit86abda68dd603251f29c946d59f23eb2219cb77b (patch)
treecb643f9458f76492cd1efca48ec4ed51e913d4b1 /dev-util/csup
parentOverride default sepermitlockdir definition so that it doesn't end in /var/li... (diff)
downloadgentoo-2-86abda68dd603251f29c946d59f23eb2219cb77b.tar.gz
gentoo-2-86abda68dd603251f29c946d59f23eb2219cb77b.tar.bz2
gentoo-2-86abda68dd603251f29c946d59f23eb2219cb77b.zip
Respect CFLAGS and LDFLAGS.
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'dev-util/csup')
-rw-r--r--dev-util/csup/ChangeLog8
-rw-r--r--dev-util/csup/csup-20060318.ebuild17
-rw-r--r--dev-util/csup/files/csup-20060318-respectflags.patch43
3 files changed, 63 insertions, 5 deletions
diff --git a/dev-util/csup/ChangeLog b/dev-util/csup/ChangeLog
index 2bf5500bf9c8..4b83354af137 100644
--- a/dev-util/csup/ChangeLog
+++ b/dev-util/csup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/csup
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/csup/ChangeLog,v 1.5 2006/11/03 08:36:16 drizzt Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/csup/ChangeLog,v 1.6 2008/04/14 12:09:03 flameeyes Exp $
+
+ 14 Apr 2008; Diego Pettenò <flameeyes@gentoo.org>
+ +files/csup-20060318-respectflags.patch, csup-20060318.ebuild:
+ Respect CFLAGS and LDFLAGS.
03 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> csup-20060318.ebuild:
Added ~ppc keyword.
diff --git a/dev-util/csup/csup-20060318.ebuild b/dev-util/csup/csup-20060318.ebuild
index 11972e39c36f..147502adfc13 100644
--- a/dev-util/csup/csup-20060318.ebuild
+++ b/dev-util/csup/csup-20060318.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/csup/csup-20060318.ebuild,v 1.5 2006/11/03 08:36:16 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/csup/csup-20060318.ebuild,v 1.6 2008/04/14 12:09:03 flameeyes Exp $
+
+inherit toolchain-funcs eutils
DESCRIPTION="C-based rewrite of CVSup (software for distributing and updating collections of files accross a network)"
HOMEPAGE="http://www.mu.org/~mux/csup.html"
@@ -22,9 +24,18 @@ DEPEND="${DEPEND}
S="${WORKDIR}/${PN}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+}
+
src_compile() {
# unable to work with yacc, but bison is ok.
- emake PREFIX=/usr YACC=bison || die "emake failed"
+ emake \
+ CC="$(tc-getCC)" \
+ PREFIX=/usr YACC=bison || die "emake failed"
}
src_install() {
diff --git a/dev-util/csup/files/csup-20060318-respectflags.patch b/dev-util/csup/files/csup-20060318-respectflags.patch
new file mode 100644
index 000000000000..c95a974c75ed
--- /dev/null
+++ b/dev-util/csup/files/csup-20060318-respectflags.patch
@@ -0,0 +1,43 @@
+Index: csup/GNUmakefile
+===================================================================
+--- csup.orig/GNUmakefile
++++ csup/GNUmakefile
+@@ -21,7 +21,7 @@ WARNS= -Wall -W -Wno-unused-parameter -W
+ -Wcast-align -Wunused-parameter -Wchar-subscripts -Winline \
+ -Wnested-externs -Wredundant-decls -Wno-format-y2k
+
+-CFLAGS+= -g -O -pipe -DNDEBUG -I$(PREFIX)/include
++CFLAGS+= -I$(PREFIX)/include
+ ifeq ($(UNAME), Linux)
+ CFLAGS+= -D_XOPEN_SOURCE -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64
+ endif
+@@ -29,14 +29,14 @@ ifeq ($(UNAME), Darwin)
+ CFLAGS+= -DHAVE_FFLAGS
+ endif
+ CFLAGS+= $(WARNS)
+-LDFLAGS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
++LIBS= -L$(PREFIX)/lib -lcrypto -lz -lpthread
+
+ .PHONY: all clean install
+
+ all: csup csup.1.gz
+
+ csup: $(OBJS)
+- $(CC) $(CFLAGS) -o $@ $^ $(LDFLAGS)
++ $(CC) $(LDFLAGS) $(CFLAGS) -o $@ $^ $(LIBS)
+
+ config.c: parse.h
+
+Index: csup/Makefile
+===================================================================
+--- csup.orig/Makefile
++++ csup/Makefile
+@@ -11,7 +11,7 @@ SRCS= attrstack.c config.c detailer.c di
+ globtree.c idcache.c keyword.c lister.c main.c misc.c mux.c parse.y \
+ pathcomp.c proto.c status.c stream.c threads.c token.l updater.c
+
+-CFLAGS+= -I. -I${.CURDIR} -g -pthread -DHAVE_FFLAGS -DNDEBUG
++CFLAGS+= -I. -I${.CURDIR} -pthread -DHAVE_FFLAGS
+ WARNS?= 6
+
+ # A bit of tweaking is needed to get this Makefile working