summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-10-09 19:44:40 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-10-09 19:44:40 +0000
commita8b5ce0ef1253329d7f60e80106030c6d6977123 (patch)
tree416ecc61b3472301942137174e01429a282f1db3 /dev-util/cunit
parentfix tests (diff)
downloadgentoo-2-a8b5ce0ef1253329d7f60e80106030c6d6977123.tar.gz
gentoo-2-a8b5ce0ef1253329d7f60e80106030c6d6977123.tar.bz2
gentoo-2-a8b5ce0ef1253329d7f60e80106030c6d6977123.zip
link to ncurses explicitly to avoid breaking reverse deps
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-util/cunit')
-rw-r--r--dev-util/cunit/ChangeLog5
-rw-r--r--dev-util/cunit/cunit-2.1_p2.ebuild5
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-util/cunit/ChangeLog b/dev-util/cunit/ChangeLog
index 095d4cc41124..b82ef098672f 100644
--- a/dev-util/cunit/ChangeLog
+++ b/dev-util/cunit/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/cunit
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.38 2013/10/09 19:33:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/ChangeLog,v 1.39 2013/10/09 19:44:40 hasufell Exp $
+
+ 09 Oct 2013; Julian Ospald <hasufell@gentoo.org> cunit-2.1_p2.ebuild:
+ link to ncurses explicitly to avoid breaking reverse deps
09 Oct 2013; Julian Ospald <hasufell@gentoo.org> cunit-2.1_p2.ebuild:
add ncurses useflag
diff --git a/dev-util/cunit/cunit-2.1_p2.ebuild b/dev-util/cunit/cunit-2.1_p2.ebuild
index daddd42fae59..97f0215028f5 100644
--- a/dev-util/cunit/cunit-2.1_p2.ebuild
+++ b/dev-util/cunit/cunit-2.1_p2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1_p2.ebuild,v 1.4 2013/10/09 19:33:31 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cunit/cunit-2.1_p2.ebuild,v 1.5 2013/10/09 19:44:40 hasufell Exp $
EAPI=5
-inherit autotools eutils flag-o-matic
+inherit autotools eutils flag-o-matic toolchain-funcs
MY_PN='CUnit'
MY_PV="${PV/_p*}-2"
@@ -32,6 +32,7 @@ src_prepare() {
sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.in || die
eautoreconf
append-cppflags -D_BSD_SOURCE
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
}
src_configure() {