summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2006-03-07 09:25:09 +0000
committerLars Weiler <pylon@gentoo.org>2006-03-07 09:25:09 +0000
commit9767430a0cfcae1ba85074184e6ee372804c7b76 (patch)
tree328f9122fda2fd5f56db8dbe61795d5b614bc090 /dev-util/cvs/cvs-1.11.21.ebuild
parentNew upstream snapshots. Not for production use at all!. (diff)
downloadgentoo-2-9767430a0cfcae1ba85074184e6ee372804c7b76.tar.gz
gentoo-2-9767430a0cfcae1ba85074184e6ee372804c7b76.tar.bz2
gentoo-2-9767430a0cfcae1ba85074184e6ee372804c7b76.zip
Version bump of upstream's stable branch.
(Portage version: 2.1_pre5-r2)
Diffstat (limited to 'dev-util/cvs/cvs-1.11.21.ebuild')
-rw-r--r--dev-util/cvs/cvs-1.11.21.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-util/cvs/cvs-1.11.21.ebuild b/dev-util/cvs/cvs-1.11.21.ebuild
new file mode 100644
index 000000000000..47084d266d26
--- /dev/null
+++ b/dev-util/cvs/cvs-1.11.21.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cvs/cvs-1.11.21.ebuild,v 1.1 2006/03/07 09:25:09 pylon Exp $
+
+DESCRIPTION="Concurrent Versions System - source code revision control tools"
+HOMEPAGE="http://www.cvshome.org/"
+SRC_URI="mirror://gnu/non-gnu/cvs/source/stable/${PV}/${P}.tar.bz2
+ doc? ( mirror://gnu/non-gnu/cvs/source/stable/${PV}/cederqvist-${PV}.html.tar.bz2
+ mirror://gnu/non-gnu/cvs/source/stable/${PV}/cederqvist-${PV}.pdf
+ mirror://gnu/non-gnu/cvs/source/stable/${PV}/cederqvist-${PV}.ps )"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc emacs"
+
+DEPEND=">=sys-libs/zlib-1.1.4"
+
+src_compile() {
+ econf --with-tmpdir=/tmp || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ insinto /etc/xinetd.d
+ newins ${FILESDIR}/cvspserver.xinetd.d cvspserver || die "newins failed"
+
+ dodoc BUGS ChangeLog* DEVEL* FAQ HACKING \
+ MINOR* NEWS PROJECTS README* TESTS TODO
+
+ if use emacs; then
+ insinto /usr/share/emacs/site-lisp
+ doins cvs-format.el || die "doins failed"
+ fi
+
+ if use doc; then
+ dodoc ${DISTDIR}/cederqvist-${PV}.pdf
+ dodoc ${DISTDIR}/cederqvist-${PV}.ps
+ tar xjf ${DISTDIR}/cederqvist-${PV}.html.tar.bz2
+ dohtml -r cederqvist-${PV}.html/*
+ cd ${D}/usr/share/doc/${PF}/html/
+ ln -s cvs.html index.html
+ fi
+}
+
+src_test() {
+ einfo "FEATURES=\"maketest\" has been disabled for dev-util/cvs"
+}